Unable to "Select All" in Explorer (file browsing)

Discussion in 'Windows Vista File Management' started by nuge, Feb 17, 2007.

  1. nuge

    nuge Guest

    Hey all - I'm hoping someone can assist me in this terribly annoying glitch
    I've run into. For some reason, it seems I have lost the ability to
    multi-select any files anywhere in my system. I can not currently:

    - Select All (CTRL-A, or via the Edit menu)
    - Ctrl-click multiple files
    - Shift-click an array of files
    - or use hte checkbox option

    to successfully select more than one file/folder at a time. I am currently
    stuck working on a one to one level on all folders/files anywhere on any
    drive. Turns out, I do this fairly often during my work day and this is
    terribly terribly frustrating.

    Did I mention that it was very frustrating? :)

    It doesn't seem to make any difference at what view I'm using (list,
    details, tiles, icons etc.), and I don't remember ever setting anything in
    the Tools -> Folder Options settings that would remotely set this as
    "desired" behaviour. I also can not find anything to clear this behavior
    either.

    Can anyone kindly assist - I'm losing my hair on this one... :(

    Much appreciated,

    Ted

    PS - I'm running Windows Ultimate, with all the latest patches applied.
     
    nuge, Feb 17, 2007
    #1
    1. Advertisements

  2. nuge

    C. L. Guest

    I have the same issue. But it happens randomly, i.e. sometimes "Select All"
    works and sometimes the option was greyed out under "Edit" Menu.
     
    C. L., Feb 17, 2007
    #2
    1. Advertisements

  3. nuge

    C. L. Guest

    To be more specific, even for the same folder, sometimes "Select All" works,
    sometimes it doesn't work.

    I am using Vista Ultimate RTM with latest patches.
     
    C. L., Feb 17, 2007
    #3
  4. I've seen this posted as well. Haven't experienced it -- but I was able to
    induce this behavior in a particular folder by regediting the saved view --
    but even when I tried 'Apply to Folders', it didn't seem to affect others.

    For a particular saved view, which would be in the registry under:

    "HKCU\Software\Classes\Local
    Settings\Software\Microsoft\Windows\Shell\Bags\<Bag#>\Shell\{TemplateUUID}

    in the value named 'FFlags'. The flags are enumerated here:

    http://msdn2.microsoft.com/en-us/library/ms649291.aspx

    The bothersome value is "FWF_SINGLESEL = 0x00000040"

    But none of this explains how Explorer decides this is the default state.

    Some questions:

    Does it occur under all or just one user account?

    Is Explorer set to 'Launch folder windows in a separate process'? (Folder
    Options -> 'View' tab -> 'Advanced Settings')

    Is Explorer set to 'Remember each folders view settings'?

    If you're familiar with using regedit, I'd love to have a look at an export
    of:

    "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer"

    and

    "HKEY_CURRENT_USER\Control Panel\Desktop"

    please e-mail me those if you could.

    It does seem that once a folder has gotten into this mode, it is saved with
    its view settings, so see if the following helps:

    With all explorer windows closed, export & then delete the
    following registry key (this will erase saved folder views):

    "HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags"

    Log off & log back on. See if that fixes it.
     
    Keith Miller MVP, Feb 17, 2007
    #4
  5. Well I have exactly the same problem. Only on the desktop itself it
    is possible to use the mouse to select multiple files, use ctrl -
    click or shift - click. But in every single windows explorer window
    (with or without the tree view) it is only possible to select one file
    at a time.
    I am using the vista default folder settings (except "show hidden
    files and folders", visible file extensions and always have the menu
    bar present).

    this problem seems to be user account specific, since the other two
    accounts on my computer (an extra admin account and a normal user
    account) this problem does not occour (yet)

    i installed vista 14 days ago and i noticed this behavior appr 1 week
    ago, before that it was possible to select multible files/folders in
    any explorer window.

    since im not that good at manually tweaking the regestry, i used a
    program called tweakVI for doing some customization of windows. even
    that I am pretty shure i didnt tweak any folder realated stuff, is it
    possible that this program could have anything to o with my current
    problem?

    Tried deleting "HKCU\Software\Classes\Local Settings\Software\Microsoft
    \Windows\Shell\Bags" and lock off and back on agian, but with no luck.
    a reboot did not help either.

    if those still are needed, i have made an export of:
    "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer"
    and
    "HKEY_CURRENT_USER\Control Panel\Desktop"

    I took a look at those exports in notepad, but except for some of the
    more general settings i was unable to make hands and tails of the
    content :)

    I hope my description help bring some light to this selecting problem.
    Help is highly welcome

    n4yp.formator


    Keith Miller MVP skrev:
     
    n4yp.formator, Feb 19, 2007
    #5
  6. Please e-mail me those reg files -- change their extension to .txt to make
    sure they get through.

    If you happened to use 'Apply to Folders' when this was in effect (but
    before you realized it :), then the behavior could perpetuate through that,
    those settings aren't stored under 'Bags'

    So, try this:

    Close all Explorer windows.

    Open Regedit.

    Any folders you viewed since the last deletion have created new Bags, so
    delete that key again.

    Navigate to:

    "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Streams\Defaults"

    and delete that key.

    Delete the value named 'Settings' found under 'HKCU\...\Streams'

    Log off & log back on.

    Hope that gets it!!!


    --
    Good Luck,

    Keith
    Microsoft MVP [Windows XP Shell/User]

     
    Keith Miller MVP, Feb 19, 2007
    #6
  7. nuge

    hsieg Guest

    Thanks... The exact same thing happened to me this morning and your tip
    solved the problem (not the first one though, needed the whole thing). No
    idea what caused the thing in the first place. At the time it happened, I had
    two opened explorer windows and it only happened in one of them. I tried a
    reboot, just in case, and it then occurred in each and every window I
    opened...

    In any case, thanks a lot, I'll save this tip somewhere just in case it
    happens again.
    Hsieg.

     
    hsieg, Feb 22, 2007
    #7
  8. You're welcome.

    --
    Good Luck,

    Keith
    Microsoft MVP [Windows XP Shell/User]

     
    Keith Miller MVP, Feb 22, 2007
    #8
  9. nuge

    nuge Guest

    Hi there - I've attempted deleting the "bags" key in the registry, and also
    followed the other step to clear the defaults key under Streams as well.

    However I'm still experiencing the inability to select more than one file in
    some folders. Switching to another user however does allow me to select
    multiple files on the same folder. (not practical in terms of solving the
    problem tho).

    I'm very perplexed on what to do to resolve this, it is getting more
    frustrating - can you recommend my next step?

    Much appreciated!

    Ted







     
    nuge, Feb 26, 2007
    #9
  10. Sorry I didn't catch this post earlier.

    If your still experiencing this behavior, I'd be grateful if you could send
    me a registry export of:

    "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer"


    --
    Good Luck,

    Keith
    Microsoft MVP [Windows XP Shell/User]

     
    Keith Miller MVP, Mar 1, 2007
    #10
  11. @Keith Miller: As for myself, i have solved the problem using your
    advise, thanks again. @nuge: try also doing the regtweaks Keith
    mentioned later in this thread (see the quote below), that solved the
     
    n4yp.formator, Mar 3, 2007
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.