Unidentified Network, Access: Local Only

Discussion in 'Windows Vista Networking' started by teksonic, Mar 29, 2007.

  1. teksonic

    teksonic Guest

    I have a new build PC with an ASRock AM2NF6G-VSTA motherboard which installed
    Vista Home Premium perfectly. Device manager is not reporting any problems.

    I am hard wired through a DLink 614+ cable router which works fine with my XP
    computers, but my Vista PC won't connect, I just get UNIDENTIFIED NETWORK,
    ACCESS: LOCAL ONLY

    I get a good IP address on IPv4, 192.168.0.101, which is obtained
    automatically, but I can't ping the router or access the router interface
    through IE.

    I have run the router evaluation tool "
    http://www.microsoft.com/windows/using/tools/igd/default.mspx" from my XP PC
    with good results.

    I am tearing my hair out, (what little remains).

    Can anyone help?

    Duncan
     
    teksonic, Mar 29, 2007
    #1
    1. Advertisements

  2. Duncan, I assume you have 2 machines connected to your router (an XP
    machine and a Vista machine). Can these machines see each other?

    When they are both connected to the router, the xp machine gets to the
    internet OK, but the vista does not. To me, this indicates some wackiness
    with the config on the vista system. Have you tried the "Diagnose and
    Repair" option? right-click on the network Icon, and select "Diagnose &
    repair".

    I've tested with the DI-614+, and it worked for us (I know, I know...).
    ensure your router has the latest firmware from dlink (ver 2.34, dated 3/06)
    from http://support.dlink.com/products/view.asp?productid=DI-614+.

    K.
     
    Karl Froelich [MS], Mar 29, 2007
    #2
    1. Advertisements

  3. Do you have protected your network with a MAC filter? It seems to me that
    maybe the router rejects the connection from your Vista PC. Look at the
    router configuration menue from your XP PC for the MAC filter and switch it
    off.

    Are there any errors logged on your router?

    Ursula
     
    Ursula Schreiber, Mar 29, 2007
    #3

  4. Addendum to original post

    I have upgraded the firmware on the router to the latest version.

    I have now installed a wireless adapter on the Vista PC and this networks
    perfectly with my 2 XP PC's through the DI-614+ router. Which proves the
    router is OK with Vista (am I right?)

    However, I still have the original problem when I connect the onboard NIC.
    ie Unidentified Network, Access: Local only

    This is leading me to suspect that maybe the NIC is not compatible with Vista,
    even though Vista is saying it is working properly. So my next step is
    install a PCI NIC and see what happens. I will report back

    Duncan
     
    teksonic via WindowsKB.com, Mar 29, 2007
    #4

  5. As promised, I am reporting back.

    I have installed a PCI NIC and guess what, all is OK. So it even though the
    onboard NIC is reporting as "This device is working properly" there must be a
    driver issue with the onboard NIC as regards Vista.

    For your information, the problem NIC is :
    Nvidia nForce Networking Controller
    Driver file - nvm60x32.sys
    Driver ver - 6.2.0.126

    Duncan
     
    teksonic via WindowsKB.com, Mar 31, 2007
    #5
  6. teksonic

    Crito Guest

    I have the exact same mobo with 405 chipset and the exact same problem.
    The lastest ForceWare 15.0 drivers don't work either. So despite all the
    Vista ready logos on my mobo's box I can't even get on the internet to
    register the [email protected]#$ thing. :mad:

    I popped in a Fedora Core 6 DVD instead and it detected my NIC during
    setup, allowing me to add some programs from the "extras" repository
    before first boot even. It also detected and installed drivers for my
    five year old Hauppague TV card which Vista still doesn't recognize.

    If only Windows was as easy to install as Linux. :D
     
    Crito, May 3, 2007
    #6
  7. teksonic

    Crito Guest

    I flash upgraded my BIOS to version 1.60 which was released a few weeks
    ago. Upon rebooting into Vista everything was redetected by still no
    network. Looks like I'm going to have to do same thing you did and just
    pop in another NIC. :mad: Works perfectly under Linux though. :D^2

    Oh, and turns out my mobo is actually the Asrock K8NF6G-VSTA which has
    a 754 socket instead of AM2. They both use the same nForce 405 chip
    though.

    'ASRock Motherboard - Download'
    (http://www.asrock.com/support/Download.asp)
     
    Crito, May 5, 2007
    #7
  8. teksonic

    Crito Guest

    Well, I got so pissed off I went into device mangler and unistalled th
    NIC, telling it to delete all the nVidia driver software in the process
    I then redetected devices and it installed the original Microsof
    driver, which NOW WORKS!

    So I guess the soultion is flash your BIOS to latest version and us
    MS' driver, not nVidia's. ;
     
    Crito, May 8, 2007
    #8
  9. teksonic

    aareleb Guest

    Hello, I just build a new PC with a Am2NF6G-VSTA Asrock Mobo runnin
    windows vista 64 bit Home Premium, im unable to find vista 64x driver
    for the NIC. Does anyone know if there are any drivers yet or of a goo
    NIC that I can install to replace it
     
    aareleb, Feb 11, 2008
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.