"Unidentified network", can't turn on sharing

Discussion in 'Windows Vista Networking' started by Mike Gilbert, Sep 27, 2006.

  1. Mike Gilbert

    Mike Gilbert Guest

    My home PC has an ASUS motherboard with two embedded LAN ports. One is
    connected to Comcast internet (directly, not through a router) and the other
    is connected to a small home LAN with Vonage and a couple of other devices on
    it. I use ICS through my home PC to let my home lan devices access the
    internet.

    When I install Vista RC1, the Internet works fine. But my home network
    shows up as "Unidentified network". I can change it to Private, but I can't
    rename it to Home LAN - the name Unidentified Network is read-only.

    When I try to turn on file or printer sharing, I get a popup that asks
    whether I want to set my network to be private or turn on sharing for public
    networks. I don't want to do either! I want to turn on sharing for my home
    lan AKA the Unidentified Network (already private), but I can't do this.

    Another strange symptom is that the diagram at the top of the network and
    sharing center says my pc->(multiple networks)->Internet. This is wrong and
    if I look at the two networks listed below, only the Internet network says
    Local and Internet - the Unidentified Network is local only.

    The embedded 3com chipset behind my home LAN has drivers loaded, apparently
    correctly - I can ping the other devices on my home network just fine. But
    something is obviously wrong.

    Does anybody know what Unidentified network means? Are there any setting
    changes I can try or any useful guides I can read on Technet or someplace
    that might help me get to the bottom of this?

    I'd hate to see Vista go Gold with this sort of problem. I submitted a bug
    report but that's a write-only mechanism, so I'm looking for advice in this
    newsgroup.

    Thanks for any help you can give me.
     
    Mike Gilbert, Sep 27, 2006
    #1
    1. Advertisements

  2. Had similar problem after RC-1 install. Ran through all troubleshooting
    procedures. Finally stumbled on following suggestion in Vista Help:

    "Turn off the power-saving option in the network adapter's properties (wired
    network adapters only)"

    Checked out the adapter properties and power saving option was indeed turned
    on. Cleared the check box, and my home network magically appeared.
    (but it is still named "Unidentified Network" !)
     
    Harry Sherman, Sep 30, 2006
    #2
    1. Advertisements

  3. Mike Gilbert

    Mike Gilbert Guest

    Thanks Harry. I tried your suggestion, but it didn't work for me. My
    network is on and working, but it's called "Unidentified Network". My main
    complaint is I can't turn on file or printer sharing without turning it on
    for my Internet connection NIC as well!
     
    Mike Gilbert, Oct 9, 2006
    #3
  4. Mike Gilbert

    Paul Smith Guest

    I have RTM and it's still not fixed. You can not have the Internet connection
    set to Public, your other LAN set to Private and File Sharing turned on.
    Also, pc->(multiple networks)->Internet happens with RTM as well.
     
    Paul Smith, Nov 21, 2006
    #4
  5. Mike Gilbert

    Paul Smith Guest

    In the mean time, I went into the Control Panel->Network Center->Manage
    Network Connections, selected my internet LAN card, Properties, and then
    disable Client for Microsoft Networks + File and Printer Sharing

    PS: I have and ASUS as well :)
     
    Paul Smith, Nov 21, 2006
    #5
  6. Mike Gilbert

    Mike Gilbert Guest

    Paul,

    Thanks for the update. I haven't had a chance to install RTM yet, so I'm
    sorry to hear your report.

    I wish Microsoft would read these threads and give us advice on fixing the
    problem, or at least help us understand what's happening!
     
    Mike Gilbert, Nov 22, 2006
    #6
  7. Mike Gilbert

    VB Rye Guest

    It's all very odd, I have Gigabyte nForce 430 with built in LAN and it comes
    up with unidentified network Nvidia have drivers for Vista dated 06/02/2007
    and still no network. Best thing I did is buy a £7.00 Realtec card and it
    works a treat. Come on Microsoft/hardware vendors it not like Vista was a
    surprise.
     
    VB Rye, Feb 12, 2007
    #7
  8. Mike Gilbert

    csroman Guest

    Ditto for me. Nforce 430 motherboard, wireless access works fine,
    realtek nic works fine, but motherboard lan controller no go.
    I was puzzled, but found someone had posted a review to Newegg (where
    I bought motherboard) and said the lan controller worked fine with XP,
    does not work with Vista.
     
    csroman, Feb 27, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.