Unistalling trial version and installing non-trial

Discussion in 'Virtual PC' started by Craig_S, Feb 1, 2005.

  1. Craig_S

    Craig_S Guest

    I downloaded the 45-day trial of the Virtual (t-v) PC 2004. With
    satisfaction I purchased the nontrial version to install on my Windows XP
    SP-1 pc. When I tried to installed the non-trial version (n-tv) I got a
    Fatal Error - Installer must exit window with the message saying. You must
    uninstall previous versions of Virtual PC Trial before installation. This
    application will now quit.

    So I did just that using the Add/Remove programs in CNTL Panel to remove the
    app and even removed all entries of the t-v in the registery with the same
    results. Can someone help me so that I can install this application.

    Thanks.
     
    Craig_S, Feb 1, 2005
    #1
    1. Advertisements

  2. OK, you got the trial version uninstalled. Reboot and install the retail
    version.
     
    Colin Barnhorst, Feb 1, 2005
    #2
    1. Advertisements

  3. Craig_S

    Craig_S Guest

    I did as you requested and rebooted the workstation, but now I get this error:
    Error -1607: Unable to Install InstallShield Scripting Run Time


     
    Craig_S, Feb 1, 2005
    #3
  4. Here are a couple of links:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;888019
    http://support.microsoft.com/default.aspx?scid=kb;en-us;831507



    --
    Colin Barnhorst [MVP Windows - Virtual Machine]
    (Reply to the group only unless otherwise requested)
     
    Colin Barnhorst, Feb 1, 2005
    #4
  5. Craig_S

    Craig_S Guest

    I tried the links as you suggested and sorry to say I'm no closer to
    resolving this than before. So I tried restoring my OS from a image to start
    the process again. I uninstalled the trial version of VPC and rebooted the
    computer. Once that was done, I tried to reinstall the bought product and
    got the Fatal Error - Installer must exit window with the message saying.
    You must uninstall previous versions of Virtual PC Trial before installation.
    This application will now quit.

    Am I still missing something?


     
    Craig_S, Feb 1, 2005
    #5
  6. Craig_S

    SujitUk Guest

    Hi Craig,
    I would like to suggest you to try out this link and download the WIndows
    Installer Cleanup utility.
    http://support.microsoft.com/default.aspx?scid=kb;en-us;290301
    When you run this utility it would show a list of Installed packages on the
    computer. and there is a option to remove the packages which do not have
    their registry entries completely flushed. I have a feeling that the
    uninsallation of the trial version of the Virtual PC is not removing some of
    the registry entries and the full version checks for those entries and tells
    that you have to uninstall it.

    So use this utlity to flush any remaining entries and then try to install
    the full version. Hope this information helps.

     
    SujitUk, Feb 2, 2005
    #6
  7. Craig_S

    Craig_S Guest

    SujitUK,

    I downloaded the Windows Installer Cleanup utility as you suggested. After
    installing the app I restarted my PC and launched the application. I went
    through the entire list of applications available for clean-up and
    unfortunately the Virtual PC software was not part of that list. I tried
    reinstalling the trial version again rebooted then ran the Clean up utility.
    It did list the application, I ran the clean-up against it and noticed that
    VPC Trial version was still listed under Programs, but it was not listed
    under the Add/Remove programs in the CNTL Panel. Again I tried to install
    the retail version and came up with the same Fatal Error as before.



     
    Craig_S, Feb 2, 2005
    #7
  8. Craig_S

    Daryl Guest

    I also have this same problem I have tride everything that you have and then
    some there is only one system that i have seen this on is a dell 2350 if
    anyone has any idea's please let us know

     
    Daryl, Feb 22, 2005
    #8
  9. Craig_S

    Craig_S Guest

    I finally got a solution after talking to 3 different MS Tech-support people
    over the phone. First I uninstalled the VPC 2004 then I had to go into
    'REGEDIT' and branch down to thru the following trees:
    HKEY_LOCAL_MACHINE
    SOFTWARE
    Microsoft
    Windows
    CurrentVersion
    Uninstall
    Once I got to this section, the right portion of that window shows the REG
    types and one of the entries there said "Microsoft Virtual PC 2004 Trial". I
    had to delete the entire registry entry. Mine was labeled
    {279D84F-4FB6-B0BB-0B81C053F210} it may be different for others because the
    1st phone support tech told me to look for a different register entry (could
    have avoided the extra calls if he had told me just to search for "Virtual
    PC" as oppose to a specific entry).

    Anyway that was my solution. I hope this works for you. No one should have
    to go thru all that.

    --Craig





     
    Craig_S, Feb 23, 2005
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.