Unrecognized option when we using "slmgr -skms" with Windows 2008 Server ?

Discussion in 'Windows Server' started by Patrick, Aug 4, 2009.

  1. Patrick

    Patrick Guest

    We has set up a Windows 2008 Server as KMS Host in our site.

    When we set up another Windows 2008 Server and use "slmgr -skms" to set the
    KMS Host, we get the error message that Unrecognized option: -skms

    We have searched the web and in one of the posting, someone mention that in
    the slmgr.vbs, there are two different string, one is "VOLUME_KMS_CLIENT"
    that is able to use the "slmgr -skms" command and our one is with the
    "VOLUME_KMS_B Channel" string.

    We install both Windows 2008 with the same VLM CD. Is it the problem in our
    case ? Your advice is sought.

    Thanks
     
    Patrick, Aug 4, 2009
    #1
    1. Advertisements

  2. Hello Patrick,

    Do you use an elevated command prompt with RUNAS?

    slmgr.vbs -skms yourservername.domain.com:portnumber

    Best regards

    Meinolf Weber
     
    Meinolf Weber [MVP-DS], Aug 4, 2009
    #2
    1. Advertisements

  3. Meinolf Weber [MVP-DS], Aug 4, 2009
    #3
  4. Patrick

    Patrick Guest

    Dear Meinolf,

    No. I have no idea of what RUNAS is. I will search the web and tried
    again.

    Parick
     
    Patrick, Aug 4, 2009
    #4
  5. Hello Patrick,

    Logged on as the administrator or domain admin open the command prompt from
    the start menu, Accessoires and rightclick the command prompt, there choose
    RUNAS Administrator.

    Best regards

    Meinolf Weber
     
    Meinolf Weber [MVP-DS], Aug 4, 2009
    #5
  6. Patrick

    Patrick Guest

    Dear Meionlf,

    Thank you for your advice. I have tried but still no good.

    On the other hand, I am able to connect via "slmgr user password KMSHost".
    However, when I run "slmgr -ato", it seems that the new Windows 2008 Server
    becomes another KMS Host.

    Thanks
    Patrick
     
    Patrick, Aug 5, 2009
    #6
  7. Patrick

    annanym

    Joined:
    Aug 20, 2009
    Messages:
    1
    Likes Received:
    0
    Hello,

    have yout tried to restart the licensing service?

    net stop slsvc && net start slsvc

    after I had started the licensing service again the skms option was not unrecognized anymore.

    regards annanym :rolleyes:
     
    annanym, Aug 20, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.