Update Rollup 1 for W2K (KB891861) ad-infinitum... (Error 0x800700

Discussion in 'Update Services' started by Pablo Cardoso, May 25, 2006.

  1. Hello everyone,

    On my WSUS Server, there is an update (KB891861) that cannot get installed
    on 2 WIN2K clients. It seems like this update keeps reappearing on these
    machines not matter what I do.

    I have removed this update from Windows (by using Add/Remove Apps) and
    installed the offline package downloaded straight from Microsot website - got
    the same result. I've looked at WSUS Wiki 80070005 error page but I've
    followed those instructions about dmconfig and also got the same result.

    When I click on the "Status -> Needed" on one of those 2 clients, I can see
    that this update is installed every other day. Sometimes it comes out as an
    error with that code (0x80070005), most of the time it gets installed with
    code 0x00000000. In the end, this update gets stuck - ad-infinitum...

    Can anyone help me figure out this error?

    Thanks in advance!
     
    Pablo Cardoso, May 25, 2006
    #1
    1. Advertisements

  2. Pablo Cardoso

    Ken Guest

    Have you tried deleting the software distribution folder on those two
    machines, it could possibly be corrupt.

    1. Stop the Automatic Updates Service
    2. Rename "%Windir%\SoftwareDistribution" folder
    3. Start Automatic Updates Service

    Run this command: wuauclt /resetauthorization /detectnow

    Or some people say you can just delete the sofware distribution folder and
    restart the machine, which will create a new one.
     
    Ken, May 25, 2006
    #2
    1. Advertisements

  3. Have you tried deleting the software distribution folder on those two
    Yeap, tried and got the same error. The problem isn't related to a
    corrupt download folder...

    Also, I've tried to remove every Windows' Hotfix that I could find on
    "Add/Remove Apps" and reinstall everything from my WSUS server... The
    same error has occurred! I can't believe this...

    So, what now?! Thanks again for your help, Ken!


    Here's a snip from the user's WindowsUpdate.log (I've trimmed it a little):

    Misc =========== Logging initialized (build: 5.8.0.2469, tz: -0300)
    ===========
    Misc = Process: C:\WINNT\system32\wuauclt.exe
    AUClnt Launched Client UI process
    AUClnt AU client got new directive = 'Install Approval', serviceId =
    {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, return = 0x00000000
    AUClnt AU client creating default WU/WSUS UI plugin
    AU AU setting client response for sessionId 0x0 to 'Pending'
    Report REPORT EVENT: {6C43BDC9-B5AE-44C0-B8D4-B5E3C6B0A01A}
    101 {00000000-0000-0000-0000-000000000000} 0 0 AutomaticUpdates Success
    Software Synchronization Agent has finished detecting items.
    Report REPORT EVENT: {01F43586-922B-4274-BC85-33A41995328A}
    101 {00000000-0000-0000-0000-000000000000} 0 0 AutomaticUpdates Success
    Pre-Deployment Check Reporting client status.
    AU AU setting client response for sessionId 0x0 to 'Active'
    AU AU received install approval from client for 1 updates
    AU #############
    AU ## START ## AU: Install updates
    AU #########
    AU # Initiating manual install
    AU # Approved updates = 1
    AU <<## SUBMITTED ## AU: Install updates / installing updates [CallId =
    {FCB502D7-8770-4B2E-BFFD-2B0EC92A66DE}]
    Agent *************
    Agent ** START ** Agent: Installing updates [CallerId = AutomaticUpdates]
    Agent *********
    Agent * Updates to install = 1
    Agent * Title = <NULL>
    Agent * UpdateId = {70ABEBD2-F515-4BD4-8683-0796F949792F}.103
    Agent * Bundles 1 updates:
    Agent * {511C66F0-5B67-49FD-8E31-25E873A33C7A}.102
    Handler Attempting to create remote handler process as WORKGROUP\user in
    session 0
    DnldMgr Preparing update for install, updateId =
    {511C66F0-5B67-49FD-8E31-25E873A33C7A}.102.
    Misc =========== Logging initialized (build: 5.8.0.2469, tz: -0300)
    ===========
    Misc = Process: C:\WINNT\system32\wuauclt.exe
    Misc = Module: C:\WINNT\system32\wuaueng.dll
    Handler :::::::::::::
    Handler :: START :: Handler: Windows Patch Install
    Handler :::::::::
    Handler : Updates to install = 1
    Handler : Installing update {511C66F0-5B67-49FD-8E31-25E873A33C7A}.102
    Handler Installing with parameters=-q /Z -ER,
    sandbox=C:\WINNT\SoftwareDistribution\Download\fdf1194a76f6ff20224de204ff25e47f.
    AU AU setting client response for sessionId 0x0 to 'Active'
    Handler Install completed with 0x80070005.
    Handler FATAL: UH: 0x80070005: InstallOrUninstallThread failed
    Handler : WARNING: Install completed: result type = 0x0, installer
    error = True, error = 0x80070005, disabled until reboot = No, reboot
    required = No
    Handler FATAL: UH: 0x8024200b: HandleSingleUpdate failed
    Handler :::::::::
    Handler :: END :: Handler: Windows Patch Install
    Handler :::::::::::::
     
    Pablo Cardoso, May 25, 2006
    #3
  4. Pablo Cardoso

    Ken Guest

    The error in your log 0x80070005 = "Error Access Denied" per Mr. Garvin's
    website, so could this be some type of folder permissions issue ?

    The other error 0x8024200b = SUS E UH INSTALLER FAILURE - Again this could
    be related to permissions, but the error message is a little cryptic to me.

    Maybe Lawrence Garvin - MVP will jump in and help here. It would be nice to
    understand the cause of the issue, you could reload the machine but if you
    are like me you want to know what the cause is.

    Thanks

     
    Ken, May 26, 2006
    #4
  5. The error in your log 0x80070005 = "Error Access Denied" per Mr. Garvin's
    Maybe it is, but Microsoft could made our lives a lot easier if they
    simply told us which folder WUAU client is trying to access and getting
    this error instead of just a code. Go figure...
    Yeah, I thought so. I've run dcomcnfg and added both the local
    Administrator and SYSTEM accounts to the properties of "Windows Update
    Client" and "Windows Update Client - Remote Access" but again the result
    is the same.

    Today this update appeared again on my WSUS server as "Needed" by the
    same computer...
    That is true. I hate when it comes to the point where "format c: /y"
    seems to be the only solution! My guess is that this user has many
    (20~30) softwares installed and maybe one of them has messed up DCOM's
    properties... The funny thing is that both WSUS and offline installation
    of this patch give the same "The update was applied successfully" screen.

    BR,
    Pablo
     
    Pablo Cardoso, May 26, 2006
    #5
  6. Because the WUA client and AU service run under the context of the Local
    System account, an Access Denied error while installing an update via the
    WUA would be an indication that something/someone has removed access
    permissions for the Local System account to some resource that is needed.

    A workaround would be to download the affected update(s) from the Microsoft
    Download Center and install them in the context of a logged on Administrator
    account.

    In the meantime, the only other solution is reconciling the access
    permissions for the SYSTEM account.

    --
    Lawrence Garvin, M.S., MVP-Software Distribution
    Everything you need for WSUS is at
    http://technet2.microsoft.com/windowsserver/en/technologies/featured/wsus/default.mspx
    And, eveything else is at
    http://wsusinfo.onsitechsolutions.com
    ....
     
    Lawrence Garvin \(MVP\), May 26, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.