UpdateRollup2 crashes ehshell.exe.

Discussion in 'Windows Media Center' started by Alan, Oct 14, 2005.

  1. Alan

    Alan Guest

    Help...
     
    Alan, Oct 14, 2005
    #1
    1. Advertisements

  2. Uninstall it from Add/Remove Programs. Otherwise, please provide more information, such as your hardware configuration and the exact text of the error message.
     
    Doug Knox MS-MVP, Oct 14, 2005
    #2
    1. Advertisements

  3. Alan

    Alan Guest

    Hi Doug:

    I just finished uninstalling and reinstalling that update. First update,
    then returned and updated the second rollup2 update. I waited 10 minutes in
    between with no activity. Hardware?..hm...not sure what you need, but its a
    Dell XPS with a 3.8 proc, 2 gig mem, Radeon X850 Plat Ed, twin DVD burners,
    19 inch DVI flat panel with WinXP MCE 2005. The error comes up the second you
    try and watch the TV part, says "Creating Crash report" then sends it. l can
    copy it to Paint if you like.

    Thank you for helping :eek:)
     
    Alan, Oct 14, 2005
    #3
  4. Ok, I know this is going to sound like a stupid question, but did you reboot after the updates? I know, I know, but I got distracted when I did the install on one of my machines and told it I'd reboot later. Well, I didn't and tried to start MCE and got the same behavior you did.

    If the problem continues, try just uninstalling the Update Rollup 2 updates, don't reinstall and see if everything works normally.

    --
    Doug Knox, MS-MVP Windows Media Center\Windows Powered Smart Display\Security
    Win 95/98/Me/XP Tweaks and Fixes
    http://www.dougknox.com
    --------------------------------
    Per user Group Policy Restrictions for XP Home and XP Pro
    http://www.dougknox.com/xp/utils/xp_securityconsole.htm
    --------------------------------
    Please reply only to the newsgroup so all may benefit.
    Unsolicited e-mail is not answered.

     
    Doug Knox MS-MVP, Oct 14, 2005
    #4
  5. Alan

    Alan Guest

    Back Again:

    I ran the program again, here what the error said:
    Title: ehshell.exe-Common Langauge Runtime Debugging Services
    Texted:Application has generated an exception that could not be handled.
    Procedd id: 0x522(5420), Thread id=0xda8(3496)

    Then it generates a crash report and sends it.

    Also, regarding the hardware....last friday I installed a new Logitech
    bluetooth Keyboard/mouse...The MX 5000 Laser. It came with new software for
    it's bluetooth, and l think modified WinXP's version of bluetooth. l have no
    clue if that helps out...

    Thanks again.
    --
    Alan :)


     
    Alan, Oct 14, 2005
    #5
  6. Alan

    JW Guest

    Before you installed the first Rollup2 update did you make the cheks
    concerning .NET Framwork as stated in the following Link?

    http://support.microsoft.com/?kbid=900325

     
    JW, Oct 14, 2005
    #6
  7. Alan

    Alan Guest

    Yes, l did reboot...several times with each install. Also, if l go to
    MCE/setting/TV...it tells me l have no tuner installed. I am positive that
    there is one in there somewhere, because before this morning, l could watch
    TV on this computer.
     
    Alan, Oct 14, 2005
    #7
  8. Alan

    Alan Guest

    After I uninstalled the Update Rollup 2 the first time, l did try MCE to see
    if it worked. It did work the same as it did prior to the update.
     
    Alan, Oct 14, 2005
    #8
  9. I can't think of any reason that Bluetooth would cause this problem. Are there any 3rd party Media Center apps (More Programs) installed? Other than the defaults?
     
    Doug Knox MS-MVP, Oct 14, 2005
    #9
  10. If its not detecting your tuner(s) try removing/reinstall those in Device Manager. And while it shouldn't be necessary, check the manufacturer's web site and see if they have an updated driver just for Rollup 2.

    --
    Doug Knox, MS-MVP Windows Media Center\Windows Powered Smart Display\Security
    Win 95/98/Me/XP Tweaks and Fixes
    http://www.dougknox.com
    --------------------------------
    Per user Group Policy Restrictions for XP Home and XP Pro
    http://www.dougknox.com/xp/utils/xp_securityconsole.htm
    --------------------------------
    Please reply only to the newsgroup so all may benefit.
    Unsolicited e-mail is not answered.

     
    Doug Knox MS-MVP, Oct 15, 2005
    #10
  11. Alan

    Alan Guest

    Yes, it has WMP 10.0, MusicMatch OnDemand, and some others l never use. As
    for .NET updates, l believe it has them all. When l go to MSFT Update, there
    are no updates of any kind available(except the different lanaguge versions).
    So, l always figure it's updated.
     
    Alan, Oct 15, 2005
    #11
  12. Alan

    Alan Guest

    Yes, it has all 3 .NET updates. No other updates show up in eith MSFT Update
    or Office Update.
     
    Alan, Oct 15, 2005
    #12
  13. Alan

    Alan Guest

    well...getting a bit frustrated now..

    I checked the .NET updates, there was one .NET 1.1 hotfix with the ending
    numbers of 03, not 04. l unistalled that anyway to see if it helped. Then
    uninstalled Upate Rollup 2. then rebooted. Then check to see if MCE worked,
    it seemed to, althought there was no volume (sound output) this time. I went
    back to the MSFT Update site, and followed the instructions it gave me, in
    addition to the Support site that JW had listed. Then returned after the
    Rollup2 update, and downloaded the second Rollup2 and .NET Hotfix...again. I
    checked the Dell site too, no other drivers are currently available. Now when
    l start MCE, l get the same error message, but with a slightly different
    process and thread location. How do l fix this mess?? And System Restore will
    not return it to yesterday for some reason either...

    Thank you for all your help.
    --
    Alan :)


     
    Alan, Oct 15, 2005
    #13
  14. Alan

    dalkar Guest

    I have experienced a similar problem with my Gateway. I got the same
    original error message with the ehshell.exe you received. When I rebooted
    Windows it got "hung" on the Windows XP screen. Uninstalling the update
    didn't help; I wound up doing a system restore. I then tried uninstalling
    the ".....03" hotfix, and when prompted to reboot, the Windows XP screen hung
    again. So, back to my earlier system restore, which seems to have worked in
    my case. So, sounds like I need to forget the rollup unless someone has any
    suggestions!
     
    dalkar, Oct 15, 2005
    #14
  15. Alan

    Mike C. Guest

    Mike C., Oct 15, 2005
    #15
  16. Alan

    Al Lounsbury Guest

    OK - I have bad things in the log that include:

    Executing line "C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\ngen.exe
    /nologo /delete ehiwmp"
    Warning: Process Return Value is 0xc0000139 --> (null)
    Error: Failed to apply command to ehiwmp (return value: 0xc0000139).

    Executing line "C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\ngen.exe
    /nologo /delete ehiExtCOM"
    Warning: Process Return Value is 0xc0000139 --> (null)
    Error: Failed to apply command to ehiExtCOM (return value: 0xc0000139).

    Now what? And this is true blue HP873N Media Center Computer!

    Al
     
    Al Lounsbury, Oct 15, 2005
    #16
  17. Alan

    Al Lounsbury Guest

    Well - it was worth a try but same error as Alan B - Entry point not found.

    Will try uninstalling this update, then reload .net 1.1 and start over -
    again!
     
    Al Lounsbury, Oct 15, 2005
    #17
  18. Alan

    Alan Guest

    Hello MCE Folks:

    I have come to realize that this Update Rollup2 for MCE 2005, simply will
    not work with this video card today. The ATI site does list a new driver, new
    as of Oct 12th, 2005, for the Radeon X850 XT Plat. Ed., but that driver is
    already installed on this computer. After calling Dell XPS Support, and
    spending 2 hours on the phone with them...they were unable to get it to work
    either, although they did say l wasn't the only call on this issue. The
    reason is, it just does'nt work. 5 attempts were made to to install this
    update, and all failed, even with everyone heres' input. I appreciate
    everyone's help and support, and l thank you. I have now uninstalled Update
    Rollup2 for MCE 2005 and managed to restore the system back to a somewhat
    working order. I will wait until Microsoft and the leading video card
    manufactuers can get together and make this update work before l waste
    another day trying to install it. It's a bit discouraging to have these types
    of issues when you are supposed to be dealing with the flagship products from
    3 major manufactuers, Microsoft, Dell, and ATI. I will also wait to purchase
    the X-Box 360 now, because l do want it to be 'full featured', as claimed.
    And yes, it's true l'm not Bill Gates over here, but hey....Updates should
    not be rocket science.

    Thanks again Everyone, if l knew where to post the complications l
    experienced today for the Microsoft folks that work on this, l surely would.
     
    Alan, Oct 15, 2005
    #18
  19. Alan

    Greg Guest

    I'm getting the exact same errors on a Dell 9100, 2 Gig Ram, 250GB Drive,
    Emuze Angel MPEG card

    I've tried to roll back as well, however, the problem persists.

    ehsshell.exe "Application has generated an exception that could not be
    handled"
    and/or I get a message indicating that there is no card available.
     
    Greg, Oct 15, 2005
    #19
  20. Alan

    Alan Guest

    MCEDude....um...Dude..

    l can open those files, but really...it might as well be written in
    pre-Jesus Hebrew, because l have zero understanding of what that says in
    there... Chances are high l could copy them and email them somewhere, if l
    had and email address to mail them too. Just a thought, albeit a small one...
     
    Alan, Oct 15, 2005
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.