Upgrade error WSUS2 to WSUS3

Discussion in 'Update Services' started by Kevin Severud, May 1, 2007.

  1. Trying to upgrade from WSUS v2 to v3 I'm getting the following errors:

    2007-05-01 11:37:05 Success MWUSSetup Validating pre-requisites...
    2007-05-01 11:37:05 Error MWUSSetup Failed to determine if an
    higher version of WSUS is installed. Assuming it is not... (Error 0x80070002:
    The system cannot find the file specified.)
    2007-05-01 11:37:10 Success MWUSSetup ReportViewer is not
    installed on this machine
    2007-05-01 11:37:10 Success MWUSSetup ReportViewer is not
    installed on this machine
    2007-05-01 11:37:23 Success MWUSSetup SQL version is not Yukon.
    Yukon version 9.00.2047. SQL instance version 8.00.2039
    2007-05-01 11:37:38 Success MWUSSetup Creating database backup...
    2007-05-01 11:45:09 Success MWUSSetup Uninstalling the selfupate
    tree...
    2007-05-01 11:45:32 Error MWUSSetup
    CUpgradeDriver::performSetup: Failed to get group name for SID
    S-1-5-21-1898450891-931487451-618671499-3085 (Error 0x00000534: No mapping
    between account names and security IDs was done.)
    2007-05-01 11:45:34 Success MWUSSetup Setup completed successfully
    2007-05-01 11:52:10 Success MWUSSetup Validating pre-requisites...
    2007-05-01 11:52:10 Error MWUSSetup Failed to determine if an
    higher version of WSUS is installed. Assuming it is not... (Error 0x80070002:
    The system cannot find the file specified.)
    2007-05-01 11:53:00 Success MWUSSetup SQL version is not Yukon.
    Yukon version 9.00.2047. SQL instance version 8.00.2039
    2007-05-01 11:53:03 Success MWUSSetup Creating database backup...
    2007-05-01 12:00:23 Success MWUSSetup Uninstalling the selfupate
    tree...
    2007-05-01 12:00:23 Error MWUSSetup RemoveSelfupdate20:
    SelfUpdateTree Uninstall Failed (Error 0x80070645: This action is only valid
    for products that are currently installed.)
    2007-05-01 12:00:23 Error MWUSSetup
    CUpgradeDriver::performSetup: Uninstall of selfupdate failed (Error
    0x80070645: This action is only valid for products that are currently
    installed.)
    2007-05-01 12:00:23 Error MWUSSetup CSetupDriver::LaunchSetup:
    Setup failed (Error 0x80070645: This action is only valid for products that
    are currently installed.)
    2007-05-01 12:05:37 Error MWUSSetup DoInstall: Wsus setup
    failed (Error 0x80070645: This action is only valid for products that are
    currently installed.)
    2007-05-01 12:07:35 Success MWUSSetup Validating pre-requisites...
    2007-05-01 12:07:35 Error MWUSSetup Failed to determine if an
    higher version of WSUS is installed. Assuming it is not... (Error 0x80070002:
    The system cannot find the file specified.)
    2007-05-01 12:07:45 Success MWUSSetup SQL version is not Yukon.
    Yukon version 9.00.2047. SQL instance version 8.00.2039
    2007-05-01 12:07:48 Success MWUSSetup Creating database backup...
    2007-05-01 12:15:56 Success MWUSSetup Uninstalling the selfupate
    tree...
    2007-05-01 12:15:57 Error MWUSSetup RemoveSelfupdate20:
    SelfUpdateTree Uninstall Failed (Error 0x80070645: This action is only valid
    for products that are currently installed.)
    2007-05-01 12:15:57 Error MWUSSetup
    CUpgradeDriver::performSetup: Uninstall of selfupdate failed (Error
    0x80070645: This action is only valid for products that are currently
    installed.)
    2007-05-01 12:15:57 Error MWUSSetup CSetupDriver::LaunchSetup:
    Setup failed (Error 0x80070645: This action is only valid for products that
    are currently installed.)
    2007-05-01 12:25:18 Error MWUSSetup DoInstall: Wsus setup
    failed (Error 0x80070645: This action is only valid for products that are
    currently installed.)

    If I figure this out myself I'll post back. In the meantime anyone have any
    suggestions on a fix?
     
    Kevin Severud, May 1, 2007
    #1
    1. Advertisements

  2. Based from the log, the upgrade initially failed in mapping the WSUS Admin
    group SID to the admin group name--did your WSUS admin group exist at the
    beginning when you tried to upgrade 2.0 to WSUS 3.0?

    Since your intial upgrade failure happened after 2.0 selfupdate tree was
    uninstalled in the middle of upgrade, your subsequent upgrade all failed
    because it failed to uninstall 2.0 selfupdate tree (which was no longer
    there).



    --
    Fei Cao
    Microsoft, WSUS

    This posting is provided "As Is" with no warranties, and confers no rights.
    Use of included script samples are subject to the terms specified at
    http://www.microsoft.com/info/cpyright.htm
     
    Fei Cao \(MSFT\), May 2, 2007
    #2
    1. Advertisements

  3. Read the release notes? We'll perhaps not thoroughly enough. But then /g is
    for unattended installs which this was not. The installer hit a problem it
    couldn't handle and left WSUS v2 partially uninstalled (such that Add/Remove
    Programs was not an option). Notice that the first time I ran setup it
    claimed success even though v3 was not fully installed. Microsoft would be
    wise to rev the setup routine for SP1 release of this product.

    My solution was to download WSUS v2 and launch the installer which allowed
    for the removal of v2. At that point I could install v3 but it was no longer
    an upgrade and thus I had to recreate the configuration I had with v2.
     
    Kevin Severud, May 2, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.