Upgrading schema version but not DC windows version?

Discussion in 'Active Directory' started by JLunardi, Oct 30, 2008.

  1. JLunardi

    JLunardi Guest

    Hi Guys,

    My first post here... We currently have a single domain forest running only
    server 2003 DC's. We are currently at schema version 30. We have had a
    request to upgrade to schema version 31 as our server team wants to
    investigate the possibility of using DFS Replication with windows 2008
    servers (http://technet.microsoft.com/en-us/library/cc732863.aspx). We dont
    want to upgrade any of our DC's to R2 as in the near future we will upgrade
    our DC's to 2008.

    So my question(s)...

    Once we run the adprep to upgrade to version 31 would we need to have an R2
    DC to be able to take advantage of DFS Replication?

    As we are going to upgrade to 2008 in the near future (with in 6 months)
    would it make more sense to just upgrade to schema version 44? but again
    would we then require at least one 2008 DC to take advantage of DFS
    Replication?
     
    JLunardi, Oct 30, 2008
    #1
    1. Advertisements

  2. JLunardi

    Masterplan Guest

    Hi,

    I'll answer your questions:
    1. Yes. Make sure that all servers using DFSR must run R2 (each server in
    the replication group must have the DFSR installed). Read here for more
    details:
    http://searchwindowsserver.techtarget.com/tip/0,289483,sid68_gci1183496,00.html
    2. As you wish. Note that in 2008 DFSR can also be used for replication of
    the SYSVOL share between domain controllers. For this, you need to extend the
    schema (to version 44). This is because only Windows 2008 DC’s can
    participate in SYSVOL replication using DFSR, and in order to add Windows
    2008 DC’s the schema must be at 2008 level. Additionally you must have
    Windows Server 2008 Domain Functional.
     
    Masterplan, Oct 30, 2008
    #2
    1. Advertisements

  3. JLunardi

    JLunardi Guest

    Thanks for the reply and the link, it was helpful, however it didn't quite
    answer my question. Maybe I should reword it a little.

    I'd like to know if its possible to run all Domain Controllers as Windows
    2003 Server RTM (SP2) with the schema version either 31 or 44 and then use
    DFS on a group of 2008 member servers.

    or do we require at least one 2003 R2 / 2008 Domain Controller?

    Thanks for the clarification.
     
    JLunardi, Oct 30, 2008
    #3
  4. JLunardi

    Masterplan Guest

    Masterplan, Oct 30, 2008
    #4
  5. JLunardi

    JLunardi Guest

    Thanks for your answers!

    --
    James Lunardi


     
    JLunardi, Oct 30, 2008
    #5
  6. Jorge de Almeida Pinto [MVP - DS], Oct 30, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.