URGENT: sc sdset myservice - now I locked myself out ... "SC OpenService FAILED 5: Access is denied"

Discussion in 'Server Security' started by msnews.microsoft.com, Sep 25, 2008.

  1. Hello,

    I tried to change a services DACL on Windows 2003 .... now I locked myself
    out of the service because the DACL was reset.

    Now when I use: "sc sdshow tomcatform" I get the following output:
    [SC] OpenService FAILED 5:
    Access is denied.

    I'm not able able to start stop the service as I get "access denied" ...

    Whatever I try I'm not able to reset the DACL to the default as I keep
    getting "access denied" messages. I tried to do the following without
    success:
    http://support.microsoft.com/kb/926639/?sd=RMVP&fr=1

    Can someone tell me how can I restore the default DACL on this service?

    Thank you very much!!!!
    Didier
     
    msnews.microsoft.com, Sep 25, 2008
    #1
    1. Advertisements

  2. Hello msnews.microsoft.com,

    So, even methode 2 gives you an access denied message?

    Best regards

    Meinolf Weber
     
    Meinolf Weber, Sep 25, 2008
    #2
    1. Advertisements

  3. msnews.microsoft.com

    pnmantak Guest

    Did you solve this problem??
     
    pnmantak, Sep 4, 2013
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.