USB 2.0 problem

Discussion in 'Windows Vista Hardware' started by VictorV, May 2, 2009.

  1. VictorV

    VictorV Guest

    Hello people,
    I'm experimenting a big problem with my Kingston DataTraveler DT100
    with 8GB.
    When I connect it, it seems to work perfectly. I can read and delete
    files without problem, but when I try to write any file on it, windows
    start to copy and then it says "Could not find this item. This is no
    longer located in G:\. Verify the item's location and try again."


    When this error occurs, Windows stops to detect my DataTraveler. I have
    to disconnect and reconnect it and all happen again (It works perfect
    until I put some file on it).


    I tried formatting, connecting in other USB ports, disabling and
    unistalling the device, changing drive letter, using another
    DataTraveler and nothing solve this. DataTravelers work perfect in my
    desktop PC with XP
    The only way i can use it, is with a USB Hub that isn't USB 2.0 (It is
    1.1) and there work perfect (but slow, obviously)


    I tried with Windows Home Premium 64bits and with Windows 7 RC Build
    7100 64bits and I got the same error message. My PC is TX2 1020us.
    If anyone have a TX2 with Vista/Seven 64bits working and have not this
    issue, could you copy yor usb drivers to pobe them with my notebook?


    Thanks a lot
     
    VictorV, May 2, 2009
    #1
    1. Advertisements

  2. VictorV

    R. C. White Guest

    Hi, Victor.

    From the device name and your narrative, I assume the DataTraveler is a USB
    flash drive. Right?

    There are two things you can do in Disk Management (diskmgmt.msc) that
    might - or might not - help with your problem.

    First, you can use DM to assign a specific letter to your drive, so that it
    won't just look for the "first available" letter when you plug in this or
    other devices. You can assign it (semi-)permanently to G: (or H: or X:) and
    Windows will try to use that letter every time, and not assign that letter
    to another device, even if that drive is absent.

    Second, you can right-click on Disk 4 (or whatever number that device is
    assigned in DM) and select Properties. On the Policies tab, make sure it is
    still set to the Default: Optimize for quick removal, rather than for
    performance, so that the cache will always be empty and you won't lose
    anything if the plug is pulled without warning.

    Please post back and let us know if this helped.

    RC
    --
    R. C. White, CPA
    San Marcos, TX

    Microsoft Windows MVP
    Windows Live Mail 2009 (14.0.8064.0206) in Win7 Ultimate x64 RC 7100
     
    R. C. White, May 5, 2009
    #2
    1. Advertisements

  3. VictorV

    rebrab001

    Joined:
    Nov 12, 2010
    Messages:
    1
    Likes Received:
    0
    I am also having the same problems with my 4GB Kingston usb stick.
    I tried the solutions above with no success.
    My operating system is Windows 7
     
    rebrab001, Nov 12, 2010
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.