USB Audio device inf file

Discussion in 'Windows Vista Drivers' started by sliwor@gmail.com, Apr 17, 2008.

  1. Guest

    Hi

    I did a .inf file for a USB audio device (using usbaudio.sys). I
    simply made a inf file so I am not really making a driver I think.
    Anyway, I made a cat file and signed it using authenticode. On Vista,
    if I set the "all drivers equal" property and install my inf, when I
    connect my usb audio device, the inf I wrote is used and everything is
    fine. That is OK for tests but it cannot be the final solution.

    So on Vista when I do not set "all drivers equal" or on XP, even if I
    install my inf first (using SetupCopyOEMInf), when I connect my usb
    device, wdma_usb.inf is used instead of my inf. That is because my inf
    rank is lower than the Microsoft wdma_usb.inf. By setting "all drivers
    equal", since I have the exact hardware/vendor ID and an authenticode
    signature, my inf is used.

    So from what I understand, to have my inf file used instead of
    wdma_usb.inf on Vista and XP, I need it need to be certified by
    Microsoft. I downloaded the Windows Logo Driver Kit but I have Windows
    XP and Vista machines so I don't think I can use it right now before I
    install Windows Server 2003. Basically my questions are:
    - How much does it cost to have a inf file only (no sys or other
    driver files) certified by MS and how can I do it?
    - Again, since I only have a inf file, do I need to use the Windows
    Logo Kit?
    - Last question, is there another clean way for an authenticode .inf/
    cat files for a USB audio device to have a better rank than the MS
    wdma_usbinf file?

    Thanks
     
    , Apr 17, 2008
    #1
    1. Advertisements

  2. Guest

    Why can't you just change your device's descriptors such that
    usbaudio.sys is loaded automatically? i.e. Class == 0x01 and so on..
     
    , Apr 17, 2008
    #2
    1. Advertisements

  3. Guest


    Without my inf file, usbaudio.sys is loaded automatically by
    wdma_usb.inf. The problem is that the Microsoft wdma_usb.inf makes it
    the default sound device (which is something I do not want). I read a
    lot about this and the only clean way to avoid this (no registry
    modification) is to write my own inf file.
     
    , Apr 17, 2008
    #3
  4. Guest

    Did you ever get your inf file to work? Have been trying to do the same thing but cannot get the *magic* combination that makes it work :-(.

    Getting it to work in winxp is easy but 7 is annoying me!

    Thanks,

    /pedro
     
    , Mar 4, 2014
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.