USB mass Storage Devices Not working

Discussion in 'Windows Vista Hardware' started by WOE is Me, Jun 26, 2007.

  1. WOE is Me

    WOE is Me Guest

    I've spent the last hour reading through these questions looking for my own
    solution.

    I have the problem where no USB Mass Storage Devices are working. I have
    two flash drives and 1 USB 2 in 1 card reader. I pointed my drivers to
    c:\windows\system32\driverstore and now I get the following

    Windows found driver software for your device, but encountered an error
    while attempting to install it.

    The system cannot find the file specified.

    I also deleted the c:\windows\inf\infcache file and that did not help.
    I have run all available updates.
    I see some messages from others posting here in regards to conflicts. Is
    there anyway to find out if something is conflicting.

    Thanks
     
    WOE is Me, Jun 26, 2007
    #1
    1. Advertisements

  2. WOE is Me

    Vitaliy Guest

    I face the very same problem with Vista Home Premium 64 bit. I found a
    workaround to that problem:
    1) As soon as you have already tried to install that USB storage device,
    insert it into USB port, open device manager (in control panel) and uninstall
    (delete) the device with exclamation mark (unrecognised Device).
    2) Do not unplug the device and re-boot the computer with USB storage device
    installed.
    3) When the computer re-boots, Vista will "discower" a new device attached
    and offer to install the drivers, just click "cancel".
    4) Vista will offer you a window what you want to do with the files on USB
    storage device - play, print, open ...
    5) Click to open the Disk drive.
    After that, each time you would plug this very USB storage device in the
    very same USB port, Vista would offer you options (3) and (4), just do as
    described above.
    Thanks,
    Vitaliy.
     
    Vitaliy, Jun 26, 2007
    #2
    1. Advertisements

  3. WOE is Me

    WOE is Me Guest

    Thanks for the quick reply.

    I tried it however, it never showed up as a working device in device
    manager. I tried cancel and that is as far as it would go. I went ahead and
    rebooted again. No change. Tried to install drivers again figuring what the
    h3!! it doesn't work anyway. It didn''t.
    Just so you know it is a image mate dual card reader. I also tried the same
    procedure with a working sim card in the device. No luck there either.
    It's model number is sddr-77. It does not need drivers for XP or Vista.

    Hopefully we find a solution so some poor person will not have to go through
    the same thing.
    Thanks
     
    WOE is Me, Jun 27, 2007
    #3
  4. WOE is Me

    Don Guest

    The key to this fairly common bug is that last sentence, but what
    is that 'specified' file? I don't know, but maybe one of the many
    log files in the Event Viewer will give a more reasonable error
    message. It's a bit of work looking through all of them, but it
    might help.
     
    Don, Jun 27, 2007
    #4
  5. WOE is Me

    Spirit Guest

  6. WOE is Me

    freddy Guest

    freddy, Jun 27, 2007
    #6
  7. WOE is Me

    WOE is Me Guest

    This is nice to know but will not fix my problem.
     
    WOE is Me, Jun 28, 2007
    #7
  8. WOE is Me

    phadu Guest

    Hi there,
    Any luck with this problem you were facing?

    I have a Vista business and have the exact same problem. None of the
    USB drives work, and they all spit out the same problem in the end. Very
    very frustrating.

    Please let me know if you have round a solution.

    thanks a lot
    Phadu
    California
     
    phadu, Sep 10, 2007
    #8
  9. WOE is Me

    phadu Guest

    FOUND THE SOLUTION. Worked for me like a charm

    Follow this blog/link below
    'Vista Driver Problems installing a USB Media Reader - A solution!
    Teknobabble’s Weblog' (http://tinyurl.com/2bd8um

    cheer
    Phad
     
    phadu, Sep 10, 2007
    #9
  10. WOE is Me

    Davis Guest

    Hey all,

    I realise this is an older thread, but I found a solution after several
    hours searching the net.

    I am currently running Vista Home Premium, 2GB Ram, etc...

    I was unable to use USB Flash Drives, as when vista tried to install
    the drivers, it would come up with an error similar to: cannot find the
    file specified.

    To fix this and install the drivers, I had to do the following:
    1. Open Windows Explorer, then go to the following address line:
    C:\Windows\inf\setupapi.dev.log...double click
    2. This should open up Notepad..or equivelant.
    3. Go to the bottom of the log and press Ctrl + F, and search upward
    for 'cannot find the file specified'
    4. I few lines above that you should see 'SourceFile - [-FileName-]'
    and just above that 'SourcePath - [-Path-]. You will find that if you
    go to that path, the specified file will not be there.
    5. If you then go to C:\Windows\System32\DriverStore\FileRepository\
    and find the specified file...copy it and paste into C:\Windows\inf
    6. When you try to install the drivers again, (using device manager ->
    reinstall drivers) direct the wizard to C:\Windows\inf and make sure
    'include subfolders' is checked, and it should say drivers have been
    installed.

    Hope this helps
     
    Davis, Mar 3, 2008
    #10
  11. WOE is Me

    kryznica Guest





    hey Davis
    I'm having some trouble finding which one of the "cannot find the file
    specified"
    section you are talking about
    can you get in more specifics in which files to use
     
    kryznica, Mar 4, 2008
    #11
  12. WOE is Me

    kryznica Guest

     
    kryznica, Mar 4, 2008
    #12
  13. WOE is Me

    Davis Guest

    kryznica,

    If you get the USB Drive to attempt to install, and then follow the
    steps i outlined, it should be the last entry in the log...eg, scroll
    to the bottom of the log, click on the last line, the press Ctrl + f
    and proceed as I previously said, it should be the first one that is
    found.

    It should look like the following

    -ndv: {Update Driver Software Wizard for
    STORAGE\VOLUME\1&19F7E59C&0&_??_USBSTOR#DISK&VEN_CORSAIR&PROD_FLASH_VOYAGER&REV_1100#AA23100000000042&0#{53F56307-B6BF-11D0-94F2-00A0C91EFB8B}}
    inf: {SetupCopyOEMInf: *C:\Windows\INF\volume.inf*}
    22:05:01.618
    inf: {SetupCopyOEMInf exit (0x00000002)} 22:05:01.637
    !!! ndv: Driver Package import failed for new device...installing
    NULL driver.
    !!! ndv: Error 2: The system *cannot find the file specified.*-

    I have highlighted the directory of the file that you need to be
    looking for. Obviously this file isn't actually there, so you will need
    to find that file in C:\Windows\System32\DriverStore\FileRepository\
    Hope this helps,

    I just realised that you may have been asking a different
    question....If you are having trouble finding where to find the log,
    just search for setupapi.dev, it may not have the .log after it, just
    double click on it, scroll to the bottom, and the continue as specified

    Thanks


     
    Davis, Mar 5, 2008
    #13
  14. WOE is Me

    Tom Guest

    Davis,

    I'm a different user who had the exact same problem. I've been searching
    through posts and forums for a week now, and I wanted to thank you so much
    for your solution because it worked like a charm on my VAIO (32bit Vista).
    Your solution took me three minutes to apply. Thanks again.

    Tom

     
    Tom, Mar 19, 2008
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.