USB ports working but not with mass storage devices

Discussion in 'Windows Vista General Discussion' started by Barry, Dec 11, 2007.

  1. Barry

    Barry Guest

    I've been having serious problems with my USB ports using an ipod, 500GB
    external drive and USB hub/SD card reader.

    My USB sockets are all powered and working OK with other USB devices
    (printer etc) but not the mass storage devices. They are powered when
    plugged in but are not seen in windows explorer or the relevant software.
    Yesterday, my wife's ipod ended up wiped clean in itunes and had to be
    restored on another PC. Today the PC won't see my SD card via a USB hub and
    it won't recognise my external hard drive. Any suggestions welcome!
     
    Barry, Dec 11, 2007
    #1
    1. Advertisements

  2. Barry

    alexB Guest

    I've had a somewhat similar issue with my USB and I've come to the
    conclusion it is the PCI card that does it. This is the reason why. I have
    three identical systems in terms of hardware. They are all good. I have this
    problem on one machine only. It has persisted for 2 years. The motherboard
    has been changed twice. It did not help.

    I have the same (or somewhat similar) screw up on every partition on this
    machine although I have different OSs: Vista, XP and Server2003 on them. On
    the other machines there are no problems under Win2K or Vista.

    My problem is that I can use only ONE storage device no matter what type it
    is.

    I am planning to call DELL and ask them to replace the PCI card since I
    still have an extended warrantee.
     
    alexB, Dec 13, 2007
    #2
    1. Advertisements

  3. My recent travails may have a bearing on your problem.

    Windows XP, Dell computer.
    Tried to install a iPod (classic 80 GB) would not see the iPod, some times
    the iPod would report connected, but would not charge. iPod worked fine on a
    laptop. Tried to connect a Passport external hard drive (180 GB) it would
    show it was powered (blue light on)(USB powered, no brick involved) but
    could not be seen either. The machine would see a 256 MB thumb disk.

    After lots of futzing around, I happened to turn off the
    printer/scanner/copier. Lo and behold the iPod and the Passport drive began
    working like champs. Something about the printer was interfering with the
    discovery of devices on other USB ports.

    About a year ago with a white-box pc running XP I found a similar problem.
    no ports would work with two different USB external hard drives if the
    printer was on and attached to either of two USB ports, everything would
    work if the printer was attached to other ports. I never followed thru on
    that just put the printer on ports that let the external drives work and
    left it that way.

    (on the back were Ports AB CD and on front were ports EF, if the printer was
    plugged in ports A or B then the external drives would not work if plugged
    into ports A or B (not holding the printer of course) C, D, E, or F. If I
    plugged in the printer to either port C or D, then the harddrive would work
    in any other open port.

    You might try removing all other USB devices as a test.

    Your failures may vary.
    Michael
    Vista Home premium
     
    Michael Walraven, Dec 13, 2007
    #3
  4. Barry

    alexB Guest

    Thank you Michael, it is relevant and useful.

    My problem is that on this computer I have had a network printer all along.
    Also I forgot to mention in my first post that a year ago I devoted a
    special service call to DELL which took about 4 hours. A very nice guy tried
    anything he or his super would come up with. Nothing helped. I think after
    that they changed the motherboard first time as a sign of desperation. It
    did not work.

    I had my own theory which in the end proved to be wrong. My thinking was
    that since only one USB attached device could work, no matter what type, the
    machine was underpowered. Of course this theory discounted that fact that
    all my machines had the same power plants.

    In short I purchased 2 most powerful DELL compatible internal power supplies
    from a small company whose name I do not quite remember. It increased my
    power from 170 to 470W but it had absolutely no effect whatsoever.

    I will try to apply your situation to mine. Perhaps some crazy configuration
    is important.

    BTW, in a bizarre dismissal of your suggestion, the other machine has a DELL
    printer plugged in USB style directly. It has a HP printer for pictures and
    photos attached as well. It has a bunch of other ports busy and everything
    works. I am using that machine's printer remotely.

    It is too complicated to analyze even for DELL people I as found out.

    Thanks.
     
    alexB, Dec 13, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.