usbccgp hangs the system when trying to standby

Discussion in 'Windows Vista Drivers' started by Leo Havmøller, Oct 14, 2004.

  1. Hi,

    I have a USB composite device with HID and audio class interfaces (its
    basically a USB headset). It uses Microsoft drivers only.

    When trying to standby the system with remote wakeup enabled, the system
    hangs while the "preparing to stand by" dialog is shown.
    The same problem occurs with a Plantronics DSP-500 headset.

    The following message is printed in WinDbg when standby is attempted:
    fyi: \Driver\usbccgp \Device\00000097 irp (83083008) QueryPower-Sleeping3
    status c0000001

    If I change the USB descriptors so only the HID device is exposed (i.e. its
    no longer a composite device), standby/resume works as expected.

    WinDbg now shows the following message instead:
    fyi: \Driver\HidUsb \Device\_HID00000000 irp (831d3e70) QueryPower-Sleeping3
    status c0000001

    IMHO this is a bug in usbccgp and/or hidusb.

    Test system is XP with SP2.

    Leo Havmøller.
     
    Leo Havmøller, Oct 14, 2004
    #1
    1. Advertisements

  2. I finally had some time to test on another PC.

    Installed XP from scratch, tried with SP1a and SP2, tried plugging the
    device as USB 1.1 and also with a USB 2.0 hub, all combinations show the
    dialog "The device driver for the 'USB Composite Device' device is
    preventing the machine from entering standby."
    Can this message help locating the problem?

    Leo Havmøller.
     
    Leo Havmøller, Oct 22, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.