UseWuServer value is missing prob

Discussion in 'Update Services' started by ithilgore, May 17, 2006.

  1. ithilgore

    ithilgore Guest

    Greetings,

    ***********************************



    WSUS Client Diagnostics Tool

    Checking Machine State
    Checking for admin rights to run tool . . . . . . . . . PASS
    Automatic Updates Service is running. . . . . . . . . . PASS
    Background Intelligent Transfer Service is not running. PASS
    Wuaueng.dll version 5.8.0.2469. . . . . . . . . . . . . PASS
    This version is WSUS 2.0

    Checking AU Settings
    AU Option is 4: Scheduled Install . . . . . . . . . . . PASS
    Option is from Policy settings

    Checking Proxy Configuration
    Checking for winhttp local machine Proxy settings . . . PASS
    Winhttp local machine access type
    <Direct Connection>
    Winhttp local machine Proxy. . . . . . . . . . PASS
    Winhttp local machine ProxyBypass. . . . . . . PASS
    Checking User IE Proxy settings . . . . . . . . . . . . PASS
    User IE Proxy. . . . . . . . . . . . . . . . . PASS
    User IE ProxyByPass. . . . . . . . . . . . . . PASS
    User IE AutoConfig URL Proxy . . . . . . . . . PASS
    User IE AutoDetect
    AutoDetect not in use

    Checking Connection to WSUS/SUS Server
    WUStatusServer is not set through Policy
    WUServer is not set through Policy
    UseWuServer value is missing. . . . . . . . . . . . . . FAIL

    The system cannot find the file specified.

    ***************************************

    This is the log of clientdiag.exe.
    The problem is that apart from itself (the WSUS server) no other computer
    shows up in the admin console. The clients are configured through group
    policy in an active dir environment.

    Thanks in advance for the help.
     
    ithilgore, May 17, 2006
    #1
    1. Advertisements

  2. ithilgore

    ithilgore Guest

    The machine that applies the policy is running win2003server SP1 sto there
    is no problem with wuau.adm .
    Do you know where the UseWuServer value is located ?
    If it is the value of the redirection ( specify intranet update services
    location ) then it has been configured already.
     
    ithilgore, May 17, 2006
    #2
    1. Advertisements

  3. ithilgore

    ithilgore Guest

    Thanks. After i checked this out , the client can now find the server ( Pass
    at UseWuServer is enabled and recongintion of the name of the server )
    but there is another error :

    GetAUSettingsRegistry(false,TEXT("SusServerVersion"), &dwSusVersion) failed
    with hr=0x80070002

    The system cannot find the file specified.

    .....
     
    ithilgore, May 17, 2006
    #3
  4. ithilgore

    Dave Mills Guest

    I all you did was set the value to 1 in the registry then how are you
    configuring the reset of the essential parameters like the URL to the WSUS
    server.

    Playing with the registry is OK to find out what is wrong but if you are using
    GP to deploy the setting then do not edit the registry. Fix the problem that is
    causing the GPO to fail.
     
    Dave Mills, May 18, 2006
    #4
  5. ithilgore

    ithilgore Guest

    The problem is that i have configured all the needed GPO values and yet
    cannot find why it is failing.
    The only issue i have found is that because the WSUS server was recently
    promoted to domain controller from another server , it cannot retrieve the
    global catalog ,though all the objects in active directory show up normally...
     
    ithilgore, May 18, 2006
    #5
  6. Export and post the registry key at
    HKLM\Policies\Software\Microsoft\Windows\WindowsUpdate

    Also run and post the results from the Client Diagnostic Tool.

    The most likely cause is that (a) policy is not being applied and local
    registry settings are invalid, or (b) you have policy conflicts due to
    multiple WUA policies being applied.

    The mere fact that WUServer was not set correctly tells me that there is no
    /valid/ policy being applied. The resolution comes from the answer to the
    question: Where is the client system getting its configuration information
    from?

    --
    Lawrence Garvin, M.S., MVP-Software Distribution
    Everything you need for WSUS is at
    http://technet2.microsoft.com/windowsserver/en/technologies/featured/wsus/default.mspx
    And, eveything else is at
    http://wsusinfo.onsitechsolutions.com
    ....
     
    Lawrence Garvin \(MVP\), May 18, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.