VerifyWUServerURL() failed with hr=0x80072efd from ClientDiag.exe

Discussion in 'Update Services' started by DaveyK, Jul 25, 2006.

  1. DaveyK

    DaveyK Guest

    Running SBS2003 Premium SP1. WSUS SP1. Workstations W2KSP4 and XPSP2. Unable
    to get clients to check in with WSUS Server. WSUS is installed on port 8530.
    I have the clientwebservice and selfupdate installed on port 80, with anon
    auth required. The IP address 192.168.0.1 is correct for the server (I have
    tried the server name, but am using the IP to eliminate DNS). I have looked
    into this error, and it appears that it is a "unable to detect internet" type
    error. I can surf the web on the Workstations. I have the MSProxy Client
    installed, and set the workstations to ignore the proxy if address is local.

    WSUS Client Diagnostics Tool

    Checking Machine State
    Checking for admin rights to run tool . . . . . . . . . PASS
    Automatic Updates Service is running. . . . . . . . . . PASS
    Background Intelligent Transfer Service is not running. PASS
    Wuaueng.dll version 5.8.0.2469. . . . . . . . . . . . . PASS
    This version is WSUS 2.0

    Checking AU Settings
    AU Option is 4: Scheduled Install . . . . . . . . . . . PASS
    Option is from Policy settings

    Checking Proxy Configuration
    Checking for winhttp local machine Proxy settings . . . PASS
    Winhttp local machine access type
    <Direct Connection>
    Winhttp local machine Proxy. . . . . . . . . . NONE
    Winhttp local machine ProxyBypass. . . . . . . NONE
    Checking User IE Proxy settings . . . . . . . . . . . . PASS
    User IE Proxy
    SERVER:8080
    User IE ProxyByPass
    192.168.*;<local>
    User IE AutoConfig URL Proxy . . . . . . . . . NONE
    User IE AutoDetect
    AutoDetect not in use

    Checking Connection to WSUS/SUS Server
    WUServer = http://192.168.0.1:8530
    WUStatusServer = http://192.168.0.1:8530
    UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS

    VerifyWUServerURL() failed with hr=0x80072efd

    A connection with the server could not be established

    I am thinking this may be an ISA issue or permissions. Can anyone point me
    in the right direction please.
     
    DaveyK, Jul 25, 2006
    #1
    1. Advertisements

  2. You have SBS2003 /Premium/, so if you have ISA Server installed, you're
    going to need to properly configure ISA Server to permit access to port
    8530. In order to do that, you'll need to create a "Custom Protocol", (I
    call mine "WSUS Protocol") defined on TCP Port 8530. Then you'll need to
    publish that webserver to your INTERNAL interface.

    --
    Lawrence Garvin, M.S., MVP-Software Distribution
    Everything you need for WSUS is at
    http://technet2.microsoft.com/windowsserver/en/technologies/featured/wsus/default.mspx
    And, everything else is at
    http://wsusinfo.onsitechsolutions.com
    .....
     
    Lawrence Garvin \(MVP\), Jul 26, 2006
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.