VerifyWUServerURL() failed with hr=0x80072efd

Discussion in 'Update Services' started by Milt Smith, Nov 1, 2007.

  1. Milt Smith

    Milt Smith Guest

    I upgraded from WSUS 3.0 Beta 2 to WSUS 3.0 Version 1. Synchronization
    worked fine but I have no computers in WSUS. When I run ClientDiag WSUS
    Client Diagnostic Tool on the WSUS server, I get the above error. My server
    is a Windows 2003 Service Pack 2.

    Any help would be appreciated.

    Milt Smith
     
    Milt Smith, Nov 1, 2007
    #1
    1. Advertisements

  2. Technically you didn't. Upgrading from the beta product to the release
    product was not a supported activity -- in fact, it was impossible to do.

    At best, you uninstalled WSUS 3.0 Beta 2 and installed a *fresh* WSUS 3.0
    RTM.
    0x80072efd is an INTERNET CANNOT CONNECT error, and basically it means the
    WSUS website is not responding to the webservice requests from the client.
    The client logs the '2efd' error when it gets *NO* response from the
    destination webserver, or any resource (i.e. proxy server) in between.

    Since you ran the CDT on the WSUS Server itself, then I'd guess that either
    the WWW service is shutdown, the website is stopped, or you have configured
    an incorrect URL in the policy used to configure your WSUS server.

    Let's start by posting ALL of the output from the CDT run on the WSUS3
    server.

    --
    Lawrence Garvin, M.S., MCTS, MCP
    MVP - Software Distribution (2005-2007)
    MS WSUS Website: http://www.microsoft.com/wsus
    My Websites: http://www.onsitechsolutions.com;
    http://wsusinfo.onsitechsolutions.com
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
     
    Lawrence Garvin [MVP], Nov 1, 2007
    #2
    1. Advertisements

  3. Milt Smith

    Milt Smith Guest

    Lawrence,

    Thanks for the quick response. Here are the result of running the Client
    Diagnostic Tool on the WSUS server.


    WSUS Client Diagnostics Tool

    Checking Machine State
    Checking for admin rights to run tool . . . . . . . . . PASS
    Automatic Updates Service is running. . . . . . . . . . PASS
    Background Intelligent Transfer Service is running. . . PASS
    Wuaueng.dll version 7.0.5451.90 . . . . . . . . . . . . PASS
    This version is WSUS 2.0

    Checking AU Settings
    AU Option is 3 : Notify Prior to Install. . . . . . . . PASS
    Option is from Policy settings

    Checking Proxy Configuration
    Checking for winhttp local machine Proxy settings . . . PASS
    Winhttp local machine access type
    <Direct Connection>
    Winhttp local machine Proxy. . . . . . . . . . NONE
    Winhttp local machine ProxyBypass. . . . . . . NONE
    Checking User IE Proxy settings . . . . . . . . . . . . PASS
    User IE Proxy. . . . . . . . . . . . . . . . . NONE
    User IE ProxyByPass. . . . . . . . . . . . . . NONE
    User IE AutoConfig URL Proxy . . . . . . . . . NONE
    User IE AutoDetect
    AutoDetect not in use

    Checking Connection to WSUS/SUS Server
    WUServer = http://2003R2TEST:8530
    WUStatusServer = http://2003R2TEST:8530
    UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS

    VerifyWUServerURL() failed with hr=0x80072efd

    A connection with the server could not be established


    Press Enter to Complete
     
    Milt Smith, Nov 2, 2007
    #3
  4. This is the point at which the CDT attempts to initiate an actual GET
    request to the WSUS Server. If you were receiving a '401' or '404' error
    from the web server, it would be relevant as to exactly which resources the
    CDT is attempting to contact, but in this case it's not, so I'll spare you
    those pedantic details (for the moment).

    Essentially what is happening here is that IIS is not responding to the GET
    request.

    This is almost always due to some failure in the network infrastructure
    between the AU client and WSUS.

    These are the most likely causes (not in any order of probability), given
    that this test was performed on the SBS 2003 server:
    [a] IIS is not running.
    The Default Web Site is stopped.
    [c] IIS is configured to use host headers and "2003R2TEST" is not
    configured on the Default Web Site.
    [d] IIS is configured to use specific IP Addresses and the IP Address
    configured in DNS for "2003R2TEST" is not configured in IIS.
    [e] DNS does not have an entry for "2003R2TEST".
    [f] DNS is returning an incorrect IP Address for "2003R2TEST".
    [g] The SBS server is trying to route this request to a resource outside
    of the SBS2003 server, that's not responding.


    --
    Lawrence Garvin, M.S., MCTS, MCP
    MVP - Software Distribution (2005-2007)
    MS WSUS Website: http://www.microsoft.com/wsus
    My Websites: http://www.onsitechsolutions.com;
    http://wsusinfo.onsitechsolutions.com
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
     
    Lawrence Garvin [MVP], Nov 2, 2007
    #4
  5. Milt Smith

    Milt Smith Guest

    Lawrence,

    It worked fine when I was running WSUS 3 Beta 2. I than un-installed the
    Beta and installed Version 1. Should I try another uninstall & re-install? or
    is there something in IIS that I can check?

    Thanks,

    Milt Smith

     
    Milt Smith, Nov 5, 2007
    #5
  6. There's nothing in IIS you can check.. .except to review the logs and
    confirm that IIS is not seeing any requests from the client at all.

    0x80072EFD means "IIS did not respond to my web service request".

    It's highly unlikely that uninstalling Beta2 and installing the RTM did
    anything to introduce a '2efd' error.

    What's most likely under these circumstances is that the DNS entry is
    defective or nonexistent, and the WUA/CDT cannot properly resolve the
    configured hostname in the WSUS URL There are very few other
    "infrastructure" options, given that the CDT is running on the same physical
    box as the WSUS services.

    To evaluate a possible DNS failure vs an IIS/webservice failure, try
    accessing resources from Internet Explorer on the SBS2003 console.

    A list of seven URLs that you should be able to access from IE are:
    http://wsusservername/iuident.cab
    http://wsusservername/selfupdate/iuident.cab
    http://wsusservername/clientwebservice/wusserverversion.xml

    http://wsusservername:8530/iuident.cab
    http://wsusservername:8530/selfupdate/iuident.cab
    http://wsusservername:8530/clientwebservice/wusserverversion.xml
    http://wsusservername:8530/simpleauthwebservice/simpleauth.asmx

    The CAB links should return a File Open/Save dialog box.
    The XML links should return a short XML file in the IE browser window.
    The ASMX link should return a short list of services available from the
    SimpleAuthWebService.


    In addition to using the hostname (e..g http://2003R2TEST...) also perform
    the tests using the IP Address of the server and http://127.0.0.1...


    --
    Lawrence Garvin, M.S., MCTS, MCP
    MVP - Software Distribution (2005-2007)
    MS WSUS Website: http://www.microsoft.com/wsus
    My Websites: http://www.onsitechsolutions.com;
    http://wsusinfo.onsitechsolutions.com
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
     
    Lawrence Garvin [MVP], Nov 9, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.