Very Slow logon from Win XP Pro to Win 2003 server

Discussion in 'Server Setup' started by zbatia, Jan 13, 2004.

  1. zbatia

    zbatia Guest

    I saw this problem is quite common. I have one primary domain server win 2003 with enabled DNS, one 100MB switch, and several Win XP Pro workstations. The logon procedure take about 5 min, the browsing is very slow. The XP workstation is configured with the correct setting for DNS IP address.
    I have to note that I have no problem to logon to another Win2K server (also PDC). When I test it, I connect the workstations to another network (both servers are not on the same network).
    What could be wrong with the Win 2k3 server? Any clues?
     
    zbatia, Jan 13, 2004
    #1
    1. Advertisements

  2. zbatia

    John Losey Guest

    If I were to guess, I'd say that the Primary DNS Server for the Win2K3 DC
    and the XP Clients is NOT currently set to be the DC. Also, make sure that
    the DC is hosting the zone for your domain, and that it was able to create
    the necessary SRV records in DNS, if not, change "Dynamic Updates" to
    "secure and non-secure" and then do the following on the DC: "ipconfig
    /flushdns" "ipconfig /registerdns" "net stop netlogon" and "net start
    netlogon".

    You'll also want to do an "ipconfig /flushdns" & "ipconfig /registerdns" on
    the XP boxes after pointing them towards the DC as their Primary DNS server.
    DO NOT POINT ANY DOMAIN MEMBERS TOWARDS YOUR ISP's DNS SERVER.

    John

    2003 with enabled DNS, one 100MB switch, and several Win XP Pro
    workstations. The logon procedure take about 5 min, the browsing is very
    slow. The XP workstation is configured with the correct setting for DNS IP
    address.
    (also PDC). When I test it, I connect the workstations to another network
    (both servers are not on the same network).
     
    John Losey, Jan 14, 2004
    #2
    1. Advertisements

  3. May not be it, but here's my 2 cents.

    What speed/duplex is the NIC setting on the Switch and on the Server?
    If one is 100/full and the other auto, you'll have one side running at 100/half.
    This may explain the slow down.

    IMO, it's best practice to "hard code" speed and duplex on both sides of this
    connection.
    I never use Auto accept for PCs on my switches.
     
    Not-My-Real-Name, Jan 14, 2004
    #3
  4. zbatia

    zbatia Guest

    I have tried both options with the same result. I'll try John's recommendations tonight, it really makes sense. I'll get back with the results.
     
    zbatia, Jan 14, 2004
    #4
  5. zbatia

    Ian Bayly Guest

    Hi Zbatia

    Did it fix the problem?

    Ian B
    recommendations tonight, it really makes sense. I'll get back with the
    results.
     
    Ian Bayly, Jan 20, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.