Very Slow Transfer Speeds on Lan

Discussion in 'Windows 64 Bit' started by FrankB, Jul 22, 2005.

  1. FrankB

    FrankB Guest

    I have 1 Win X64 machine running on a peer-to-peer network with a 3Com 10/100
    hub with multiple WinXP machines, and I have 1 process that I always run on
    X64 and it requires me to transfer large files (200mb-500mb) between the
    other 32 bit Win XP Pro machines. It can take 14-18 minutes to transfer a
    400mb file either To or From X64. In the time it takes me to send 400mb
    either to/from X64 I can copy 17gb from WinXP Pro (32 bit) to an external
    firewire hdd. Seems drastically slower than it should be. No other speed
    problems anywhere on the lan. Net connections on X64 are fine too. The only
    thing I've tried is to turn off the firewall on X64 - firewall is off on all
    machines on my lan because it sits behind a hardware firewall - and it makes
    no difference with the speed.
    Do I have to be happy with this? Something going on that's not evident? Any
    FrankB, Jul 22, 2005
    1. Advertisements

  2. Its possibly the drivers for network card thats causing that problem.
    Andre Da Costa [Extended64], Jul 22, 2005
    1. Advertisements

  3. FrankB

    Guest Guest

    FB- [Fri, 22 Jul 2005 10:48:04 -0700]:
    Are they all 100 Mbps NICs? Hubs, which you say you
    have, drops to the lowest common NIC speed. If you
    have one 10Mbps on the LAN, everything moves at 10Mbps.
    That makes it less than 1 MB/sec... or for your data,
    maybe 500 seconds -- eight minutes. Hubs also collide
    at the drop of a hat, so maybe much less than 1 MB/sec.
    They still sell HUBS, but any SWITCH will cost no more,
    and work much better (won't drop to lowest NIC speed,
    and won't collide at the drop of a hat).
    Guest, Jul 22, 2005
  4. FrankB

    FrankB Guest

    Interesting thought, thanks. I went to the ASUS support site and downloaded
    several new drivers. Installed one that supposedly upgraded the lan adapter
    to gigabit ethernet. Didn't make any difference so I'm trying to pursue ASUS.
    FrankB, Jul 23, 2005
  5. FrankB

    FrankB Guest

    Thanks for the thought but all machines and hubs are at 100MB and have been
    for some time.

    FrankB, Jul 23, 2005
  6. Sometimes you just have change the brand card to another one to possibly see
    some difference in performance, its possible that its not a properly written
    driver for x64.

    Andre Da Costa [Extended64], Jul 23, 2005
  7. FrankB

    FrankB Guest

    It's an ASUS mobo and the lan adapter is built into the board - nothing I can
    change. And all the other machines are fine.

    FrankB, Jul 23, 2005
  8. FrankB

    Proconsul Guest

    On 7/22/05 7:31 PM, in article
    Check the drivers for your NIC - drivers often make the difference......

    Proconsul, Jul 23, 2005
  9. Are you using nvidia chipsets? If so, the culprit may be the NV firewall
    which some posters have said causes issues whether you installed it or not.
    Some have advised to intall it and then unistall it. Seems counterintuitive
    but others can comment.

    Colin Barnhorst, Jul 23, 2005
  10. Assuming you have a 100Bbps hub, nail all your NICs to 100Mbps and full
    duplex (rather than autonegotiate)
    Often NICs from different vendors on the same network do not autonegotiate
    well (dropping you to 10)
    Just a thot
    Johann Gamblepudding, Jul 23, 2005
  11. Yeah, I was going to recommend he check the TCP/IP settings definitely. Also
    assign IP address to make sure.
    Andre Da Costa [Extended64], Jul 23, 2005
  12. FrankB

    FrankB Guest

    The plot thickens. The onboard lan adapter on the ASUS mobo comes from a
    company named Marvell. I found a 64bit driver on their web site, downloaded
    and installed it... and everything got worse. Trying to send a 475mb file to
    32 bit WinXP, about 1/3 of the way through X64 says "Network resource not
    available" and X64 has dropped all lan connections - you can't see into the
    machine or out from the machine??? He's not on the lan anymore. If I reboot
    everything is back to snuff but try that file transfer and it happens again.
    All my lan adapters and hubs are 3Com; this is Marvell. Time to disable the
    onboard Marvell and replace it? But do I need a nic that has reported 64bit
    capability? I have a couple of the older 3Com nic's still lying around but if
    they can't do 64bit do I want to use them? I can't yet find a 3Com nic that
    says it'll do 64bit! So should I buy an Adaptec 64bit nic, disable the
    onboard Marvell and put the Adaptec in? I swapped ports on the hub and it
    didn't make any difference. I don't think it's the cable because when I
    reboot everything works fine. I've had a 3Com hub go bad on me once but it
    was fairly obvious when it did! I don't think I want to swap out the hub?
    FrankB, Jul 23, 2005
  13. FrankB

    FrankB Guest

    The other thing I wanted to add was that all these guys are downstream from
    my Linksys router/firewall and he's also a dhcp server so he's taking care of
    all the addresses. Whatever the problem is it seems to be strictly confined
    to the X64 machine with the ASUS motherboard.
    FrankB, Jul 23, 2005
  14. FrankB

    FrankB Guest

    Thanks for all your suggestions here. I was nosing around the ASUS support
    site and discover that the bios on my ASUS A8V appears to be back a couple
    revs to handle the Athlon 3500 + processor. So I've got to upgrade my bios
    before I go on any further and this can rest until I prove or disprove this
    FrankB, Jul 24, 2005
  15. FrankB

    Hydrology Guest

    Hi Frank, the two process that you are comparing are not really comparible.
    If your network is running at 100 Mbps (it is not MBps) it will only transfer
    12.5 MBps, and that is assuming you are getting 100% of your network
    bandwidth. You are lucky if you are getting 50%, so the true transfer rate
    is probably around 6MBps at best. I often see our office transfer rate often
    down to 3 to 10% of the network bandwidth.
    For your file 500MB/840sec = 0.6 MBps (4.8% of bandwidth)

    The write to your external hard drive is a function of your hard drive
    speed. I don't know what hard drive you have, but you are probably getting
    around 60 MBps if your drive is not too old. So take a mid value of 60MBps
    and you will see that the external hard drive write will be at least 10 times
    faster than a 100Mbps network copy.
    For your file 14,000MB/840sec = 16MBps So your firewire is 26 times faster
    than your network copy. That is not too far outside of what I am seeing.

    Have you tried to copy the 500MB file from one XP32 machine to another XP32
    machine? I would be surprised to see much of any difference, but let us know
    the results.

    Be careful to differentiate between Mbps (bits) and MBps (Bytes).

    Hydrology, Jul 26, 2005
  16. Well from experience here i know that the 10/100/1000 mbit adapter from
    marvell works well in my networks setup. I'm running 7 machines connected to
    a 8 port 10/100/1000 switch, the last port is connected to my cable modem
    which is 10/100mbits. recently i upgraded to winxp pro 64bit and noticed
    that my network connection was a little slow using the drivers that were
    defaultly installed for my machine. after a run with windows update i
    downloaded the updated drivers for my card and everything is back to normal.
    out of curiosity i tried downloaded the beta drivers from marvell/yukon and
    i seen another small imporvement in my transfer speeds.

    I'd definately suggest checking your drivers and trying them from both
    places, but marvell also supplies a small program to test your cable. You
    might find that you cable is slightly unplugged and not getting the best
    connection. which would cause slow speeds due to failed packets which need
    to be retransmitted.

    now the firewire drive should be pretty quick, I believe most are still
    rated at 400mbits which would be about 4 times faster than the ethernet
    network you are running.
    I'd also look at the anti virus solutions you are running on the machines,
    some antivirus programs take alot of time to scan the files that you are
    sending. i'm running Nod32 64bit edition right now and it is very quick.
    there are a few other things to try but let us know what happens from here.
    Chris Streeter, Jul 26, 2005
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.