Video card and driver compatibility with Age of Empires I and II

Discussion in 'Windows Vista Games' started by Lowana, Nov 6, 2007.

  1. Lowana

    Lowana Guest

    Hi I recently installed Age of Empires I (with the rise of rome expansion
    pack) and Age of Empires II (with the conquerers expansion pack) from the
    Age of Empires Collector's Edition. The installation went without a hitch
    but when I go to play the game a box comes up saying 'Could not initalize
    graphics system. Make sure your video card and driver are compatible with
    DirectDraw. I've tried a few things but nothing works. Age of Mythology
    works fine on my computer but I can't work out why these two games can't
    work. Can u help me please.
    Thanks,
    Lowana.
     
    Lowana, Nov 6, 2007
    #1
    1. Advertisements

  2. You might try going to the Microsoft web site and download and install
    DX9.1c. Some of the directX components are missing in Vista (not really,
    but that's the simple answer!), so reinstalling DX9 does fix a lot of
    issues. If that doesn't work, let us know.
     
    Dustin Harper, Nov 12, 2007
    #2
    1. Advertisements

  3. i have the same problem but i cant find direct x 9 in the download center.
    cloud you please help me find it for vista home premium?
     
    same problem but still need help, Dec 7, 2007
    #3
  4. Lowana

    Andy [YaYa] Guest

    Andy [YaYa], Dec 10, 2007
    #4
  5. Lowana

    BigAl050 Guest

    I had the same problem with age of empires I and II. I tried eveything
    you said Im stumped. Can you help me? Please?
    BigAl050
     
    BigAl050, Feb 10, 2008
    #5
  6. Lowana

    BigAl050 Guest

    Anybody
    I've tried everything but I still cant get AOE2 to work.
    Please,Please,PLEASE.
    Help Me
    Thank You
    BigAl05
     
    BigAl050, Feb 10, 2008
    #6
  7. Lowana

    Brian Guest

    I recommend you list your computer specs if this is a hardware driver problem.
    Are you running in 32 bit compatibility mode. Did you download the latest
    drivers from your hardware manufacturers website?

    I can tell you that AOE 2 does work on my 64 bit machine.
     
    Brian, Feb 17, 2008
    #7
  8. Lowana

    havoc5485 Guest

    hi im having a problem with the first age of empires and the rise o
    rome expansion everything installs fine but when i go to single playe
    it tells me to insert disk even tho it is already in there i have vist
    and was wondering if there were any solutions if u could please e-mai
    me anything that could help it would be very thankfull i tried the whol
    compatabilty tab thing to and vista isn't on it so thatnx for your tim
     
    havoc5485, Dec 14, 2008
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.