Virtual Disk Wizard minimized

Discussion in 'Virtual PC' started by nobody, Dec 14, 2011.

  1. nobody

    nobody Guest

    I'm running VPC 2007 SP1 on a Windows XP Pro SP3 system. I have used
    virtual disc wizard in the past with no problems. Today when I start it,
    it starts minimized and right-clicking on the icon in the taskbar does
    nothing. I tried uninstalling and re-installing VPC 2007 but it didn't
    help. The last time I shut down my virtual PC before this happened, VPC
    crashed and sent a report to Microsoft. What should I try next? Thanks!

    John
     
    nobody, Dec 14, 2011
    #1
    1. Advertisements

  2. nobody

    VanguardLH Guest

    One possible cause is that the window isn't actually minimized but
    hidden behind another window. Although a program should change the
    focus for its window (to be on top), sometimes that doesn't work or they
    forget to do that. You might find the wizard's wizard is underneath
    another window. Drag the windows off the side of the monitor (even so
    far as to only leave a small portion of their window on the screen) to
    see if the wizard's window was underneath.

    Are you using multple monitors or multiple desktops?
     
    VanguardLH, Dec 15, 2011
    #2
    1. Advertisements

  3. nobody

    nobody Guest

    I am using dual monitors, but I closed all other programs and still
    don't see the Virtual Disk Wizard window. The New Virtual Machine Wizard
    shows up normally, but not the Virtual Disk Wizard.

    Is there some way having dual monitors could contribute to this?

    John
     
    nobody, Dec 15, 2011
    #3
  4. nobody

    VanguardLH Guest

    I don't that dual monitors contributes to this problem only that I've
    seen other apps that opened a window and it showed up in the wrong
    monitor than expected.

    Another cause is you dragged the window completely off the screen. It's
    open but off screen. With a typical setup, dragging with a mouse means
    the mouse can only go to the screen edge so there will still be a pixel,
    or more, of one side of the window that you dragged over the edge.
    However, if you have virtual desktops, especially if they are setup to
    present a desktop that is larger than the monitor size (i.e., you have
    to scroll to see all of a desktop) or with dual monitor setup, the mouse
    might be configured to go off screen (into the oversized desktop area or
    to the other monitor). That means you could end up dragging a window to
    off screen and not be able to see it.

    When you right-click on the wizard's taskbar icon, what context menu
    entries are available?

    Try the following (which you will have to do in the blind):
    - Click the app's taskbar button to give it focus to its window.
    - Hit Alt+Spacebar. This opens the window's control menu (the leftmost
    icon in the window's titlebar).
    - Hit Alt+X. This is the key shortcut to the Maximize menu entry.
    - The window should maximize to the size of the current screen.

    If maximizing the window doesn't get it to show in the screen, or if
    restoring the window to normal size puts it off screen again, you could
    try moving the normal window from off screen to on screen:
    - Click the app's taskbar button to give it focus.
    - Hit Alt+Spacebar to open its control menu.
    - Hit Alt+M to activate the Move entry. You'll see the cursor change to
    a 4-way pointer (if the window were on screen).
    - Use the arrowpad keys to move around the window. Hold down the left
    or right arrow keys for awhile to see if the off screen window happens
    to roll into view, or the same for the up/down arrow keys.
    - When the window is in view, hit the Enter key to accept the new
    position (don't hit Esc as that undoes your Move and the window
    bounces back to where it was).
     
    VanguardLH, Dec 15, 2011
    #4
  5. nobody

    nobody Guest

    I finally resolved this problem!

    In the directory
    C:\Documents and Settings\<User>\Application Data\Microsoft\VirtualPC
    there is a file named Options.xml

    In that file there is a this section:

    <virtual_disk_wizard>
    <left_position type="integer">208</left_position>
    <top_position type="integer">229</top_position>
    </virtual_disk_wizard>

    Somehow the number in the left_position type section had become
    corrupted. It was about 10 digits long! Editing this file to change the
    number to a reasonable value fixed the problem. The Virtual Disk Wizard
    now appears onscreen when it is started and works correctly.

    John
     
    nobody, Apr 13, 2012
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.