Virtual PC 2004 not installing VM network services driver

Discussion in 'Virtual PC' started by Parp, Jan 13, 2005.

  1. Parp

    Parp Guest

    I get the error "Virtual PC could not open the Virtual
    Machine Network Services driver." everytime I try and
    install VPC 2004... My NIC is a Realtek 8169, I've
    installed the latest drivers (Dec 2004) from Realtek and
    still nada...

    OS is XP SP2, all updates.. the NIC is built into the mobo,
    but everything else works fine. VMWare Workstation worked
    fine.... but I uninstalled it as I thought it might
    conflict (as I did with Checkpoint SecurRemote, Sonicwall
    GVC, Cisco VPN Client) but still nada...
     
    Parp, Jan 13, 2005
    #1
    1. Advertisements

  2. Parp

    Parp Guest

    Fixed it.. Had to open up Network connections, right-click
    on the realtek connection and manually add a service to the
    card (using have disk, from c:\program files\microsoft
    virtual PC\utility\vmnetsrv)..

    Surprised no one asked if I had the latest network drivers,
    as that seems to be the only other answer I've found for
    this problem anywhere on the net....

    Anyway, hope my nightmare of getting this typical microsoft
    software helps someone else at least (where did I put that
    vmware cd)
     
    Parp, Jan 13, 2005
    #2
    1. Advertisements

  3. Yeah, that worked. Thanks !


    I'm glad that someone got this resolved. When Connectix owned VPC, I never
    had a problem. It wasn't until MS got a hold of it that it went downhill.
    However, they did add some nice features that allow easier use of VPC, and
    related to that, Virtual Server is a fine product. Hopefully this tip will
    get int he Microsoft KB to allow others in the future to resolve this issue.
     
    Andrew G. Fritz, Jan 14, 2005
    #3
  4. Parp

    Brian Baker Guest

    Thanks for the tip, I was able to do the same thing to fix my previously
    working installation of Virtual PC.
     
    Brian Baker, May 17, 2005
    #4
  5. Parp

    phillip9 Guest

    I tried manually reinstalling the service from (c:\program files\microsoft
    virtual PC\utility\vmnetsrv), but that did not work for me. Strange.

    I have also tried uninstallling VPC and reinstalling, with the same problem
    reoccuring (it looses the network services each time forcing me to manually
    reinstall them, but even that does not restore the networking)

    Does anyone have any other suggestions?

    thank you,

    phil
     
    phillip9, Jul 2, 2005
    #5
  6. Parp

    Steve Jain Guest

    Do you have the most current NIC drivers?


    --
    Cheers,
    Steve Jain, Virtual Machine MVP
    Website: http://www.essjae.com
    "This posting is provided "AS IS" with
    no warranties, and confers no rights.
    You assume all risk for your use.
    I am not am employee of Microsoft."
     
    Steve Jain, Jul 2, 2005
    #6
  7. Parp

    phillip9 Guest

    yes, sorry I did not say that before.

    I was able to just get it working a few minutes ago.
    1. uninstalled vPC from Add/remove programs
    2. restarted
    3. reinstalled vPC
    4. network services still not working
    5. ran the program files\vpc\utility\install.bat
    6. restarted
    7. still did not fix anything
    8. tried using (program files\vpc\utility\remove.bat
    9 restarted
    10. ran program files\vpc\utility\install.bat again
    11. still did not fix anything
    12. manually installed network services
    a. r.click on my network
    b. l.click properties
    c. l.click my network card
    d. install
    e. services
    f. browse . program files\vpc\utility\VMNetSrv
    installed VMNetSrv.inf
    13. vPC finally worked with the network.

    NOTE: I had done all this previously, except the Remove.bat (#8), so I
    suspect that must be the missing piece that got it to work this time. I also
    suspect many people don't use remove.bat, so that might be why so many
    other's are having this problem.

    Thanks everyone,

    phill
     
    phillip9, Jul 3, 2005
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.