Virtual PC -> Virtual Server -> Virtual PC = BORK

Discussion in 'Virtual PC' started by nak, May 23, 2009.

  1. nak

    nak Guest

    Hi there,

    As you can see from my extremely descriptive subject title I'm having issues
    with a VM that I have transported between virtualisation software.
    Basically I setup a system to 95% completion using Virtual PC 2007. It was
    working great. As I had just purchased my first server, I thought I would
    setup Virtual Server 2005 R2 and give that a shot. One I got it running I
    finished configuring Visual Studio, during this process I installed IIS6,
    the VM is an XP Pro SP3 based system.

    Anyway, after all of that I decided it would be better if I just run the
    whole thing from my laptop as usual, so copied it back to local disk. After
    doing this the VM won't boot correctly, I get to the login screen, enter my
    password, then BOSH, the damn thing resets and boots me out entirely before
    booting back up to the login screen.

    So my question is, is there some easy method to save this system? I would
    rather not have to setup all of the software again as that took a couple of
    days, although I do have a backup prior to installing the software on top of
    Windows which is still working fine, it's all of the additional software
    that takes the time.

    Any help would be greatly appreciated! BTW, I can boot up in safe mode no
    sweats.

    Nick.
     
    nak, May 23, 2009
    #1
    1. Advertisements

  2. What you're describing can happen on physical machines too.
    First, have you done a repair installation? You could be seeing
    problems from the differenent CPU/HAL changes from copying back and
    forth between multiple platforms.
     
    Steve Jain [MVP], May 24, 2009
    #2
    1. Advertisements

  3. nak

    nak Guest

    Hi Steve,
    Well if that's the case, I've certainly never experienced it lol! I
    tried a system restore to a point where it was working but that didn't give
    any joy, I shall try a repair from the CD ISO too and see how it goes.

    Cheers for the advice.

    Nick.
     
    nak, May 24, 2009
    #3
  4. nak

    nak Guest

    Hi Steve,

    I've been reading several sources on the net regarding the HAL. Is it
    possible to use "sysprep" to reset the HAL without having to perform a
    repair install? I'm not entirely convinced that doing a repair is going to
    keep everything working intact, considering the amount of patches /
    additional software that was installed on top of the base xp sp3
    installation.

    I'm reading about the tool on Microsofts support site at the moment,
    once I've had a go I'll post my results.

    Nick.
     
    nak, May 26, 2009
    #4
  5. nak

    nak Guest

    Before I tried sysprep I thought I'd try running the VM in the free VMWare
    Player, it all works fine and the OS actually detected the change and
    offered to reactivate Windows. So through the process of elimination I
    guess this is a Virtual PC bug. Now my VM is working fine, and believe it
    or not, faster than it was previously.

    Nick.
     
    nak, May 26, 2009
    #5
  6. Sounds good. Do you want to continue trying to get it to work with
    VPC or are you happy where you are?
     
    Steve Jain [MVP], May 26, 2009
    #6
  7. nak

    nak Guest

    Hi Steve,

    I think I'll run with this for a while and see how it goes, mainly as
    I've got a few deadlines approaching and can't really risk putting this
    newly built vpc out of action again. But for future reference, I now know
    to transport "copies" of the VPC between releases, as opposed to a sole vhd.

    Thanks for your time and help!

    Nick.
     
    nak, May 27, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.