VirtualPC: "An internal virtual machine error (13) has occurred."

Discussion in 'Virtual PC' started by Charles F McDevitt, Jul 15, 2005.

  1. I've been running Red Hat Enterprise Linux 4 under VirtualPC (with SP1) on
    an XP pro SP2 system.
    It was working ok, but I recently ran up2date on the linux box, which
    upgraded some of the software, and now I have a problem.

    Whenever I get to the point where linux tries to switch to graphical display
    mode, the VirtualPC gets an error:

    "An internal virtual machine error (13) has occurred." and "The virtual
    machine will reset now."
     
    Charles F McDevitt, Jul 15, 2005
    #1
    1. Advertisements

  2. It sounds like up2date changed your X11 driver. Boot to run level 3, login
    in text mode, and run your X11 configurator again. Some people have luck
    using X11's S3 driver with 16-bit pixels, some use X11's generic VESA driver
    with 32-bit pixels, and I use VESA but forgot how many bpp. The default X11
    S3 driver setting is 24 bpp, which the Virtual PC product doesn't properly
    emulate.
     
    Norman Diamond, Jul 19, 2005
    #2
    1. Advertisements

  3. I tracked this down to the newer version of xorg in Red Hat Enterprise Linux
    4 Update 1.

    For some reason, I can't use 1600x1200 resolution any more or it blows out
    the VM.

    I can get it to boot 1024x768 (16 bits per pixel), which is better than
    nothing,
    but doesn't work well with my monitor.
     
    Charles F McDevitt, Jul 19, 2005
    #3
  4. Charles F McDevitt

    Steve Jain Guest

    <conspiracy>
    Its because those Linux guys hate MS and anything MS and specifically
    coded xorg to fail under VPC!!
    </conspiracy>

    Sorry, could help doing a reverse conspiracy theory.

    What video card/driver are you selecting? The Trio64 or generic VESA?
    Also, have you tried a generic LCD panel of 1600x1200 for the monitor?

    --
    Cheers,
    Steve Jain, Virtual Machine MVP
    Website: http://www.essjae.com
    "This posting is provided "AS IS" with
    no warranties, and confers no rights.
    You assume all risk for your use.
    I am not am employee of Microsoft."
     
    Steve Jain, Jul 19, 2005
    #4
  5. I'm using the VESA generic driver, which worked with Red Hat Enterprise 4,
    but I've also tried the "s3" driver... Same problem.

    I'll try changing the monitor type, and see what happens, but I've already
    tried a couple settings without any luck.
     
    Charles F McDevitt, Jul 20, 2005
    #5
  6. With the Anaconda installer you should have the option during the post
    installation cleanup to pick a monitor type and resolution. Forget about
    what the real monitor is and choose Generic LCD and under that pick your
    resolution. Remember that you are working with a graphics card with only
    4mb of ram.
     
    Colin Barnhorst, Jul 20, 2005
    #6
  7. I'm not running Anaconda, since this was an already working system with a
    working Xwindows config.
    The problem started only after upgrading to RHEL 4 update 1.

    But I will try changing the monitor type to Generic LCD 1600x1200, and see
    what happens.
     
    Charles F McDevitt, Jul 20, 2005
    #7
  8. The Generic LCD option is the one that has been working best for virtual
    machines.
    Good luck.
     
    Colin Barnhorst, Jul 20, 2005
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.