Vista 64bit FSx trouble running

Discussion in 'Windows Vista Games' started by MaDbRiT, Feb 13, 2007.

  1. MaDbRiT

    MaDbRiT Guest

    I have Vista ultimate 64bit, when I install FSX it wont run properly, I keep
    getting a flashing screen, if I do a ALT/TAB then it works ok, but very slow,
    was much faster on XPpro.
    I have an amd 64 x2 dual core 4200, 3 GIG ram, Nvidia 6800le Graphics

    I thought this game was made to run in Vista, VERY disapointed in Vista.

    ANy help please, dont want to waste the money
     
    MaDbRiT, Feb 13, 2007
    #1
    1. Advertisements

  2. MaDbRiT

    Paul Smith Guest

    Be disappointed in nVidia's drivers, they're the most likely cause.

    --
    Paul Smith,
    Yeovil, UK.
    Microsoft MVP Windows Shell/User.
    http://www.windowsresource.net/

    *Remove nospam. to reply by e-mail*
     
    Paul Smith, Feb 13, 2007
    #2
    1. Advertisements

  3. I can almost guarantee that the problem lies in NVIDIA's drivers. They have
    been very buggy lately, but are working on getting a better version out.
    They better hurry, though!
     
    Dustin Harper, Feb 13, 2007
    #3
  4. MaDbRiT

    Adam Guest

    New Nvidia drivers were released yesterday. Hopefully that helps your
    situation.
     
    Adam, Feb 15, 2007
    #4
  5. MaDbRiT

    SoJoe Guest

    I am glad to hear i am not the only one having this issue that narrows things
    down quit a bit. I am experiencing the same problem with the video flickering
    during the loading Process from the OSD. then when in full video mode the
    video is basically not distinguishable at all until i do the window video
    mode and then it runs ok but had a better experience on XP 64 Pro OS. I am
    also dismayed by the fact that i no longer have the dual display mode
    function with none of my games. I have dual digital 19" LCD display which i
    used to run as one screen or span across both monitors. This function is no
    longer available with the video drivers and hence forth not available in any
    of my games. I suspect the vidia drivers as well and have sent Nvidia a run
    down on the issue and my system. I have built my system ground up and i am an
    A+ tech been working on pc's since the 80's and just upgraded to vista 64bit
    Ultimate. I am running the 4300+ AMD 64 x2 with the Nvidia 550 motherboard,
    2 gb 667 mhz ram, Nvidia 7600GT PCI express 16 Video Card, Sound blaster
    audigy 2 platnuim sound card. Also running the Avermedia TVHD MCE A180 Video
    card which also refuses to work. It will Totally Lockup and i can hear the
    TV. Fortunately i have a Dual boot OS to see that things do still work with
    my Old OS. Well i guess i can sleep a little better tonight, Thanks.
     
    SoJoe, Feb 16, 2007
    #5
  6. MaDbRiT

    SoJoe Guest

    Found this solution in another part of newsgroup and seem to work for me.
    Turn my graphics up full speed and looks great better than it has on the
    other OS. Now if we can get both monitors to work. I am a patient person.
    Have to be in this kinda hobby. Have to thank for workable solution for the
    time being.

    Subject: RE: Flight sim X 12/27/2006 10:14 AM PST

    By: Gerry In: microsoft.public.windows.vista.games


    I don't know whether this is related to your problem or not. I experienced
    problems running FSX when I enabled a second monitor with my Nvidia 7950GT in
    Vista x64 RTM. FSX would start but "Fly Now" would result in a corrupted
    display. I solved the problem by disabling the 2nd monitor when running FSX.

    I believe the issue is with the Nvidia beta driver for Vista. Your ATI
    driver may be having the same issues. If you have a second monitor attached
    to your system, try disabling it when running FSX.
     
    SoJoe, Feb 17, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.