Vista adds computername\ to username

Discussion in 'Windows Vista Networking' started by Poisondwarf, Oct 9, 2006.

  1. Poisondwarf

    Poisondwarf Guest

    Hi, I'm on RC2 7544 and am trying to map a network drive.

    When entering username and hitting connect, it adds computername\ to the
    username, giving:

    computername\username which cannot log in

    I can't change the username on the server to that as wouldn't accept \.

    How can I stop it adding the computername\ ?

    TIA

    PD
     
    Poisondwarf, Oct 9, 2006
    #1
    1. Advertisements

  2. Are you looking the network capture to see if the client is sending
    computername\username while authenticating ?

    There are two things you could try -
    (1) Explicitly specify <NAS_BOX>\<USERNAME> in the user prompt
    (2) Net use * \\<NAS_BOX>\share /user:<NAS_BOX>\<USERNAME>

    If both (1) and (2) dont work, it could be a issue with
    LmCompatibilityLevel.
     
    Prashanth Prahalad [MSFT], Oct 9, 2006
    #2
    1. Advertisements

  3. Are you looking the network capture to see if the client is sending
    computername\username while authenticating ?

    There are two things you could try -
    (1) Explicitly specify <NAS_BOX>\<USERNAME> in the user prompt
    (2) Net use * \\<NAS_BOX>\share /user:<NAS_BOX>\<USERNAME>

    If both (1) and (2) dont work, it could be a issue with
    LmCompatibilityLevel.
     
    Prashanth Prahalad [MSFT], Oct 9, 2006
    #3
  4. Poisondwarf

    Mike Boreham Guest

    I had the same problem.

    The following worked for me (pasted from an earlier post by a microsoft
    techie)

    Please try this:

    - Make sure you have file sharing and network discovery turned on from
    Control Panel -> Network and Internet -> Network and Sharing Center.

    Quote:-

    Also, try this:

    - Click Start
    - Click Control Panel
    - Click System and Maintenance
    - Click Administrative Tools
    - Double-Click Local Security Policy
    - In the left pane, click the triangle next to Local Policy
    - In the left pane, click Security Options
    - In the right pane near the bottom, double-click "Network security: LAN
    manager authentication level"
    - Click the drop-down box, and click "Send LM & NTLM - use NTLMv2 session
    security if negotiated"
    - Click OK

    endquote.
     
    Mike Boreham, Oct 10, 2006
    #4
  5. Poisondwarf

    Poisondwarf Guest

    Thanks Both,

    I'm afraid neither from both of your two ideas worked.

    I think it must be because we are not in a domain, but using Workgroups?
    (I've added the workgroup in).

    I've left the authentication changed as "Send LM & NTLM - use NTLMv2 session
    Any other suggestions?

    TIA

    PD
     
    Poisondwarf, Oct 10, 2006
    #5
  6. Poisondwarf

    Poisondwarf Guest

    Hi,

    It does now work using another users login!

    Changing the Network security: LAN
    solved it.

    Thanks for your help.

    PD
     
    Poisondwarf, Oct 10, 2006
    #6
  7. Poisondwarf

    Poisondwarf Guest

    Hi all,

    All solved now! Changing the security level was important to connect, and
    I'd been a muppet on the NAS, not making the user file sharing. Did that and
    now and it doesn't add the computername\ to the username.

    Thanks again for your help on the security settings.

    PD
     
    Poisondwarf, Nov 3, 2006
    #7
  8. Poisondwarf

    Roy Levow Guest

    Mike,

    I have a feeling this is going to be a common problem. I hope for others
    that MS gets it into the KB. Thanks for sharing it. The LAN security change
    completely solved my problem.

    -- roy --
     
    Roy Levow, Dec 30, 2006
    #8
  9. Poisondwarf

    ringzania Guest

    The fix described in this previous post won't work with Vista Hom
    Edition. I'm trying to access my work network through a VPN and once
    get through the Sonicwall to the network login Vista insists o
    prepending my computer name to my login user name which, of course, th
    network does not recognize.

    I've tried the registry fix to the lmcompatibilitylevel key by settin
    it to 1 and that hasn't helped either. Is there someplace else I shoul
    be looking? Any hints as to how I can fix the problem?

    To
     
    ringzania, Feb 13, 2008
    #9
  10. Poisondwarf

    digger Guest

    i had this problem with vista home premium on both computers in the
    network. First, I was denied permission to access. I added a password
    protected user to the host computer. Then I turned on all file sharing
    permissions in host's network and sharing center. I added a password to
    the "guest" computer's user log-on. I think it was at this point that I
    could get to a log-on, and it gave me that prefix "computer name/user
    name" problem. I then went to the guest computer's network and sharing
    center, and turned sharing on for the public folder. After that, I was
    able to log on to the host computer. I don't know why, that's what
    happened.:eek:
     
    digger, Sep 19, 2008
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.