Vista Administrator has "access denied" to 2nd hard drive?

Discussion in 'Windows Vista Administration' started by markymark7717@gmail.com, Feb 24, 2008.

  1. Guest

    Well trying to secure some files on a 2nd drive (D drive). I had set
    it up to block access to everyone but me (the administrator). Now even
    while logged on as the administrator I can't access the files on the
    drive. I get a message " D:\ is not accessible", "Access is
    denied"?????? What is up with that? So I tried to do a system restore
    but without getting into pointless details on that, it didn't work. So
    Trying to change the D drive security settings back to default I go
    into Properties, Security, advanced, everything appears to look good
    as the administrator is set to have "full control" of the drive. I
    tried a few other logical options on there but nothing has
    changed.Administrator is still denied access. So now that logic
    doesn't work, what now?
     
    , Feb 24, 2008
    #1
    1. Advertisements

  2. MC360 Guest

    Update...I tried logging in as God but thats still doesn't give me the
    authority to change anything.
     
    MC360, Feb 26, 2008
    #2
    1. Advertisements

  3. TCT Guest

    I'm having the exact same problem. Did you find a solution???
     
    TCT, Mar 6, 2008
    #3
  4. Russellz Guest

    I have a similar problem with Windows/XP.

    If I select 'My Computer' and double click the second hard drive I get
    "Access Denied". I can't find the blocker. No problem with the first hard
    drive.

    However, if I select 'Start', 'Run' and 'Browse', I can browse the drive
    easily. Also, no problem if I access from an application such as Word or if I
    access from the network.
     
    Russellz, Mar 9, 2008
    #4
  5. MC360 Guest

    Well......I have restored access to "D drive". The solution......no
    clue. I haven't done anything I didn't try before. Actually I had
    given up on it for a while but decided one day to see if more
    repetitive tinkering would end in the same failure as before...this
    time it WORKED!!!!! Why it worked this time and not the 20 previouse
    attempts I can not say. For something that should be pretty straight
    fwd & logical...my gut feeling is that its a Vista issue. Perhaps one
    of the recent updates solved the problem? conclusion....No clue.
     
    MC360, Mar 11, 2008
    #5
  6. MC360 Guest

    Oh...as I play this Vista game once more....I am now once again denied
    access to drive D, which I had full access to for the last 4 days now,
    including this morning. So back to more pointless tinkering and
    waisting my time with Vista issues since they wont just fix
    themselves...do they?
     
    MC360, Mar 14, 2008
    #6
  7. MC360 Guest


    Well...I found a solution to the problem. Disable the User Account
    Control (UAC) feature.See the attached link for details. Not the
    perfect fix but its a start.
    http://www.petri.co.il/disable_uac_in_windows_vista.htm
     
    MC360, Mar 15, 2008
    #7
  8. help123 Guest

    Hey Man

    I am not sure exactly what you did , but I went into properties o
    accounts and in security tab I make changes in the access to drive the
    when I logged back it said to me Access Denied on c drive even though
    was administrator.

    Now what I did was , I restarted my windows went into safe mode i.e b
    pressing F8 key before windows normal startup screen appears then I ru
    (run command from start) on run I typed regedit then went to EDIT men
    top next to File menu then in permissions I add one user (in my case
    had guest user already on so I put that user and give all access to tha
    user) after that I run win vista in normal mode and went to gues
    account and right click on C drive which said Access Denied then i
    properties , then security and then finally clicked on Authenticate
    Users and click edit to make changes and allow all the features then i
    said me access denied or can't do it I continue to press (continu
    comand) as many times it came then finally I logged into my origina
    administrator account and got access to my drive and every thing wa
    back to normal.

    I hope it will work for u too I was too frustrated but thank to God i
    worked
     
    help123, Oct 17, 2008
    #8
  9. LadyDaisy Guest

    I finally just turned of UAC. I could not even delete my own favorite
    folders I had made myself or organize them.
     
    LadyDaisy, Oct 20, 2008
    #9
  10. avares Guest

    You have to give "yourself" permission to see the second hard drive
    :)
    Do the following, I just copied and pasted from the link
    http://www.tech-recipes.com/rx/2204/vista_how_to_take_ownership_system_file/

    First you will need to access an elevated command prompt, to do this:

    1. Click the Start button.

    2. Click All Programs.

    3. Go into Accessories.

    4. Right-click on Command Prompt.

    5. Select Run as administrator.

    6. When the UAC Prompt appears, click Continue.

    Once you have your elevated command prompt, follow these steps:

    For our example, we are going to use the Bubbles screensaver fil
    (Bubbles.scr)

    1. At the command prompt, input takeown /f filepath (takeown /f d:).

    2. Press Enter on the keyboard.

    3. A message will be displayed that this completed successfully.

    4. Now input icacls filepath /grant yourusername:f (icacls d: /gran
    avares:f).

    5. A message will be displayed that this completed successfully.

    You will now be able to modify or replace the file. When you are done
    simply remove the permissions to keep the file secure
     
    avares, Jan 9, 2009
    #10
  11. Dan Wakeman Guest

    I found this to be true with Windows Server 2008 R2 also. R2 defaults to UAC enabled. R1 did not. The dialog box text gives no indication at all that UAC is involved. It just says "access denied" so every reasonable IT person looks at security and permissions. Turn off User Access Control. A reboot is required.

    Sorry for bumping an old thread, but I figured the 2008R2 relation was worthwhile.
     
    Dan Wakeman, Jan 10, 2011
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.