Vista can't copy files from network share on XPPro

Discussion in 'Windows Vista Networking' started by MDaniel, Dec 12, 2006.

  1. MDaniel

    MDaniel Guest

    I have an XP Pro machine with a folder shared with full control for
    everyone. All other machines, regardless of Windows version, have no
    problem accessing this share with full control. I've installed Vista
    Ultimate RTM on two machines and have had the following problem on both:

    Both Vista machines can read/write/execute files that are in that
    network share. For example, if its a .pdf, .txt, or .doc, I can double
    click it from the Vista machines and it opens just fine with the
    appropriate application. If its an .exe, like the installer for Firefox,
    it'll launch and install the program. I can also save and delete files
    and folders on that network share from the Vista machine. So far so
    good.

    The problem is with simply trying to copy a file from that share TO the
    Vista machine. I get an error message titled "Destination Folder Access
    Denied" that reads "You need permission to perform this action". It
    doesn't matter where I copy the file to. Desktop, Public, Documents,
    etc. Same thing. So I can open/execute it, but I can't copy it.

    This happens on both Vista machines. I have enabled the Public folder on
    both Vistas and they can copy files to/from each other. And the XP
    machine can copy to/from the Vistas' Public folders.

    I am an using the same administrator account on all machines. The
    problem is the same whether I use Vista's explorer or command prompt.

    I haven't found much on Google but I did try disabling UAC, firewalls on
    all machines, and even IE7's Protected Mode without any success.
     
    MDaniel, Dec 12, 2006
    #1
    1. Advertisements

  2. I have seen the same thing only when copying from the Vista machine.

    I would be interested in what the final outcome is.
     
    Michael Price, Dec 12, 2006
    #2
    1. Advertisements

  3. MDaniel

    Surya64 Guest

    in the networking and sharing center there is a setting called "Password
    protected Sharing". If you set this to false, then it will start working.
    By default it is set to On so only people with user id and password on the
    destination machine can access it. If you turn it off you should be fine.
    (of course anybody on your network will have access to that as well).
     
    Surya64, Dec 13, 2006
    #3
  4. MDaniel

    MDaniel Guest

    No, the problem is not with network users accessing files on the Vista
    machine's shares. I'm using the same admin level accounts on all
    machines and that part works fine. The problem is with Vista accessing a
    share on an XP machine (which it can do) and then copying a file from
    that share to the Vista machine. Reading/writing/executing on the share
    work, but simply copying a file to the local (Vista) hard drive fails.
     
    MDaniel, Dec 13, 2006
    #4
  5. MDaniel

    BVH Guest

    I''ve got the same problem with a 2003 share... Everything is working fine I
    can copy to the share, edit files on the share but the second I try to copy
    or move off the share to vista I get the "Destination Folder Access Denied"
    "You need permission to perform this action" error.. Kinda sounds to me like
    the *Destination Folder* on the Vista machine is the one blocking the copy
    the file!

    I did find out that if I copy a file from Vista to the share and then copy
    it back everything works fine with that one file or folder...

    I'm at a total loss I've spent the last 3 nights doing nothing but searching
    the web for answers and trying everything I can think of that might affect a
    share like this. I really don't understand how more people aren't having
    this problem. My business partner is getting the same thing on his home
    domain and we get it at our office as well?!

    Is anyone else having any problems copying / moving a file from a 2003 or XP
    share onto the Vista machine? Did none of you backup your XP workstation or
    laptop data on a share and then want to copy it back over after you
    installed Vista?

    My only guess is there is a common sharing misconfiguration with a hand full
    of people and the rest of working fine or that no one actually transfers
    files between there computers anymore.. :)

    Benjamin VH
     
    BVH, Dec 13, 2006
    #5
  6. MDaniel

    MDaniel Guest

    Yeah this one's really got me stumped too. I work on other people's PCs
    all day long figuring out things like this and I'm drawing zippo on this
    one. It seems like it would be a common problem too. You throw Vista on
    a spare computer, connect it to the LAN, try to grab a file off a share,
    and BOOM: brick wall.

    FWIW, I'm pretty sure I didn't do anything exotic during Vista's setup.
    Its pretty much defaults. I set the workgroup name and username/password
    to match my existing LAN, and told Vista that this is my home network.

    My wild guess is that is some new security "feature" somewhere that
    we're not finding. It reminds me a little of when you download an .exe
    file from the Internet with IE6 on XP-SP2 and when you try to run it, it
    denies access. Then you have to go into its property sheet and tell it
    that its OK. Its like Vista doesn't quite trust the XP/2003 machine over
    the network and doesn't want the user, even an admin, to bring over
    potentially hazardous files.
     
    MDaniel, Dec 13, 2006
    #6
  7. MDaniel

    BVH Guest

    It's not an enabling sharing issue. We're connected FROM Vista *TO* XP /
    2003 Server Share. We can see the files, the folders everything is working
    great. I can copy to the share and delete stuff.. The second I try to move
    something off the XP / 2003 Share onto the Vista share I get you don't have
    premissions errors...
     
    BVH, Dec 15, 2006
    #7
  8. MDaniel

    BVH Guest

    MDaniel,

    I've got some breaking news on this problem! I took my laptop to our
    office.. I unjoined it from my home domain as I would rather it not be on
    one anyway.. So I'm in a workgroup setup now everything is still bugging out
    at home with the shares.

    I connect to the office network UNC over to a share off our file server to
    test..
    Prompted for username and password and poof I'm on..
    So far the same as home.
    Now I try and copy off something from the share and you know what.. It
    worked.. Just copied right over!! I was so happy and pissed off all the same
    time!

    So with that said I've not had time to look at what's different between the
    domains yet.. I will however on Saterday and let you know what I find out..

    Benjamn VH
     
    BVH, Dec 15, 2006
    #8
  9. MDaniel

    MDaniel Guest

    Just so I understand what you did:

    The Vista machine is in workgroup mode as opposed to being a domain
    member and you're logged into it locally with credentials that don't
    exist on the domain at work. So when you tried to access a share at
    work, it prompted you for credentials, and after you entered a name and
    password, it worked?

    Here's the results of another test I did:

    My machines are all in a workgroup, not a domain. Neither has even been
    joined to a domain. I've been using the same username/password on both
    the XP and Vista machines but for this test, I logged onto Vista using a
    name and password that don't exist on the XP machine.

    Logged on the Vista with this other name/password, I entered the UNC
    name of the XP machine into the address bar and a list of its shares
    came up, but I couldn't open any of the shared folders. It didn't ask me
    for a name and password. It just said access denied until I granted the
    guest account priveleges on this share from the XP machine.

    So I went to a command prompt and issed the following:

    net use p: \\xp_machine\share_name /user:mike *

    It prompted me for mike's password (Mike is my main admin account on the
    XP machine) and it created the mapped drive. But I had the same problem
    copying files from it as I had before when I was simply logging on to
    Vista as Mike. *sigh*

    Oh, I also tried right clicking the command prompt and running it as
    Administrator. I mapped my xp share to a drive and got the same thing. I
    can only copy a file from it if it was created on the Vista machine. So
    it doesn't seem to be a permission, UAC, or Explorer issue.

    I did some more Google searching and found one hit about someone having
    the same problem on Vista x64 but no solution.

    Mike
     
    MDaniel, Dec 15, 2006
    #9
  10. MDaniel

    MDaniel Guest

    Whoa, I think I just made a discovery. My Vista machine is a laptop
    that's dual booting with the older WinXP installation. When Vista's
    running, its installed to C drive and it sees XP's C drive as D which is
    also an NTFS partition. The file copying access denied also happens when
    I try to copy files from the network to the D drive. So its not just
    protecting the system drive.

    BUT, I plugged a flash drive into my Vista machine and had no problem
    copying files from the network share to it. Once on the flash drive,
    Vista has no complaints copying the files from there to the desktop or
    the D drive.

    Since I can't format this flash drive to NTFS and I can't install Vista
    onto a FAT32 partition right now, I don't know exactly what's going on,
    but I'm suspecting some new Vista NTFS black magic.

    The other machine I experienced this on was a brand new machine onto
    which I installed Vista on an NTFS partition created during setup. I
    don't have possession of that computer anymore but I just built myself a
    very similar one and once the memory arrives on Monday, I'll be able to
    play around some more. Unless someone wants to install Vista on a FAT32
    drive and see what happens.

    Mike

    PS. I just fired up Win98 in a virtual machine on my main XP Desktop and
    shared a folder to the network. Vista has no problem copying files from
    the Win98's share which is of course on a FAT32 volume.

    I always thought that the underlying file system of a network share
    didn't really matter across the LAN. After all, Win9x machines, which
    can't access NTFS volumes, have never had a problem accessing NT/2K/XP
    shares on an NTFS volume across the LAN. But now it appears that Vista
    doesn't like to copy from a share on an NTFS volume to an local NTFS
    volume. If either side is FAT32, the copying works. Great. Lets all go
    back to an outdated and insecure file system just so Vista will play
    nice on a LAN.
     
    MDaniel, Dec 15, 2006
    #10
  11. There are a few interesting issues with UAC when logged on with an
    "administrative" user account, particulalry in Domains. For example, it is
    essentially not possible to use a different user account and be "elevated"
    at the same time.

    I've found it considerably easier to use a Domain user account that is NOT
    an administrator on the Vista computer. Then, when you really need to do
    something administrative, you get a prompt for a different user account, not
    just the "elevation" prompt and you can supply a different Domain or local
    user account for that process.

    Have you tried logging on with a Domain user account that is NOT an
    administrator on the Vista computer - do you get the same problem?
     
    Bruce Sanderson, Dec 18, 2006
    #11
  12. MDaniel

    MDaniel Guest

    This is not a UAC or domain issue since I've disabled UAC and don't have
    a domain in this case. I've logged on to Vista as an admin, even "the"
    Administrator, and a normal user. I've run a command prompt as admin or
    normal user and used DOS commands to try to copy files. I've even
    created a new folder on the C drive and ensured that NTFS permissions
    gave full control to everyone, authenticated users, users,
    administrators, guest, and even specific user accounts. Neither the XP
    machine I'm trying to copy files from nor the Vista machines that are
    accessing the share and trying to copy files have ever been members of a
    domain.

    This isn't a simple NTFS or sharing permission issue. I've been working
    with permissions long enough to know how to deal with them. No other
    machine on the LAN running any other version of Windows using same logon
    accounts has ever had any problem copying files from a network share.

    The Vista machine, given the appropriate NTFS permissions on the shared
    folder on the XP machine, can read, traverse, modify, write, execute,
    delete, etc files/folders on the shared folder. The only problem is with
    actually copying a file. Its weird that I can execute/open a file, but I
    can't simply copy it. So how is it that I get "access denied" only when
    copying a file from a network share (where I have full control) to a
    folder on my hard drive (where I have full control)?

    The only variable I've found that has any affect on the issue is the
    file system on one side or the other. If I plug a FAT32 flash drive into
    the Vista machine, I can copy files from the network to it no problem.
    When I shared a folder from a Win98 machine (of course FAT32), I had no
    problem copying a file from it to either NTFS volume on the Vista
    machine. Its just when the network share is on an NTFS volume, AND I try
    to copy it to an NTFS volume on the Vista machine do I get denied
    access. But a two step copying (network share -> local FAT32 drive ->
    local NTFS drive) goes OK.
     
    MDaniel, Dec 18, 2006
    #12
  13. Sorry, Mike, but I'm somewhat stumped. I just tried what I understand your
    scenario to be between an XP SP2 and a Vista RTM 32 bit computer at home and
    can not reproduce your problem. It's not much help, but I suspect something
    unusual about your Vista installation. I've been using Vista and XP SP2 at
    home and in the office and been able to copy files back and forth without
    any problems, except that the Vista file copy function seems to be somewhat
    slow!

    Here's the scenario I just tested at home:

    1. Logged on to the Vista computer
    2. created a new folder under the root of the C partition
    3. changed the permissions (NTFS) for the new folder to Users, Modify
    4. in Start, Run, keyed the \\ followed by the name of the XP SP2 computer
    5. got a prompt for credentials
    6. supplied the credentials for the XP SP2 computer
    7. Explorer opened showing me the shares on the XP SP2 computer
    8. opened one of the shares
    9. using drag and drop, copied files from the share on the XP SP2 computer
    to the newly created folder on the Vista 32 bit RTM computer

    On the Vista computer, I was logged on with a local user account that is a
    member of the Adminstrators group. UAC is on. The Vista install is a brand
    new, clean install of Vista RTM Ultimate. In Network and Sharing Center:
    Network Discovery is On
    File Sharing is On
    Public Folder Sharing is Off
    Printer Sharing is Off (no printers installed)
    Password protected sharing is On
    Media Sharing is Off

    I've not made any adjustments to the Firewall or other security stuff.

    The Vista and XP SP2 computers actually have different names for their
    Workgroup.

    Perhaps someone else has some suggestions. I'm going to be away for about
    the next 10 days and will most likely be newsgroup disconnected for the
    duration!

    Merry Christmas and a Happy New Year!
    --
    Bruce Sanderson MVP Printing
    http://members.shaw.ca/bsanders

    It is perfectly useless to know the right answer to the wrong question.
     
    Bruce Sanderson, Dec 19, 2006
    #13
  14. MDaniel

    MDaniel Guest

    After a lot more detective work, I think I've finally figured it out. It
    has something to do with Kaspersky Antivirus running on the XP machine
    and NTFS ADS (alternate data streams). ADS isn't something I think about
    much but its existance is filed away somewhere in my brain. I also
    remember that one time when I needed to uninstall Kaspersky, it asked if
    I wanted to remove the ADS data so I know they must use ADS.

    So here's the deal: If Kaspersky's realtime monitor is running on the XP
    machine, it must add ADS data to every file. Vista pukes when it
    encounters this and forbids copying the file to its own NTFS volumes.

    Back on XP: Snoozing Kaspersky, moving a file from the C drive (NTFS) to
    a FAT drive (where ADS is stripped), then back to the C drive, allows
    Vista to copy the file over the network. Kaspersky MUST be disabled
    during this operation and MUST NOT be re-enabled before Vista copys the
    file. Also, simply snoozing Kaspersky isn't enough: You must move the
    file through a FAT32 volume to strip the ADS data before Vista will
    accept it.

    I'm running Kaspersky Antivirus Personal 5.0.391 on the XP computer with
    it set to automatically download all updates from the Internet. I don't
    see any program patches on their web site or any help pages that
    describe this problem.
     
    MDaniel, Dec 20, 2006
    #14
  15. MDaniel

    BVH Guest

    HOLY GOD MAN!! You rock! I've got Kaspersky on my 2003 Server and my XP
    machines! I do have a question however... I wonder if you have Kaspersky
    enabled and then copy a file to a FAT32 Drive and then back do you still get
    the access errors??

    The fact that you're coping files to FAT32 share and back means that your
    clearing the entire premissions structure off the files and then rewriting
    on the copy back..

    I'll play around with this Kaspersky route on our stuff and see what
    happens. I do however have Kaspersky running on my Office Domain as well
    with no problems there. But the settings are very likely different on the
    KAV install at my house and my office.

    More to come. Sorry for the delay things have been crazy with Family and
    what not.

    Benjamin VH
     
    BVH, Dec 20, 2006
    #15
  16. MDaniel

    MDaniel Guest

    After copying a file from the NTFS drive to a FAT32 drive and back to
    the NTFS drive (with Kaspersky snoozed during the process), the file
    will be copyable from the NTFS share. Once I re-enable Kaspersky, its
    "access denied" again, even if I don't touch the file from XP.

    I just did another experiment: I snoozed the AV, then edited the
    permissions on a single file on the NTFS share. I broke inheritance,
    cleared the ACL, then created a new ACE with full control for everyone.
    Vista still won't copy it. The file must be copied through a FAT32
    volume with the AV snoozed to become copyable by Vista.

    Mike
     
    MDaniel, Dec 20, 2006
    #16
  17. In my case, it would appear that I have a similiar but different
    problem.

    I can copy from Vista to an XP machine only. However, when I am on the
    XP machine, I cannot copy the same files from the Vista machine. I too
    have hit a brick wall on this one.

    I don't think it is an Antivirus issue because even with the AV turned
    off on both I was still having the same problems with files that had
    never been touched on the vista box before.

    Anyone have any other ideas?

    John
     
    John_H_Bergman, Dec 20, 2006
    #17
  18. MDaniel

    BVH Guest

    Mike,

    Kk. I have a couple minutes to mess with this finally. Life has been
    crazy with family and work.

    I'm currently uninstalling KAV off my server completely. One thing to keep
    in mind is that my Office network is running KAV as well however everything
    works great, the only difference that I currently know of is that the Office
    KAV is a much newer version then the one here @ my house.

    OK... I've removed KAV completely from my Server and everything is WORKING
    prefectly now! I'm testing the same on my XP desktop.
    Next test is to reinstall KAV with the lastest version on my Desktop
    assuming removing it works on XP as it did on Server 2003.
    Ok... I've now reinstalled KAV on my XP Desktop with the lastest and
    greatest version and I'm getting blocked again. According to KAV the
    "iStreams" is the ADS agent. I didn't install this option on reinstallation
    and I'm still getting blocked... We're a reseller for KAV and have access to
    higher level techsupport which I've put in a request to.

    I'll see what they say but don't expect anything back until afer the
    holyiday weekend.

    I'll keep posting more as I find it out. Now I just need to activate Vista
    till my action pack copies get here.

    Benjamin VH
     
    BVH, Dec 22, 2006
    #18
  19. I'm running Avast on my Vista x64 box, and Panda on my XP box.
    uninstalled panda, and there was no change. I'll try uninstallin
    avast soon to see if that makes a difference there too
     
    John_H_Bergman, Dec 22, 2006
    #19
  20. So, I put a copy of XP in a Virtual Machine, fresh with SP2 and all the
    hotfixes... I can copy from the vista machine from within the XP
    environment inside the VM. Has any one else encountered such issues?
    I am not sure what the differences could be between a fresh install,
    and one that was tainted with an anti-virus that is now uninstalled,
    but still unable to copy from vista.
     
    John_H_Bergman, Dec 24, 2006
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.