Vista client lost connection to secure wireless network ?

Discussion in 'Windows Small Business Server' started by Xavier, Nov 23, 2008.

  1. Xavier

    Xavier Guest

    Hello,

    Customer network description: SBS2003 Std SP1. 2 NIC configuration. 2 CISCO
    Aironet Access Points. Wireless secure network configured as per Owen
    Williams whitepaper ( http://home.comcast.net/~clearviewtc/ ). 15 wireless
    clients (14 XP SP2 and one Vista) have been using this network without any
    issue for 2 years now.

    We are adding to this network 4 new laptops. These laptops are Dell Latitude
    D531 (with Dell Wireless 1395 802.11 b/g). We have installed Vista SP1 from
    scratch on these systems along with the latest drivers from Dell. We have
    joined the systems to the domain and added them to a group called "Wireless
    Domain Computers". Thanks to that, upon reboot, the system do get
    certificates and wireless configuration. At that point it can connect to the
    secure wireless network. So far so good. But here comes the weird issue
    we're facing: we have switched on and off the wireless button on the laptop.
    Since we've done that, the computer does not connect to the wireless network
    anymore (even after several reboots).

    When looking at the adapter in the network sharing centre, we do see the
    following message (approx. translation from French): "The parameters
    registered on this computer do not correspond to the required configuration
    for the network".

    We have re-re-installed one of the computer, we have installed the latest
    network drivers, we have successfully tested the wireless card with a test
    (wep protected) wireless network.

    I must admit that I am now clueless. Any hint, help or pointer would be
    highly appreciated.

    Xavier
     
    Xavier, Nov 23, 2008
    #1
    1. Advertisements

  2. Sounds like you need to delete out that Wireless network config for that
    specific configuation and set it up again.

    I see that type of error when I've had a saved config for a Linksys and
    then I try to connect to another Linksys and the security settings are
    different.
     
    Susan Bradley, Nov 23, 2008
    #2
    1. Advertisements

  3. Xavier

    Xavier Guest

    Hello Susan,

    By "deleting out that Wireless network config for that specific configuation
    and set it up again" do you mean flattening out the AP configs, the IAS
    configuration, etc. and redo all that configuration work ? That is going to
    ask some time and effort that can only be planned for a week-end. If you
    mean deleting the configuration on the PC itself, this has been done a
    couple of times and it didn't help.

    What drives me crazy is that the whole configuration is pushed through GPOs
    and as worked flawlessly for 2 years. Over time we have added a few laptops
    to the original network without any issue. In the mean time I found the
    exact translation of the error message: "*** the capability of this network
    adapter does not meet the requirements of this network ***" and if I check
    the adapter I do find back WPA-Enterprise, TKIP, etc... which are the
    technologies used by the infrastructure.

    Xavier
     
    Xavier, Nov 23, 2008
    #3
  4. Not on the server side, I'm talking about on the workstation side.
    There's a saved config on the workstations that sounds like it's gotten
    corrupted.
     
    Susan Bradley, Nov 23, 2008
    #4
  5. In the wireless properties on the laptop - you should see a list of wireless
    networks the PC has connected to, with your local wireless at the top. Just
    deleted it from there (sorry, I don't have wireless on this box to tell you
    the exact steps to get there).

    If your implementation is working on the rest of the PCs, please resist the
    temptation to change anything on the server or the WAPs. Last time I ran
    into this on a Dell with Intel NICs, it was a bad NIC. The laptop would
    connect flawlessly to my guest network (unsecured), but not to the secure
    network that's configured according to Owen's documentation. I ended up
    talking Dell into replacing the NIC, which fixed it. I've also had driver
    issues and, occasionally, a cert issue. If it's the cert, you should see
    auto enrollment errors in the application log on the laptop.

    I don't know how exciting a prospect this is for you, but one idea might be
    to swap the NICs between two of the laptops. If the problem follows the
    NIC, you'll know for sure. (If these things all have the same NIC driver,
    you can easily rule that out as well). At least on the ones I've worked on,
    changing the NIC is easy if you follow the documentation.
     
    Dave Nickason [SBS MVP], Nov 24, 2008
    #5
  6. Xavier

    Xavier Guest

    Hi Dave,

    We have found that we face a driver issue here:

    We reinstalled the PCs with XP: works fine so it can't be a bad NIC issue
    We tested the PCs with Vista and another NIC (spare PCMCIA Linksys): works
    fine

    We'll contact Dell to check if they can provide us with some other driver or
    we will see if we can order Intel NICs and put them in the laptops.

    Thank you for your help,

    Xavier
     
    Xavier, Nov 26, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.