Vista & Data Exception Prevention (DEP) - HOW DO I SHUT OFF FOREVER

Discussion in 'Windows Vista General Discussion' started by caroladavies, Oct 25, 2007.

  1. caroladavies

    caroladavies Guest

    Hi

    My question is simple ... how the heck do I remove/delete/turn off
    permenatly DEP?

    It's interfering with a lot opf programs that access the internet for
    them to work - I just want it gone or at least turned off for
    everything.

    My computer has VISTA for operating system

    Please Help Me
     
    caroladavies, Oct 25, 2007
    #1
    1. Advertisements

  2. From Michael:
    Disable DEP in Vista:
    Type or copy and paste this into an elevated command prompt window:

    bcdedit.exe /set {current} nx AlwaysOff

    Hit enter and you should see the confirmation: Operation Completed
    Successfully
    Reboot and DEP should be off.

    Use bcdedit.exe /set {current} nx AlwaysOn
    to turn it back on.
     
    Andre Da Costa[ActiveWin], Oct 25, 2007
    #2
    1. Advertisements

  3. caroladavies

    R. C. White Guest

    Hi, Caroladavies.

    Could you give us some examples of the programs that do not work? At least
    one?

    I've not turned off DEP, and none of my programs have any problems with
    accessing the Internet.

    RC
    --
    R. C. White, CPA
    San Marcos, TX

    Microsoft Windows MVP
    (Running Windows Live Mail beta 2 in Vista Ultimate x64 SP1 beta v.275)
     
    R. C. White, Oct 25, 2007
    #3
  4. caroladavies

    MICHAEL Guest

    MICHAEL, Oct 25, 2007
    #4
  5. You're wasting your time no-one ever says what they have a problem with its
    always some random programs. The closest I got to an answer was some Borland
    Delphi programs might give trouble. Its a shame really as a list of problem
    programs would be useful.
     
    [email protected], Oct 25, 2007
    #5

  6. Another example of Dennis showing his "intelligence". There is no
    no-one. It is either 'no one' or more appropriately 'nobody'. Followed
    by your other stupid but typical mangling of the language saying:
    "...what they have a problem with its always..."

    I got to ask, you finish sixth grade Dennis? Between you and Frank
    you're constant incoherent babbling and mauling of the language is
    very annoying.
     
    Adam Albright, Oct 25, 2007
    #6
  7. caroladavies

    Frank Guest

    Hey butt-munch...you think this is some kind of an American English
    class? Guess what as*hole, the entire world is here! Get use to it you
    little pig. As long as your message is understood, grammar is irrelevant.
    You do understand, right?
    Frank
     
    Frank, Oct 25, 2007
    #7
  8. Everyone understands you are a proven liar and village idiot in any
    language.
     
    Adam Albright, Oct 25, 2007
    #8
  9. caroladavies

    Frank Guest

    Fukkin drunk & lying again mr prius?
    You're a pig!
    Bet you understand that fact!
    Frank
     
    Frank, Oct 25, 2007
    #9
  10. Really starting to scrape the bottom now aren't you Adam.
    You are beginning to sound more like the loser Frank likes to taunt all the
    time.
    BTW they don't have sixth grade here but as usual you are so stuck up your
    jacksie you don't know that there is a world outside your head.
     
    [email protected], Oct 25, 2007
    #10
  11. Actually I'm well aware there are damn fools like you all over the
    world as you prove daily.
     
    Adam Albright, Oct 25, 2007
    #11
  12. caroladavies

    Frank Guest

    Hey butt-munch...how does it feel to be the fukkin village idiot fool of
    this ng.
    Tell us mr prius.
    Frank
     
    Frank, Oct 25, 2007
    #12
  13. I ran into the dep issue with Quake 3, which was quite difficult to ge
    working on Vista Ultimate 64. With the DEP turned off it runs fine. M
    question is is there a way to just create an exception in the comman
    prompt for that program so that I can have DEP turned on and still ru
    it
     
    Inspectorjimb, Jan 11, 2009
    #13
  14. caroladavies

    Moonraker0 Guest

    I don't know about the Command Prompt, but you can create an exception
    for a 32-bit program with Computer→System Properties→Advanced System
    Settings→Performance→Settings→Data Execution Prevention.
     
    Moonraker0, Jan 11, 2009
    #14
  15. Thanks, I actually figured it out. That screen you mentioned was locke
    down. I needed to enter in the command prompt to set nx to optin rathe
    than always on. Once that was done I was able to enter the program int
    the selection list on the dep screen
     
    Inspectorjimb, Jan 12, 2009
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.