Vista does not recognise USB mouse

Discussion in 'Windows Vista Hardware' started by Aaron B, Dec 3, 2007.

  1. Aaron B

    Aaron B Guest

    I was using Vista Ultimate 32bit with this Dell system with PS/2 mouse.
    I bought a new USB mouse to replace the broken mouse.
    But when power up Vista, it does not recognize this new USB mouse.

    I check this USB mouse at my laptop, and this mouse works fine.

    How can I make Vista to switch from PS/2 to USB mouse?
    Thank you.
     
    Aaron B, Dec 3, 2007
    #1
    1. Advertisements

  2. Have you tried the Mouse on the different USB ports located on the system?
     
    Andre Da Costa[ActiveWin], Dec 3, 2007
    #2
    1. Advertisements

  3. Aaron B

    Aaron B Guest

    Yes, I tried all 4 slots of USB. Same results.
    However, I can use these same USB slots to connect to my flash drives.
     
    Aaron B, Dec 3, 2007
    #3
  4. Aaron B

    Ian D Guest

    This shouldn't affect things, but you never know, - is legacy USB
    support enabled in the BIOS? Did your USB mouse come with a
    USB to PS/2 adapter you can try?
     
    Ian D, Dec 4, 2007
    #4
  5. Try booting with both mice installed and see if it finds it then.
     
    the wharf rat, Dec 4, 2007
    #5
  6. Oh, good call! I bet that's it.
     
    the wharf rat, Dec 4, 2007
    #6
  7. Aaron B

    Destin_FL Guest

    Something I have found true almost every time in Vista that I don't remember
    having to do in XP.... I don't say it as a bad thing, just a lesson I have
    learned over the past couple of weeks with Vista.

    Go to Device Manager and 'scan for hardware changes' - XP was nearly
    flawless about rebooting, and there magically was your new hardware device,
    but Vista will not do that. You have to force Vista to scan the system for
    the new hardware, i.e. changes.

    I installed a new/separate/additional hard drive (internal, in a bay next to
    the main drive) and tried 47 ways from Sunday to get the drive to show up.
    Not in device manager, not in disc management, nowhere... reboot reboot,
    blah blah blah.... finally went into device manager and did Scan For Changes
    and the drive showed up immediately. Kind of a DUH moment for me.

    I had to do the same thing to get a PCI card of USB ports to show up. I
    suspect your mouse may be the same deal.

    Tim
     
    Destin_FL, Dec 4, 2007
    #7
  8. Aaron B

    Robin Guest

    Do you know if "scan for hardware changes" is on all the Vista versions? I
    can't find it on home premium.
     
    Robin, Dec 4, 2007
    #8
  9. Robin,
    It doesn't show up unless you have highlighted an item ('Desktop' for
    instance).

    Michael
     
    Michael Walraven, Dec 4, 2007
    #9
  10. Aaron B

    Destin_FL Guest

    The way I am arriving there: Click the Start Orb > go to Computer >
    right-click on "Computer" When you right-click, choose Manage.

    Wonderfully what you'll see in your device manager and also you disc
    management. So let's say youre looking for an device, say a hard drive that
    isn't showing in Device magr OR disc managment. Very odd......... BUT......
    happily there is a solution.

    In the devise manager, highlihght the grouping where the new hard drive
    should be, Upon hightlighting disc drives in Device Manager, right0click
    and scan for hadware changes,

    Works like charm for finding all sorts of contrary devices!!

    T
     
    Destin_FL, Dec 4, 2007
    #10
  11. Aaron B

    Aaron B Guest

    I tried this same mouse with PS/2 adapter to my other computer running XP.
    This mouse works, both ways with PS/2 adapter and USB plug.
    The problem is this new Vista computer does not pick up the USB connection.
     
    Aaron B, Dec 4, 2007
    #11
  12. Aaron B

    Aaron B Guest

    This Vista computer only able to pick up the PS/2 mouse.
    It does not recognise the USB mouse.
    Even this same USB port works with my flash drive.
    This same USB mouse works on my XP laptop.
     
    Aaron B, Dec 4, 2007
    #12
  13. Aaron B

    Aaron B Guest

    But I am unable to do anything with the USB mouse plug in. Becuase this
    Vista
    does not recognize this mouse. Without a mouse, I am unable to open device
    drivers.
     
    Aaron B, Dec 4, 2007
    #13
  14. Aaron B

    Aaron B Guest

    Unable to click anything when I got no mouse.
     
    Aaron B, Dec 4, 2007
    #14
  15. control-escape, and then use arrow keys and return to select!
     
    the wharf rat, Dec 4, 2007
    #15
  16. Here is a kludge of the first order, but it might work.

    Use your USB/PS2 to start up with the ps2 mouse configuration.
    Get to device manager and get ready (highlight the scan for hardware).
    Unplug the ps2 configuration, plug the mouse into the USB then using the
    keyboard 'click' the button (usually the space bar or the enter key).

    Michael
    Vista Home premium
     
    Michael Walraven, Dec 4, 2007
    #16
  17. Aaron B

    Aaron B Guest

    I just tried. I can move from icon to icon, but nothing else works in Vista.
     
    Aaron B, Dec 4, 2007
    #17
  18. Aaron B

    Maximus Guest

    I'm having a similar issue with a few devices, but when I scan for hardware
    it finds them. Issue is it then searches for drivers. These are devices
    which should be plug and play, no drivers provided. However it just keeps
    asking for me to insert CD with drivers. Any thoughts?
     
    Maximus, Dec 5, 2007
    #18
  19. Aaron B

    DellCA Guest

    @AaronB-

    This is John, a support analyst at Dell headquarters.

    There are a lot of good suggestions here in this thread, and I
    apologize for taking so long to find it. You may need to get and use a
    PS/2 mouse in order to fix the problem, since it is a lot easier to
    follow the suggestions given by everyone if you can use a mouse.

    John
    Dell Customer Advocate
     
    DellCA, Dec 10, 2007
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.