Vista Home Premium: New user account failing to load user profile

Discussion in 'Windows Vista Administration' started by Metajoe, Jan 4, 2009.

  1. Metajoe

    Metajoe Guest

    I am trying to set up a standard user profile on my laptop for my mom to
    use because personally I do not want her to be snooping around in my own
    profile when she uses it for school. So, I went into the control panel
    and created a NEW account for her. I didn't have any problems doing
    that. I set up folder permissions and then went to test the new user
    and although it took awhile for Vista to prepare the account, I got in
    and an error message came up about how some Vista email client failed
    and pressed OK and I let it sit for awhile and nothing else came up. So
    now if I try to log into that account, it gets stuck at a blank blue
    background. I opened up the task manager and tried running
    explorer.exe, but it wouldn't start. I've also tried pulling up
    services.msc, but that won't come up either. So I'm rather clueless as
    what to do next and Googling for this problem hasn't helped me find any
    fixes for it either.

    Anyone have any ideas as to what is causing this and what I can do to
    make it work?

    Thanks in advance to anyone who can help me out here.
     
    Metajoe, Jan 4, 2009
    #1
    1. Advertisements

  2. The phrase 'set up folder permissions' sounds like a possible problem. If
    you changed the standard permissions you might have changed them enough that
    Vista can no longer perform correctly on those files.

    Remove the account.
    Go to c:\users and delete the folder that was created.

    Create the account again. This time leave ownership and permissions of the
    files alone. After the account is fully set up and running then you can
    consider changing permissions etc .

    Michael
     
    Michael Walraven, Jan 4, 2009
    #2
    1. Advertisements

  3. Metajoe

    Metajoe Guest

    I deleted the account and folder and tried again. Same thing. Som
    mail error message comes up and nothing happens afterwards. The onl
    processes that I saw running in the task manager were;

    csrss.exe
    dwm.exe
    taskmgr.exe
    winlogon.exe

    That's it. Tried pulling up explorer.exe and that failed. No errors
    but it wouldn't actually start up
     
    Metajoe, Jan 4, 2009
    #3
  4. Sounds like the template that is used to create a new user has become hosed.
    I THINK that is at c:\users\Default
    (need to show system/hidden files). It might be that if you rename that
    folder it MIGHT recreate it with default settings. However you should
    probably wait and get better advice from someone who knows more. Sorry that
    I was a dead end for helping you.

    Michael
    (BTW, you are more likely to get assistance if you include problem and
    replies in each message. They can get pretty long but then someone seeing
    the conversation can step it and help. For instance from parts of the thread
    included here, no one would know what your problem is or what other things
    you have tried.)
     
    Michael Walraven, Jan 5, 2009
    #4
  5. Metajoe

    Metajoe Guest

    What would cause the template to go haywire on me then? And what abou
    that "Default" folder? What would I have to rename it to? I alread
    have a folder for the account I created.

    No, no, it's ok, at least you've tried to help me. Of all the othe
    topics I've made for this, the only other person to reply offered a
    encryption program for my account to use, which is a last resort fo
    me.

    So thank you for throwing out an idea and replying to this thread.
    appreciate any help I can get. Vista doesn't seem to be an OS peopl
    are willing to help others with, from what I'm seeing.

     
    Metajoe, Jan 5, 2009
    #5
  6. I would rename to something like OldDefault

    A point: Have you modified the security for the system? I.e. have you turned
    off UAC, changed permissions/ownership for system controlled area? ( It
    helps others to understand your configuration).
    Also do you have virus/malware protection programs that purport to 'protect'
    your system from changes? Turning off or disabling these features may help.

    Looking out on web there seem to be others with similar problems but I have
    not seen solutions.

    Here are a couple of more ideas, well worth their cost.

    in regedit,
    HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
    open the various S-1-5-..... until you find the one that has c:\users\your
    new user as 'ProfileImagePath', delete this entry. (the entire S-1-5-.....)

    Make sure that there aren't any more profiles with this entry.

    delete the c:\users\your new user folder entirely.

    shutdown and restart

    verify that there is no c:\users\your new user or entry in the registry that
    you deleted

    now try to create the new user


    Also if (whoops - when) you get your problem solved do post back what you
    did to solve it!!! The next person would be much appreciative.


     
    Michael Walraven, Jan 5, 2009
    #6
  7. WARNING WARNING WILL ROBINSON

    I tried renaming the Default directory. (The cook should eat his own bread).
    I lost my PS-2 mouse, no response just arrow in the middle of the screen.

    I got the mouse back by:
    Power down (not restart).
    Removed mouse
    Powerup until system was ready for user/password
    Power down
    Plugged mouse back in.
    Powered up, mouse was ok.

    Powering down/up with without removing the mouse did NOT find the mouse.

    Sorry about that....
    Michael


     
    Michael Walraven, Jan 6, 2009
    #7
  8. Metajoe

    Metajoe Guest

    I see that folder rename idea didn't work for you, so I doubt it'd wor
    for me.

    I have UAC off and have Windows Defender and AVG running basically fo
    protection, so I don't know if they'd have anything to do with it.

    Yeah, I looked around online first before registering an account her
    without much of a lead anywhere.

    And I'll try that Regedit thing either tonight or tomorrow morning.
    It's almost 11pm here.

     
    Metajoe, Jan 6, 2009
    #8
  9.  
    Michael Walraven, Jan 6, 2009
    #9
  10. I put the folder name back before I ever got to trying making a new account
    so don't actually know how that would have worked out.

    I would try putting UAC back on while you try to create the new user, you
    might get some usefully clues from what it natters about. I think AVG is
    just an antivirus, but I haven't used it for several upgrades so don't for
    sure about that either. Windows Defender will protect the system from
    changes and you might try disabling that. Would think that it could handle
    add a new user OK but stranger things have happened. (I lost my old tube
    monitor last night, just coincidence but if I didn't already know it was
    failing I sure would have been suspicious that my fooling around did it -
    like my mouse).

    Michael

     
    Michael Walraven, Jan 6, 2009
    #10
  11. Metajoe

    Metajoe Guest

    I tried both the regedit and the UAC thing. Neither worked. I did a
    little more hunting around for msoe.dll because the mail error was that
    that file could not be initialized. I found a thread about it that
    relates to my problem
    @ 'Login in as User MSOE.DLL could not be initialized : Windows Vista
    Setup : Windows Vista IT Pro : Microsoft TechNet Forums'
    (http://tinyurl.com/a5g6te)

    I tried this (3rd post down on thread):

    "The problem has been resolved in my case. The last things I did was
    disable user account control, run the sfc /scannow command-line tool
    (which couldnt find any problems), create a new user account and log in
    with it in safe mode. Then starting up Windows normally, I was able to
    successfully log on with this account. The configuration of Windows
    Mail completed now. Hope it wont come back."

    And it failed. The error went away, but nothing loaded afterwards.

    And now my attention is on this post (4th post down on thread):

    "...On the third call to Microsoft, we brought in an ADS specialist and
    in ten minutes, he identified the original problem. The users were
    members of the Domain Guest user group. This does not affect the users
    running Windows XP, but a Vista user is then locked into a mandatory
    profile. So any changes that a user makes are not saved when they log
    out. Simply removing the users from the group and running a gpupdate
    corrected the problem. It was such a simple resolution, but what a
    very long and painful path to get there."

    Now, I did a little searching and discovered that in Vista Home
    Premium, you cannot access the user groups application with MMC
    apparently. But I'm unsure about whether users can do it through the
    command line. I know you can do it through there, but I don't remember
    how.

     
    Metajoe, Jan 6, 2009
    #11
  12. I am familiar with the 'net' command for adding/removing/controlling user
    accounts.

    try net ? for hints

    net user test /add
    will add a user

    net user test /del
    will remove the user

    run the command in an elevated command prompt window.

    net user 'name'
    towards the bottom will report the local and global groups that the 'name'
    user is a member of.

    I have assumed that you are not a member of a domain, where there is a
    centrally controlled 'domain controller'. Based on that assumption there
    should not be any 'global groups'. If you are in a controlled domain, then I
    understand that the owner of the domain controller is who will have to add
    users and such (I am not a member of a domain so if you are most of my
    advice is not useful).

    Michael


     
    Michael Walraven, Jan 7, 2009
    #12
  13. Metajoe

    Metajoe Guest

    I added a user and it wasn't part of any domain and I looked at th
    account from before and it was the same thing. Part of the norma
    users group as well. So yeah, I'm stumped. I can't spend any mor
    time with it either unfortunately. So I'm just going to encrypt an
    hide the files I don't want to be seen to anyone else. Thanks for th
    help though, I really appreciate it.

    Sorry we couldn't go any further with this problem. I'd love to, but
    just don't have the time anymore.

    Maybe someone else with this problem can help it continue. Like yo
    said, there are others who have this problem that could certainly use
    fix like I do.

    So if there is anyone out there watching this thread that has the sam
    or very similar problem, PLEASE keep this thread going so you ca
    figure out this conundrum of Vista.

     
    Metajoe, Jan 7, 2009
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.