Vista Indexing slows EVERYTHING down(or maybe something else)

Discussion in 'Windows Vista Performance' started by JoeF, Nov 21, 2007.

  1. JoeF

    JoeF Guest

    I have a Core 2 Duo 6700 2.66Ghz, 4GB RAM, gigabit network, 10K rpm SATA
    drive, and Windows Vista Ultimate 64-bit OS with all Vista updates applied.

    It is joined to a Small Business Server 2003 Premium R2 domain and using
    Offline files (Default).

    EVERY time I Restart the computer, it takes about 30+ minutes of the
    harddrive grinding away and slowing down everything to a very frustrating
    point. I imagined it was the indexing taking place and ran 'Indexing Options'
    and removed all entries except for MS Office Outlook 2007 and Startmenu. I
    only care about Outlook Instant Search capability.

    I restarted and the same problem exists.
    After running the Resource Monitor, the disk and Network sections are close
    to the 80% level. When expanding the Disk section and sorting by ascending
    Disk Reads, the following details exist:

    svchost.exe (local SystemNetworkRestricted), Pid-400,
    C:\Windows\CSC\v2.0.6\namespace\DomainServername\Users\USERNAME\MY
    Documents.....(There is a long list of files after this)

    When sorting by Ascensding Disk WRITES, the same image and Pid exist,
    however; the file is C:\$LogFile (NTFS Volume Log).

    I don't understand why this is happening and desperately want to eliminate it.
    As of now, I just leave the computer powered ON but if I have to install a
    new app which requires a restart, I'm not able to work efficiently until 45
    minutes later.

    Please, please, please help me!

    -JoeF
     
    JoeF, Nov 21, 2007
    #1
    1. Advertisements

  2. Indexing is a low priority background job. It should not have very much
    effect on responsiveness of your system (it does do a lot of disk access
    though).
    I am not connected to a domain, so cannot help there.

    Michael
    Vista Home Premium
     
    Michael Walraven, Nov 21, 2007
    #2
    1. Advertisements

  3. JoeF

    Sandy Guest

    Why not just turn it off entirely. I did and it cut WAY down on the HD
    activity. It sounds to me like the time you might be saving on searches
    using Indexing is less than the extra time it would take to do non-indexed
    searches. In any case it might be worth a try just to test the differences.
     
    Sandy, Nov 21, 2007
    #3
  4. JoeF

    MK19 Guest

    How do you turn off Indexing in Vista? It is not a service like in
    XP...
     
    MK19, Nov 21, 2007
    #4
  5. I advise you not to switch off indexing. There's no way it could be having
    such an enormous effect on a computer of that spec.

    I read somewhere (I'm sorry, I can't remember where) that there is a known
    bug causing this exact behaviour, and I seem to recall it has something to
    do with Microsoft's automatic updates system. I think I also read that they
    are having real trouble chasing it down.

    I'm sorry I can't be more specific, but maybe this might trigger a memory in
    someone else, or perhaps help you focus your search a little bit.

    SteveT
     
    Steve Thackery, Nov 22, 2007
    #5
  6. JoeF

    Rick Rogers Guest

    Hi,

    Check properties of a drive/volume, the option is on the general tab.
     
    Rick Rogers, Nov 22, 2007
    #6
  7. JoeF

    Sandy Guest

    Actually I think it is. You can disable each drive individually by right
    clicking on it and unchecking the appropriate boxes but I believe you also
    have to go into Administrative tools/ 'services' and change the setting for
    "Windows search" to "disabled". At least that is what I did. It made a big
    difference for me. I am not a pro at this stuff so I can only tell you what
    worked for me and also that AFAIK all the disabling I've described is
    completely reversible if you see no improvement.
     
    Sandy, Nov 22, 2007
    #7
  8. JoeF

    JoeF Guest

    It's very frustrating. I have duplicated/triplicated(Is that a word?) the
    exact same problem on different installations of Vista Ultimate 32, 64,
    upgrades, etc...

    It is a Dell Dimension 9200. I thought it may have somethingto do with
    Symantec System Recovery 7.0, so I uninstalled it. - The same problem exists.
    Like I said, when I leave it on, it works great. Forget about restarting it,
    unless I do it before going to bed.

    Since the Disk usage and network usageseem to have a correlation, I think it
    may lie within a domain configuration. What exactly is this referenced path:
    "C:\Windows\CSC\v2.0.6\namespace\...."


    -JoeF
     
    JoeF, Nov 22, 2007
    #8
  9. JoeF

    caretaker Guest

    Before I would do anything I would run the CCleaner or similar, as it
    looks more like a software problem
     
    caretaker, Nov 22, 2007
    #9
  10. JoeF

    Adam Guest

    Are you sure it's the indexing which is giving you this problem? I had a
    machine which I upgraded from XP to Vista, and that was very, very slow for
    30 minutes or so after a reboot. It turned out to be the Superfetch
    service. If I switched this service off, the system ran fine. It might be
    worth trying that to see if it fixes the problem, although of course it
    means you won't get the advantage of Superfetch (which, is only an advantage
    if it works!). Your problems certainly sound very similar to the ones I
    had.

    Unfortunately, In my case, the only way I could fix the problem was to do a
    fresh install.

    I did also have another problem with 2 different Dells which caused Outlook
    to run very slow. This turned out to be the "Cyberlink Outlook Addin" which
    is preinstalled on most Dells I think. Uninstalling this also spend things
    up.

    Good luck,
    A.
     
    Adam, Nov 22, 2007
    #10
  11. Like I said, when I leave it on, it works great. Forget about restarting
    This is strange, and is way too severe for the indexing. Of course, the
    biggest disk activity after startup is actually Superfetch doing its thing,
    but again this uses the lowest CPU and I/O priority settings, so it's hard
    to blame it for such a severe slow down. Some slow down, yes, but not like
    you are reporting.

    I'm sorry I can't be more helpful.

    SteveT
     
    Steve Thackery, Nov 22, 2007
    #11
  12. JoeF

    caretaker Guest

    If you had Symantec System Recovery 7.0 on it, than you may have t
    uninstall it using the removal tool. It's a nigthmare lol. afte
    reinstall- uninstall, reboot 2 times
    then run CCleaner or similar, reboot and run CCleaner again. I prefe
    CleanMyPc but CC should work lo
     
    caretaker, Nov 22, 2007
    #12
  13. JoeF

    FeynmanFan Guest

    "C:\Windows\CSC" is where Windows stores files marked for offline use. "CSC"
    stands for Client Side Caching.

    Don't know if that helps at all, but I'm seeing the same slowdown with
    references to that directory in Process Monitor.
     
    FeynmanFan, Dec 13, 2007
    #13
  14. JoeF

    Denlyn Guest

    Windows Vista Indexing is perhaps the worse case of resource hogging
    that Microsoft has ever released. Consider this scenerio.........

    You log onto the internet, search for, say cookies, and all of a sudden
    you have to wait until the search is done. This may take between .563
    seconds to 2.170 seconds.

    Look at indexing in Vista and the results are perhaps the same. The
    problem with this is that the indexing is always searching and always
    storing that information ready for instant access.

    Regardless of what anybody states, indexing does slow down a PC and I
    have done several tests with this pain in the rear application.

    The first was done on a fast computer.
    The second was done on a medium computer.
    and
    the third, on a slow computer.

    I will let everyone decide what is fast, medium and slow as each
    individual will have their own sense of what is fast.

    For those that don't have a problem, they most likely will have a fast
    computer. With saying that, they will undoubtedly notice a jittery mouse
    movement or the response time of clicking on a button will have
    diminished by a fraction.

    Not everyone has a super fast computer.

    To turn off indexing is easy.

    Go to control panel.
    Indexing.
    Advance.
    and untick all the files that have a tick in the box next to it.
    Some files will require you to untick them twice as they are a
    protected system file.

    In the main window of Indexing, remove whatever is showing so as the
    box is empty.

    Go to Hard drive.
    C:/ drive
    Right click.
    Properties
    and Untick "Index this drive for faster searching"

    Go to Control Panel.
    Administrative tools.
    Services.
    and disable Windows Search.

    Restart the computer and no indexing is running.

    As stated, it does effect the computer in many ways and does slow down
    the running of Vista.

    My $0.02 worth.

    Cheers
     
    Denlyn, Dec 14, 2007
    #14
  15. JoeF

    Tony565 Guest

    JoeF,

    As some of the other posters have said you can disable and shut down Vista's
    indexing. The constant wear and tear you'll save on your hard drives is more
    than worth the extra second or two added to your searches. The info is as
    follows:

    Disable Windows Search Service
    This method stops and disables all search indexing processes, and is the
    recommended way.

    1. Click the Start button, then select Control Panel -> System and
    Maintenance -> Administrative Tools, and double click on Services applet.
    Alternatively, simply type “Services†(without quotes) in Start Search box.
    2. If User Account Control asks for permission, click Continue.
    3. Locate the service named Windows Search. Right click on it and then
    select Properties on the menu.
    4. Click on Stop button to stop the indexing service immediately.
    5. On the Startup Type dropdown box, select Disabled.
    6. Click on OK button.

    To re-enable the Windows Search, simply change back the Startup Type to
    Automatic and restart your computer.


    Disable Indexing on Drives
    This method allows users to selectively disable indexing on certain drives
    that are rarely used or searched. However, it may take a long time to apply
    new attributes to all files, folders and sub-folders to exclude them from
    indexing.

    1. Click the Start button then select Computer from the Start Menu.
    2. Right click on the drive (or drive letter) that you want to turn off the
    indexing.
    3. Select Properties on the contextual menu.
    4. Unselect (uncheck) the Index this drive for faster searching option.
    5. Click Apply or OK button.

    To re-include the drive, simply select the option again and click OK.

    I hope this clears things up for you.

    Tony565
     
    Tony565, Jan 10, 2008
    #15
  16. JoeF

    Denlyn Guest

    Although in longer form............

    ...........Didn't I just say that? :shock:

    XP and Vista are basically the same (I do say BASICALLY) and with that,
    the majority of the system can be very similar excepting with a few name
    changes.

    I am sure if no one understood what I meant, they would have replied
    and I would have given them an indepth walk-through.

    Why do people do that?

    Oh' well, who am I to argue with.

    Cheers.
     
    Denlyn, Jan 10, 2008
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.