Vista-Lexmark USB Communication Failure

Discussion in 'Windows Vista Printing / Faxing / Scanning' started by Castagnola, Dec 3, 2009.

  1. Castagnola

    Castagnola Guest

    Hi,

    I have an HP Desktop PC that has had a Lexmark X3650 All-In-One (no
    wireless) attached via USB for almost a year now without problem. The P
    has auto Windows Update and an HP driver update switched on.
    On either 26/11/09 or 27/11/09 the PC had done a windows Update an
    reboot. My next attempt to print on 27/11/09 was met with a "Canno
    Communicate" error, the print queue shows the request with no status
    The printer icon shows as offline.
    Here's what I've tried:
    Reboot the PC, power off/on the printer, disconnect/reconnect the US
    cable, check other devices work on that USB port and cable, print tes
    page from printer menus OK, print photos OK from PictBridge an
    flashdrive/SD cards on printer. Tried the front USB port on th
    printer.
    As there was no difference in comms, I downloaded a cleanup utility an
    the latest driver from Lexmark, ran the cleanup (reboot) and started th
    driver install. At the point where the install requires connection o
    the USB cable I connected the cable and... nothing.
    I tried other USB ports and cables but the PC does not recognise tha
    the printer has been plugged in.
    I tried the Windows Fix-It utility that checks the spooler etc., i
    reported no problems.
    I rolled back to before the dates above unsing Windows Restore but n
    improvement, infact when I boot now I get a FaxMan error and Printe
    Device error, presumably because of the failed re-installation of th
    Lexmark drivers.

    Can anyone suggest what to try next? Is my printer USB fried or is i
    Vista simply not playing ball
     
    Castagnola, Dec 3, 2009
    #1
    1. Advertisements

  2. 1. Try another USB device on the same port that the printer was on. Does
    the 'other' device work?

    2. Try the Lexmark printer on another PC (ask a friend if you only have the
    single PC). Does it work?

    Now you should have a clearer idea about where the problem lies.
     
    Cari \(MS-MVP\), Dec 3, 2009
    #2
    1. Advertisements

  3. Castagnola

    Castagnola Guest

    Hi,

    I tried a camera, a mobile phone, a mouse and a PDA in the USB port,
    all of which worked once Vista reloaded the drivers.

    I'll need to take the printer to a friends house to test on another
    PC.
    Watch this space.
     
    Castagnola, Dec 3, 2009
    #3
  4. Castagnola

    Castagnola Guest

    OK.

    I tried the printer on another PC - no response from the PC at all.
    returned the printer to the shop as it was still under warranty, an
    they replaced it with a new one which fired up as soon as I plugged i
    into my PC.

    Thankyou for the advices - I really thought it was Vista playing up.

    For all readers - only the USB had gone down on the Lexmark X3650; al
    other inputs eg PictBridge, SD card, Flashdrive etc. and th
    scan/copy/print functions were OK. The printer itself reported n
    failures.

    Happy Printing
     
    Castagnola, Dec 7, 2009
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.