Vista loses drivers

Discussion in 'Windows Vista Hardware' started by harmonp, Jun 29, 2007.

  1. harmonp

    harmonp Guest

    Why is it that Vista can't hang on to drivers that have been successfully
    installed. I have an HP laser printer and an HP All-in-One. Both have Vista
    drivers which have been installed and both work correctly...for a while.
    Periodically, Vista says it needs to look for new drivers, then it can't find
    the drivers, and I'm tied up for hours trying to get Vista to recognize one
    printer or the other. Sometimes Vista (Ultimate) loses track of the USB
    printer drivers and sometimes it is the Scanner driver. I had to buy all new
    printers/scanner to work with Vista, and yet I have to spend hours keeping
    them connected properly in Vista.
    harmonp, Jun 29, 2007
    1. Advertisements

  2. harmonp

    freddy Guest


    Some folks have had good luck resolving issues like you have by deleting the
    INFCACHE.1 file, which can get corrupted with bad data and cause issues. The
    file is located at C:\Windows\inf. There, scroll down to the INFCACHE.1 file
    and right click it and select delete. To do this, you will likely have to
    give yourself permission to delete it, because of Windows built-in security
    you know. Just right click the file, select Properties and then click on the
    security tab. Let us know whether this procedure does anything. Sometimes
    it does and sometimes not.
    freddy, Jun 29, 2007
    1. Advertisements

  3. harmonp

    harmonp Guest

    Thanks for your response. Last night before I turned off the computer, I
    deleted the INFCACHE.1 file, and this morning when I turned the computer on,
    both the laser printer and the all-in-one worked fine. I hope they continue
    to work. I noticed that Windows did not re-create the INFCACHE.1 file. I
    take it the file is not necessary.
    harmonp, Jun 30, 2007
  4. harmonp

    freddy Guest


    Vista likely will recreate the file when it has a need for it, such as when
    it doesn't know what to do with unrecognizable inf files.
    freddy, Jun 30, 2007
  5. harmonp

    partenope Guest

    freddy and all,

    I installed a PNY OPTIMA Attache' 2 gig memory stick. My upgraded (Vista
    Home to Vista Ultimate) Dell lost the connect.

    I tried finding drivers on re-install in C:\Windows (and subfolders).

    I found a reference to wpdfs.inf in the registry, but the only occurrence of
    THAT that I find is a zero byte file, " Mstf_User_WpdFs....... " in

    I have deleted INFCACHE.1 file and get no recognition.

    I assume I have a "lost driver." Anyone have any ideas? I can't get any
    memory sticks to work in the machine.

    Thanks for any assistence.
    partenope, Jun 30, 2007
  6. harmonp

    freddy Guest


    Plug in the memory stick and look in Device Manager to see how it is
    recognized there. Device Manager should show the device three times, as

    1. Under Disk Drives
    2. Under Portable Devices
    3. Under Universal Serial Bus controllers as a USB Mass Storage Device

    Note any indication of errors, such as a yellow bang (!), or any other
    indication of a problem. In Device Manager, follow any any suggestions for
    resolving any problem indicated. Post back on results.
    freddy, Jul 1, 2007
  7. harmonp

    partenope Guest

    In the meanwhile, I tried reformatting the stick. I got the "Open File /
    Optimize Memory" option window briefly before the Windows found new hardware"
    window opened.

    Re-plugging it, I get []? Other devices
    []! USB 2.0 FD

    ( [] represents the icon, also in the tray, Found New Hardware)

    Device status This device is not configured correctly (Code 1)

    (No changes, nor links to the device under:

    Disk Drives and Portable Devices have:
    USB HS-xD/SM
    ... USB Device (under Disk Drives)
    and ... Card (under Devices, except the last, "USB
    HS-xD/SM "

    Universal Serial Bus controllers have
    General Purpose USB Hub
    M/S Internet Keyboard Pro Composite Device
    2 Standard Enhanced PCI to USB Host Controllers
    5 Standard Universal PCI to USB Host Controllers, and,
    7 USB Root Hubs

    No indications of problems besides the Other Devices - USB 2.0 FD.
    partenope, Jul 1, 2007
  8. harmonp

    freddy Guest

    Good morning partenope,

    I'm having difficulty following your descriptions. For example, I don't
    know what USB HF-CF or any of the other similar descriptions mean, such as
    USB 2.0 FD, etc. In summary, it appears to me that Vista is recognizing the
    drive, but is having a problem with the way it's configured, judging from the
    Code 1 you have.

    The Optimize Memory window you're getting is Windows trying to tell you that
    you can use the drive as a ReadyBoost device. This is OK. You can choose to
    use the drive in that manner or not. If you don't know about ReadyBoost, you
    can use google to learn more. I'm using a 2 GB USB SanDisk as a ReadyBoost
    device, and I've not had any problem with it, so I know that Vista can work
    with these USB type flash drives.

    At this point, I'd suggest you contact the manufacturer's tech support, if
    they have one, to determine what they say about the configuration of the
    drive. I don't know what configuration the drive should have. Did the drive
    come with any instructions about that? You may also try using google to see
    whether you can find any information about that issue. Likely others have
    posted about this on the Internet, if they have had a problem.

    Also, peruse the manufacturer's website for any information on what the
    story is about this drive. Did the drive come with any pre installed
    software? If it did, that can cause a conflict with Vista, as it's likely
    not compatible with Vista. I'm just not familiar with this device. You can
    also try viewing the drive in Vista's Disk Management utility: Right click
    Computer (formerly My Computer), select Manage and then select Disk
    Management. The drive should show up there and perhaps it will display some
    indication on the status of the drive and thus give you a clue as to what is
    wrong with it.

    I think my flash drive is formatted in FAT 32, and Vista has no problem with
    that. In Disk Management, you may try formatting the drive in FAT 32 to see
    whether that solves the problem. Just some suggetions. Post back on the
    results you get.

    freddy, Jul 1, 2007
  9. harmonp

    partenope Guest

    Ok.. "magical" thinking here. I'm struggling at the edge of my knowledge,
    and I'm hoping that you're close to omniscient.

    I'll explain with details embedded, below.

    Those are the built-in Dell 13-in-1 card reader: Compact Flask, SD card,
    and, I assume, whatever other memory cards.
    That is the PNY Optima Attache 2 GB memory stick in question. The one I
    bought because my other memory sticks weren't being recognized, and it was
    labled "Vista Ready."
    I should point out that I only got it once (or maybe twice) but I didn't act
    on it fast enough to get the computer to use it for that session. (more
    info below)
    Yes. Excellent idea. After I started researching the web for my problem,
    I initially thought that may be the ONLY use for it. I have 2 Gig of
    onboard memory (and slots for 2 gig more, and I've had a dozen apps open in
    their own windows in addition to all the background items running, so I
    assume that I'm good for now in the memory department.
    Manufacturer says it's Vista compliant, that I should call M/S tech support.
    Google finds several references to XP problems. Possible solutions,
    delete INFCASH.1 (did that), reformat flash drive (did that), finally, there
    was a Windows Vista Magazine registry tweak (
    in my case.

    "Change Device Status to 2, ReadSpeadKBs and WriteSpeed KBs to 1000."

    A few readers had success with that. At first I found no such entry, just
    now I did -- but no success.
    It did show up there one time, when I clicked on "open file." I managed to
    copy a few files to it, and assumed (hoped) that the problem had magically
    gone away (perhaps because I was now using a Vista ready device and Vista had
    "figured it out." But, it went back to "New Hardware Found" and eventually
    "Device Driver software was not successfully installed" after finding nothing
    on my hard drive, in Windows Update, or "on the web" (where ever Vista looks).
    I found mine as FAT 32 on my XP computer, and reformatted it there. The
    Volume Name wasn't accepted as "USB 2.0 FD" (spaces and period), so I
    changed it a bit. Vista still recognizes USB 2.0 FD under other devices. I
    don't get to the point where I can read the volume name.
    Thanks! I really appreciate your tackling this (and, so far, am enjoying
    the challenge, myself).

    I still suspect there may be an answer in this near mythical "wpdfs.inf" --
    but I only find it a couple places in my registry (in connection with the PNY
    flash drive), and allusion to it in my temp file, and a asian site (with
    mostly, I believe, Asian characters) on Google. Nothing from Search all of
    partenope, Jul 1, 2007
  10. harmonp

    freddy Guest


    Well, I can say that you should not need any drivers for this device, other
    than those that Vista automatically assigns to the device. So, you should
    stop thinking along the lines of there could be a driver you need to
    download. The only exception would be if somehow your motherboard and its
    chipsets and chipset drivers don't support USB 2.0. I have no idea what type
    system you have, so it's up to you to know about this point.

    Try connecting the drive to different USB ports. Some motherboards have
    separate ports for USB 1.0/1.1 and USB 2.0, usually those boards that are not
    of current manufacture. In addition, reformat the drive in Vista, in case
    The WinXP format is somehow different from that of Vista and could be causing
    a problem. It's not necessary to change the name of the volume from that of
    the default. You can make the change later if that's important to you.

    Don't focus on USB items in Device Manager that are not causing a problem.
    Only focus on how Device Manager handles the problem device. Adding comments
    about other devices have no bearing on the problem and only cause confusion.

    I don't see how any registry entries could have anything to do with your
    problem. I think the registry hack you're talking about has to do with using
    a USB flash drive that Vista doesn't recognize as ReadyBoost capable. The
    hack causes Vista to use it for ReadyBoost. Your problem is to get Vista to
    accept the device in any form. So, forget registry hacks for this problem.

    For just your problem device, Device Manager should recognize it in the
    three place as I indicated in my previous post. Check on how Device Manager
    shows this drive in those three places (forget all the other USB items). I'm
    almost out of ideas. The only other step I could recommend is to do some USB
    troubleshooting steps that you have not done, but I can post those later
    after you have followed up on what we've discussed here.
    freddy, Jul 1, 2007
  11. harmonp

    queen Guest


    i am the administrator and i am logged in as the administrator. when i try
    to delete this file, it tells me i do not have permission. any ideas?
    queen, Jul 1, 2007
  12. harmonp

    freddy Guest


    Even the Administrator sometimes has to give himself permission to do
    something in Vista. You do this by right clicking the file and selecting
    Properties and then clicking on the Security tab. Under that tab, you can
    give permissions. Vista works this way when you don't own the file. You own
    the file when you created it. If Windows created it, then you don't own it,
    but you can gain access because you're the Administrator. This procedure
    makes Vista more secure.
    freddy, Jul 1, 2007
  13. harmonp

    queen Guest

    hello freddy:

    thanx for the input. i did exactly as you stated here. unfortunately, even
    after deleting the file and rebooting, my problem still exists. i knew that
    that may have been the case when you said it may, or may not work; but i
    wanted to try anyway. for some reason, vista simply does not want me to use
    my external USB hard drive. i'm ready to start kicking some a-- and taking
    OS names later!

    also, i just wanted to say that i think you are simply the best at answering
    questions here. i never see you try to put people down or act as if you know
    everything. you do a good job. your help is much appreciated.

    now, if some of these dumb ass MVPs took a hint from you, they'd realize
    that they didn't know everything, and they would stop arguing with people
    over peanuts! some of those damn microsoft MVPs (most valuable poodles) kill
    queen, Jul 1, 2007
  14. harmonp

    freddy Guest


    For some reason unknown to me, Vista gives a certain number (no clue as to
    how many) of people a lot of trouble in recognizing USB devices. At the same
    time, most people (don't have a clue as to how many) likely don't have a
    problem with this. I'm running five USB devices (scanner, flash drive, USB
    floppy, Zip drive, and printer), and Vista recognized all of them with no
    issues. I suspect my experience is likely the norm, but I can see from my
    vantage point here that there is a problem in this area.

    I suspect the problem is exasperated by the fact that there is such a wide
    array of different motherboards and chipsets, along with related USB devices,
    with a never ending variation in the quality control applied in assuring that
    all this multitude of hardware complies with the various USB standards that
    have been in use since its inception.

    Now, can you imagine all that variation in hardware coming together and
    connecting to Vista? It's just got to cause problems, and it does! That's
    my take on the issue, and to what extent Vista has the bugs, rather than the
    hardware, is anyone's guess. I'm sure there is plenty of blame to go around.
    But it's really hard to tell.

    Anyway, sorry to bend your ear, but thanks for the kind words. In regards
    to your external USB hard drive, don't give up. Peruse this and other forums
    and I'm sure you'll manage to connect it eventually. I recall one poster who
    had a similar issue but managed to get it running by connecting it to a
    powered USB hub. You never know. Other people couldn't get Vista to
    recognize an external USB hub. Go figure.
    freddy, Jul 1, 2007
  15. harmonp

    queen Guest


    you didn't bend my ear, and i agree. but the reason why i say the problem
    is on the part of Vista is because i have other devices connected via USB and
    i do not have any problems with them at all. i know of other people who have
    the same issue that i have, and they come to me for an answer because of my
    technical knowledge. but as you can see, i just can't get this thing to
    work, no matter the many measures i have tried. hopefully, this will work
    itself out -- sooner rather than later.

    i'm trying to figure out why i do not see "MVP" next to your name?
    microsoft needs to take the title away from some of these losers, as they do
    nothing but insult people all day. never thought i'd find that here.
    queen, Jul 2, 2007
  16. harmonp

    Alyce Barry Guest

    I'm so relieved to find a description of this problem I've been having for months. In my case the dialogue says "Windows needs to install driver software for your USB CF Reader." I'm on Vista.

    I tried deleting the INFCACHE.1 file, and as you predicted, I have to give myself permission to do so. When I click the Security tab, I don't know what to do next. Can you either tell me how, or tell me where to find out? Thanks so much.
    Alyce Barry, Jan 15, 2011
  17. harmonp

    Alyce Barry Guest

    This solution -- deleting INFCACHE.1 -- worked for me, at least for a while. In my case, the error read that my USB CF reader required a driver.

    Later in the same day, however, the problem
    reoccurred -- the same error message showed up on booting up -- so I deleted INFCACHE.1 once again, and I found I needed once again to give myself permission.

    So I'm wondering if there's something different I need to do to make this solution permanent. On the security screen in Properties, there were 2 choices -- System and my user name. I chose the latter. Next time I'll take a look at System to what that looks like, but it seems unlikely.

    Do you have any further thoughts on this? Thank you.
    Alyce Barry, Feb 19, 2011
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.