Vista not indexing folders that are selected for indexing

Discussion in 'Windows Vista File Management' started by dlreid, Aug 31, 2007.

  1. dlreid

    dlreid Guest

    I have search indexing turned on, and several folders selected for
    indexing including the "documents" folder (which I have moved to the
    location "D:\documents"). However, some of the sub-folders in
    "documents" are not being indexed. I search for "*.*" or any other
    search term in a folder with hundreds of files, and nothing is
    returned. I must use the advanced search function and select "search
    non-indexed locations" in order for the search results to show up. I
    have rebuilt the index several times. I have taken ownership of all
    the files in the "documents" folder. I have tried de-selected and
    then re-selecting the location for indexing. I have made sure that
    the file types are selected. Some of the files are .txt files, others
    are .pdf files. None of them show up during a normal search. I have
    Acrobat professional 8.1 installed.

    I believe this is a serious flaw or bug in Vista's search indexing.
    If there is a solution, hotfix, or if someone can at least tell me
    that this is a known issue and it's being worked on, I would greatly
    appreciate it.

    Thanks,

    Dave
     
    dlreid, Aug 31, 2007
    #1
    1. Advertisements

  2. dlreid

    Dave Guest

    Are you searching for filenames, or text within the files?
     
    Dave, Aug 31, 2007
    #2
    1. Advertisements

  3. dlreid

    dlreid Guest

    I am searching for either or both. File names and text within files,
    both searches result in zero matches. For example, if I create a text
    file named "test.txt", and fill it with the word "test" repeatedly,
    rebuild the index, leave the computer on overnight, come back once
    indexing is complete, and search for "test" in that folder, I get zero
    results.
     
    dlreid, Aug 31, 2007
    #3
  4. Strange. In the Indexing Options Control Panel, is D:\Documents definitely
    listed as being indexed?

    I would try doing a Restore Defaults in the Control Panel to reset
    everything about the index back to the defaults and then try from there.
     
    Dave Wood [MS], Aug 31, 2007
    #4
  5. dlreid

    Dave Guest

    I don't have any suggestions... you've tried what I would...

    I've tried searching on my D: partition, and it finds text in a file I just
    created.
    I can even find lots of files on my USB E: drive that's not indexed.

    Just to clarify... how are you doing the search?
    from the
    1. Start - quick search box?
    2. Start - Search (on the right side)?
    3. Windows Explorer, navigate to D:\Documents - search box?
     
    Dave, Aug 31, 2007
    #5
  6. dlreid

    dlreid Guest

    D:\documents is definitely selected as being indexed. In fact,
    indexing and searching works fine for most of the sub-folders in D:
    \documents, however there is one in particular (that i have noticed,
    there may be more), which refuse to be indexed, even when I
    specifically select it in the indexing options. As I said, this seems
    to be a bug. I will try restoring defaults and then rebuilding, and
    I'll post if that works.

    When I first installed Vista, the search indexing would not index my
    Outlook emails. It would start indexing them and then at some point
    stop. I contacted MS support about it and they determined it was a
    bug, and it was later fixed in an update. I guess this is something
    similar, where a particular set of circumstances prevents certain
    items from being indexed.
     
    dlreid, Aug 31, 2007
    #6
  7. What are the names of some of the sub-folders that are not indexed? For
    example folders called "temp" are not indexed I believe ...
     
    Dave Wood [MS], Aug 31, 2007
    #7
  8. dlreid

    dlreid Guest

    The folder that is not being indexed is d:\documents\literature.
    Inside literature there are about 20 subfolders. The folders contain
    mostly PDF files, with some text files and a couple random files.
    None of these files shows up when searching indexed locations, no
    matter how I perform the search.
     
    dlreid, Sep 1, 2007
    #8
  9. dlreid

    dlreid Guest

    I reset the index to default and then rebuilt it, waited for indexing
    to complete, then added D:\documents to the index, then waited again
    for indexing to complete. I checked and only a small selection of the
    subfolders in D:\documents return any search results. Most folders
    return zero results no matter what search terms I use (even *.*). At
    this point I believe that the search indexing in Vista is seriously
    broken. I can only hope that this issue will be addressed when SP1 is
    released. My theory is that this bug manifests itself when the user
    changes the location of the \users\ folders, as I have with my
    "documents" folder.
     
    dlreid, Sep 2, 2007
    #9
  10. dlreid

    Jerry Guest

    Go run %SystemRoot%\system32\services.masc. (do it as Admin of course).
    Find Windows Search service and double click to open. Go to Log On tab.
    Now make sure that "Allow system to interact with desktop" is NOT ticked. If
    it is, clear it.
    You might need to rebuild the index after this, but I'm not sure.


     
    Jerry, Sep 2, 2007
    #10
  11. dlreid

    Jerry Guest

    sorry, that's services.MSC, of course :)


     
    Jerry, Sep 2, 2007
    #11
  12. dlreid

    Jerry Guest

    I'm just too quick on the "send" button today :)
    One more thing: restart the service.


     
    Jerry, Sep 2, 2007
    #12
  13. dlreid

    dlreid Guest

    Thanks for the suggestion. I tried that and "allow system to interact
    with the desktop" was not ticked. But I was able to solve my problem
    with this work-around: I right-clicked on the "documents" folder and
    in the location tab I selected "restore defaults", and elected to copy
    all files back to the default location (in the c:\users folder).
    After allowing indexing to complete, I can now successfully search all
    the folders. So there is a bug in Vista's search indexing that
    sometimes prevents the indexing of user folders if they have been
    moved from the default location to another partition or drive. Moving
    the user folders back to their default location solved the problem.

    This bug does not always occur, because I have another computer with
    the "documents" folder moved to a different partition, and search/
    indexing works fine. So I don't know what triggers it.
     
    dlreid, Sep 2, 2007
    #13
  14. dlreid

    Lothan Guest

    Is it possible to change the defaults to automatically exclude other folders
    with a particular name? As an example, I have a lot of source code checked
    out in the %UserProfile%\Documents\Visual Studio 2005\Projects and I want to
    exclude all the Subversion (.svn) folders in this tree. I know I can exclude
    the folders manually one-by-one, but this would be extremely tedious and
    time consuming. I would rather be able to just edit a file or registry key
    to tell it to skip any folders named .svn, temp, or whatever.
     
    Lothan, Sep 6, 2007
    #14
  15. <snip>


    Lothan

    You may be able to do this with a registry edit if all those .svn
    sub-folders are under the same parent folder. You should be completely
    familiar with editing the registry to do this. All of the standard warnings
    apply.

    All of the Search/Index options are under the Key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search

    If you start expanding that key, you will see:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
    Search\CrawlScopeManager\Windows\SystemIndex\DefaultRules

    With a list of numerical keys. These keys contain several values including a
    URL value that points to a folder name/location and another value named
    "Include" which appears to either allow indexing (value date = 1) or
    disallow indexing (value data = 0).

    You may be able to export one of these keys, edit the exported key to point
    to the folders that you want to exclude, set the 'include' value date to '0'
    and then import the key back to the registry.

    You should be able to find one of these numerical keys that is already set
    to exclude a particular folder name, (such as: file:///*\temp\* ) export
    that key, change the path to your .svn folders, rename the key to the next
    highest available number and then import the key back to the registry.

    Let me know if this works for you or if you need more help.
     
    Ronnie Vernon MVP, Sep 6, 2007
    #15
  16. dlreid

    Lothan Guest

    Thanks for the information, Ronnie. I added a new registry key (using the
    next sequential number) with the URL file:///*\.svn\*, rebuilt the index,
    and all those folders are no longer included in the index. I found it easier
    to export the existing rule for file:///*\temp\*, edit the key name and URL,
    and then import the modified key since everything else is the same.

    I poked around a bit more in the persistence handlers and also found a way
    to change to change the default indexer for ASP files. By default, Windows
    Search uses the HTML filter for ASP files and this means it indexes only the
    HTML portion that is visible in a browser. I'm not sure why this is the
    default because very few ASP files are actually renderable without executing
    through a script engine and it makes it impossible to index the source code
    in these files. To rectify this issue, I changed the persistent handler in
    HKCR\.asp\PersistentHandler from HTML
    {eec97550-47a9-11cf-b952-00aa0051fe20}) to Text
    {5e941d80-bf96-11cd-b579-08002b30bfeb}.

    I'm also noticing a lot of simple text extensions have no associated preview
    handlers for some reason, but I haven't had a chance to poke around the
    preview handlers yet and haven't really made it a priority just yet.

    Perhaps in a future release Microsoft will wrap a really good UI around
    these settings to make it easier for us without having to poke around the
    registry.
     
    Lothan, Sep 13, 2007
    #16
  17. Lothan

    Your welcome and good job tweaking those registry settings. :)
     
    Ronnie Vernon MVP, Sep 14, 2007
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.