Vista - [ODBC Microsoft Access Driver]'(unknown)'

Discussion in 'Windows Vista General Discussion' started by JD, Aug 17, 2007.

  1. JD

    JD Guest

    hello,

    Using VBScript to connect the Microsoft Access Driver (.mdb) file getting
    error on Vista, but it is working on XP

    connstr="Driver={Microsoft Access Driver
    (*.mdb)};Uid=xx;Pwd=yy;Dbq=c:\users.mdb;"

    The following error using Vista

    "[Microsoft][ODBC Microsoft Access Driver]'(unknown)' is not a valid path.
    Make sure that the path name is spelled correctly and that you are connected
    to the server on which the file resides."

    Could you please give some solutions /suggestion to fix this error?

    Thanks
    JD
     
    JD, Aug 17, 2007
    #1
    1. Advertisements

  2. JD

    Mr. Arnold Guest

    http://www.google.com/search?q="[Mi...n)'+is+not+a+valid+path.+&hl=en&start=10&sa=N

    I would suspect that what is needed for the solution to run on XP is there,
    and it's not there in the same manner on Vista. You might have a versioning
    issue in using MDAC between the two O/S(s) or it might even be a security
    issue on Vista.

    You have heard of the Vista UAC manifest that a program may need to use to
    present security credentials for an application running on Vista? Use Google
    and look up information about the UAC manifest on Vista that a program may
    need to use.

    You cannot expect that something that runs on XP is going to run on Vista,
    without some possible tweaks.
     
    Mr. Arnold, Aug 17, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.