Vista png problem in IE7, graphics not properly displaying

Discussion in 'Windows Vista General Discussion' started by Brawly, Mar 17, 2007.

  1. Brawly

    Brawly Guest

    Evidently, after much google searching the following are prominent problems
    with IE7, and I found countless articles and information in other forum
    groups about this, unfortunately with no solution. The first is random
    crashes of IE7, afterwhich you receive an error message, then Vista restarts
    the browser. The second is random non-displaying of graphics on webpages in
    IE7. In as far as I can tell, this is being faulted to the png feature in
    Vista. I am suffering from both of these problems. Interestingly, some
    information I have read indicated that Microsoft is currently working on a
    fix for IE7 to resolve these issues. That being said, is this an inherent
    problem in the application code for IE7 with no workaround until then? Is
    there currently a fix for this issue right now? Anyone out there having
    similar issues, please respond to this post, and if you have resolved the
    issue with IE7, please share - it would be greatly appreciated! One last
    footnote, those users who have installed FireFox or Opera in Vista do not
    suffer these issues. This appears to be sound evidence that the problem(s)
    is isolated to IE7? Thanks in advance for any help!
     
    Brawly, Mar 17, 2007
    #1
    1. Advertisements

  2. Brawly

    dean-dean Guest

    Is it just a problem with .png images being displayed in IE, or other images
    as well? You could try this:

    In Command Prompt (which you should run as administrator, by right-clicking
    on its shortcut), type

    regsvr32 c:\windows\system32\pngfilt.dll

    Press Enter on you keyboard. You'll see a confirmation that pngfilt.dll
    (the IE PNG plugin image decoder) has been successfully registered.
     
    dean-dean, Mar 17, 2007
    #2
    1. Advertisements

  3. Brawly

    Brawly Guest

    Thanks for the response. I tried the cmd entry you suggested and
    unfortunately I received the following error message: "The module
    c:\windows\system32\pngfilt.dll was loaded but the entry point
    DllRegisterServer was not found". It also includes the following in the
    error message: "Make sure that windows\system32\pngfilt.dll is a valid DLL or
    OCX file then try again". I think this message confirms my problem. Do you
    have any solutions? Thank you very much for your assistance.
     
    Brawly, Mar 17, 2007
    #3
  4. Ask Help about sfc - the system file checker. If pngfilt.dll is
    corrupt, sfc should be able to repair it from your Vista DVD.
     
    Michael Jennings, Mar 18, 2007
    #4
  5. Brawly

    Lame Guest

    I have the same problem on my notebook.

    The pngfilt.dll is not loaded with internet explorer 7, the support of png
    images does not works properly. But... this dll works fine with windows
    sidebar.
    This problem appears in only one user account on my computer. If I create a
    new user account, the png support in internet explorer works fine.

    The regsvr32 command does not works (The module ... was loaded but...)
    The sfc command does not change anything.

    Thanks for your help.
     
    Lame, Mar 29, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.