vista quit recognizing printers ... help!

Discussion in 'Windows Vista Printing / Faxing / Scanning' started by joebass, Aug 4, 2009.

  1. joebass

    joebass Guest

    here's the skinny: I have a newer sony vaio running vista ... I have
    hp printers installed, as I need a printer in various work locations ..
    all of the printers have worked fine for 6 months. Now, all of th
    sudden, with no error messages/popups/etc. they have all quit working.
    My USB ports are functioning with all other devices and the printer
    work fine with any other pc. The printers will read "ready" and th
    file will show as printing, but nothing happens. When I initially plu
    the printers into the usb, I get an error sound, but no pop-up. I hav
    tried deleting one of the printers, but I got no usb printer recognitio
    to re-install it, so I restored to a point before the printer issues an
    the printer is back in the printers folder, but still doing nothing.
    ok, any ideas
     
    joebass, Aug 4, 2009
    #1
    1. Advertisements

  2. joebass

    DL Guest

    Did you update any drivers from MS Update?
    Connect a printer directly to the Sony, does it work then?
     
    DL, Aug 4, 2009
    #2
    1. Advertisements

  3. joebass

    joebass Guest

    yes ... all drivers claim to be up to date. And ... all printers hav
    been directly attached to the vaio via usb. All printers were fine an
    working for 6 months, they literally just stopped responding ..
     
    joebass, Aug 4, 2009
    #3
  4. Do they work when you disconnect other USB devices? Do they work one at a
    time... ie only the single USB printer connected and no other USB devices
    attached?

    Do they work with other PCs?
     
    Cari \(MS-MVP\), Aug 4, 2009
    #4
  5. joebass

    DL Guest

    Claim to be upto date wasnt what I asked.

    Did you use MS Update for any drivers?, if you are unsure view your MS
    Update history. If any MS Update drivers have been installed, roll back
    those drivers, and obtain new ones direct from Sony and reinstall them.
    My past experience of Sony are that even an updated Sony driver, obtained
    direct from Sony can cause problems and some times has to be rolled back.
    Basic principle with drivers is that 'if it aint broke dont fix it.'
     
    DL, Aug 6, 2009
    #5
  6. joebass

    joebass Guest

    all usb devices work and have worked individually and alone, including
    printers until now. I made no updates nor changes before this happened.
    They literally just did not work one day and have not returned.
     
    joebass, Aug 6, 2009
    #6
  7. joebass

    DL Guest

    Then as its a new Sony you need to contact Sony support, for what maybe a hw
    problem
     
    DL, Aug 9, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.