Vista recognizes as blank disk some of my non-blank cds

Discussion in 'Windows Vista General Discussion' started by _dude, Oct 18, 2007.

  1. _dude

    _dude Guest

    Hi all,

    My Windows Vista is sometimes recognizing some of my CDs as blank disks and

    asking me for formating it ["Prepare this blank disk" - with only the Live
    File

    System option avaible]. The problem is that it does it for CD-R and CD-RW
    already written (closed or not) or even for original cd-roms that aren't
    writeble.

    The second symptom is that it doest it just sometimes. I noticed it after I
    tried to install one product [VMWare player] (that was already fully
    uninstalled) and it asked me once for disabling the cd-autorun.

    So, after the problem begin I noticed that when the Windows Media Player 11
    was

    opened, for the windows session the trouble occurrs, so I had to restart the
    computer, don't run WMP11 and then the CD in question was normally accessible.

    But when I installed another product [iTunes], somehow it also access the cd

    drive and then the problem occurs. Now, even if I don't run any programs
    after

    booting windows, sometimes the cd-rom is recognized as a blank disk and it

    stands for formating it. If I do it for a CD that was burned by another

    software, the CD becomes empty and I lost the previusly written data.

    If the cd inserted is factory made, not writeable at all, and it asks for
    formatting and I confirm it, I get a error message saying the the disk is
    write-protected and one file [desktop.ini] stands in queue for being burned
    later into the disk. The file contents are:
    desktop.ini
    [.ShellClassInfo]
    [email protected]%SystemRoot%\system32\shell32.dll,-21815

    I disable the Windows options for remembering each folder's view. If anyone
    of you can help me, I'll be thankfull. I already looked a lot around the web
    but didn't find a suitable solution.

    Thank you.
    Mario

    PS:
    Computer: Dell Precision M65 Laptop
    CD-DRIVE: TSSTcorp DVD+-RW TS-L632D ATA Device
    The drive is clean. In another OS that I have installed, I can read
    perfectly the same CD.
    It's not a CD specific problem. I happens with various CDs of different
    media types (CD-ROM, CD-R, CD-RW, ...).
     
    _dude, Oct 18, 2007
    #1
    1. Advertisements

  2. _dude

    _dude Guest

    UPDATE:
    OS: Windows Vista Ultimate x64_6.0.6000
    Fully Updated on Oct - 17 - 2007.
     
    _dude, Oct 18, 2007
    #2
    1. Advertisements

  3. _dude

    wheelman Guest

    i dont know what your problem is,sorry,but vista shut my cd burner down and
    my dvd burner down..like a week or two..after i had vista installed and i had
    to go out and buy brand new..vista approved software,,so it would let the dvd
    and vd burners work again..uncle bill got paid again..are you useing old
    drives and old software..i think it all should be newer then 2006 to work
    with vista..

     
    wheelman, Oct 18, 2007
    #3
  4. _dude

    CK Guest

    =?Utf-8?B?d2hlZWxtYW4=?= <> Whilst
    having a limited moment of clarity in an otherwise cloudy existence the
    drunkard typed
    YOU DUMB ****.
     
    CK, Oct 18, 2007
    #4
  5. _dude

    wheelman Guest

    your momma raise you that way..or are you just that gwkfgkfk dkdfkfd kdkdkd
    dkdjkjf dkdkdkd kdkdke kdkdkd kdkdkd dkkdkofoo

     
    wheelman, Oct 18, 2007
    #5
  6. _dude

    _dude Guest

    wheelman, thanks for replying it,

    I'm not planning to upgrade the drive because I'm pretty sure it's a
    software problem, and also, the drive is compatible.
    It already worked once, I just want to figure out how fix it insted of
    reinstalling the OS.

    Bye
     
    _dude, Oct 18, 2007
    #6
  7. _dude

    wheelman Guest

    my two burners worked two for like a week or two..then vista decided to shut
    them down..if the drivers are older then vista..i would guess..that may be
    your problem
     
    wheelman, Oct 18, 2007
    #7
  8. _dude

    Frank Guest

    How fukkin dumb are you?
    That dumb huh.
    Ok.
    Frank
     
    Frank, Oct 18, 2007
    #8
  9. _dude

    Piotr Rezmer Guest

    Hi, I have the same problem on Vista Premium. Have you got Media Center
    Application? If yes, try to browse the cd with this application.

    best regards
    Piotr
     
    Piotr Rezmer, Oct 18, 2007
    #9
  10. Nobody here is as dumb as you've proven yourself to be.
     
    Adam Albright, Oct 18, 2007
    #10
  11. "like a week or two..after i had vista installed"
    Not likely, something else happened.
    What did the manufacturers say when you asked if they supported their
    products with Windows Vista.

    --
    Jupiter Jones [MVP]
    http://www3.telus.net/dandemar
    http://www.dts-l.org


     
    Jupiter Jones [MVP], Oct 19, 2007
    #11
  12. "My Windows Vista is sometimes..."
    "If the cd inserted is factory made, not writeable at all, and it asks
    for formatting and I confirm it,"
    Those suggests a hardware problem probably with the drive.

    Power off and open the case.
    Reseat drive cabling at both ends.

    "In another OS that I have installed..."
    Not always a guarantee of a good drive, but it does help.
     
    Jupiter Jones [MVP], Oct 19, 2007
    #12
  13. _dude

    _dude Guest

    Hi all,

    thanks for the helping replies. Adding something to the topic I would like
    to say the the hardware components are fully supported by Vista. They're all
    signed drivers and this Dell workstation is homologated by Microsoft.

    The second thing that I'd like to reinforce it that the drive is fully
    clean. I ran a lot of error checking tests, in other OSes all is just fine,
    and even on Vista itself everything works fine after I acceppt the windows
    try of writing onto the disk.

    The trouble pretty looks have this origin: windows is trying to append a
    desktop.ini file into the disks.
    If its a non-writeble disk, I still can access it by allowing it to "prepare
    and format", then pops-up an error detecting that the disk is non writeble
    and the disk access is restored.
    But if its a opened session disk, I can't acess it, because if I acceppt the
    "disk preparing", it makes the previusly burned session unavaible, making the
    disk appear as blank.

    Cya
     
    _dude, Oct 24, 2007
    #13
  14. _dude

    mm Guest

    Hey _dude,

    I've got exactly the same problem with my Vista Home Premium on a VAIO
    notebook (pre-installed). If I start a burning program, like Nero,
    then start a copying-process, then stop the process, the CD works
    fine. I fully agree, it must be the desktop.ini...

    If you have Ultimate you can try to revoke burning privileges for your
    user account. Maybe vista then does not try to create a desktop.ini on
    the CD.

    I hope, I will find a solution for my Vista Home Premium...

    Best regards, mm
     
    mm, Oct 28, 2007
    #14
  15. _dude

    _dude Guest

    Hey mm,

    I managed to fix the problem.

    This is how I did: Appearing that the problem became after the Autorun
    setting was changed, I set it back to 1, where it was 0, in the key:
    HKEY_LOCAL_MACHINE\System\CurrentC­ontrolSet\Services\CDRom
    Autorun

    I apparently fixed the issue, given that now I can insert CDs and read them,
    witho
    ut being prompted for formating. But the damn desktop.ini still is created
    there. I think that's windows default and static behavior, and we won't be
    able to get rid of it (at least I don't know how, because I already disable
    everything related to thumnails of preferences remembering). But how it's now
    causing any trouble for now, lets leave it there.


    Another thing I saw around was people deleting their devices (cd-rom), and
    leting windows detect and install it again, it managed to solve the issues
    for them.

    But I think that the first workaround will solve you issue in the Win Vista
    Home as well.

    Good luck!

    _dude
     
    _dude, Nov 7, 2007
    #15
  16. _dude

    mm Guest

    Hey, this works great! Thanks a lot!
     
    mm, Nov 9, 2007
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.