Vista Service Pack SP1 Installation - persistent 8007010B Error

Discussion in 'Windows Vista Talk' started by Tom Geer, May 7, 2008.

  1. Tom Geer

    Tom Geer Guest

    For days now I have been trying to get Vista SP1 to install. Well into
    the installation but before any reboots (after two full progress
    meters) disk activity slowly diminishes to nil and then the pesky
    8007010B Error and it halts. A snippet containing the offending code
    from the WindowsUpdate log is included below.

    If indeed 8007010B = directory name invalid or some such then the
    culprit should be
    C:\Windows\SoftwareDistribution\Download\370a8a4bc0631584d862be923aa9fef0\
    according to the Update log. This folder is present and apparently
    uncorrupted, containing over 40MB of SP1 udate files (mostly .cabs).
    I've given full access permissions to
    C:\Windows\SoftwareDistribution\Download\ and
    C:\Windows\SoftwareDistribution\DataStore\ as well aS all subfolders
    and files within both. I've flushed both folders and after another
    failed install, restored them. I've even created entirely new folders
    with unrestricted access permissions, copied both folders, deleted the
    originals and renamed to duplicated and replace both folders. There's
    no discernable problen here.

    Otherwise my system is 100% ready to accept SP1 having followed
    Microsoft's preperations to the letter. All other updates are
    installed, all drivers have been updated where possible including an
    Authentec fingerprint scanner which is known to be SP1 incompatible
    unless updated. Furthermore I have tried every workaround and "fix" I
    can find after 3 days of scouring the internet, including:

    - running CHKDSK C: /F and SFC /SCANNOW
    - running the Windows Vista Memory Diagnostic Tool
    - terminated all non-vital processes including anti-virus and firewall
    - defragging the system drive.
    - cleanup, repair, compact, defrag registry
    - Went back and reinstalled Windows Update Agent 3.0
    - verified more then enoung free disk space (over 40GB!)
    - tried both the full standalone install package (450MB) and the
    Windows Update install (45MB) which wasn't being offered at first but
    now is.
    - no serial cables connected to a UPS.
    - all drivers updated, BIOS flashed and all Windows Updates installed
    including the two SP1 prerequisite updates.

    .... and several more things that don't immediately come to mind, I'm
    sure.

    I find it strange that although there are numerous reports of this on
    the internet, there has not been on definitive, working answer.
    Stranger yet, Microsoft is obviously aware of this yet their
    recommendations do not resolve the issue.

    Here's that part of the WindowsUpdate log:


    2008-05-07 14:16:41:379 1080 ae8 DnldMgr Preparing
    update for install, updateId =
    {C3E99F5D-2F9C-42BE-93E2-ACFA9E16852A}.101.
    2008-05-07 14:16:41:379 860 da8 Handler :::::::::::::
    2008-05-07 14:16:41:379 860 da8 Handler :: START ::
    Handler: CBS Install
    2008-05-07 14:16:41:379 860 da8 Handler :::::::::
    2008-05-07 14:16:41:379 860 da8 Handler Starting
    install of CBS update C3E99F5D-2F9C-42BE-93E2-ACFA9E16852A
    2008-05-07 14:16:41:519 860 da8 Handler CBS package
    identity: VistaSP1-KB936330~31bf3856ad364e35~x86~~6.0.0.18000
    2008-05-07 14:16:41:519 860 da8 Handler Installing
    express with
    source=C:\Windows\SoftwareDistribution\Download\370a8a4bc0631584d862be923aa9fef0,
    workingdir=C:\Windows\SoftwareDistribution\Download\370a8a4bc0631584d862be923aa9fef0

    Here's the error:
    ==========================================================
    2008-05-07 14:24:57:818 860 774 Handler FATAL: CBS
    called Error with 0x8007010b,
    =========================================================
    2008-05-07 14:24:57:818 1080 df8 AU >>## RESUMED
    ## AU: Installing update [UpdateId =
    {66F16258-9D3B-4353-8765-E55E803151D0}]
    2008-05-07 14:24:57:818 860 da8 Handler FATAL:
    Completed install of CBS update with type=0, requiresReboot=0,
    installerError=1, hr=0x8007010b
    2008-05-07 14:24:57:818 1080 df8 AU # WARNING:
    Install failed, error = 0x8007010B / 0x8007010B
    2008-05-07 14:24:57:864 860 da8 Handler :::::::::
    2008-05-07 14:24:57:864 860 da8 Handler :: END ::
    Handler: CBS Install

    Why it should be such a royal pain in the ass to install a service
    pack is beyond me.

    I MUST be missing something - anyone?

    Sincerely,

    tgeer
     
    Tom Geer, May 7, 2008
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.