Windows Vista has been known to cause slow network transfer speeds for some users, most noticeable when copying files across a network that take much longer than before.

Some suggestions that may help users experiencing slow network performance are as follows:

1) Download the latest drivers for your network adapter from the manufacturers site (do not rely on the Windows Update drivers). Then, check they are configured properly by viewing the device manager settings.

2) Install the latest Windows Update patches, including Vista SP1.

3) If you use a 3rd Party firewall, be sure that it is configured correctly. For example, in Kaspersky Internet Security there is a "high speed" setting that should be ticked.

4) Try disabling Remote Differential Compression by clicking Start > Control Panel > Programs > Programs and Features. Then click Turn Windows features on and off, untick Remote Differential Compression and click OK:


5) The final thing to try would be to disable network Auto-Tuning. First, load the run box by pressing WINDOWS KEY + R and then run:

netsh interface tcp set global autotuninglevel=disabled

You will need to restart your PC after this and retry the network transfer. If speeds are still low, you can return the auto-tuning to default mode by re-running the following command:

netsh interface tcp set global autotuninglevel=normal
Ian, Mar 11, 2008