Vista VPN and Cisco Pix Firewalls

Discussion in 'Windows Vista General Discussion' started by Peter, Sep 5, 2006.

  1. Peter

    Peter Guest

    Hello

    I have a question. I have Windows Vista install on a laptop and Desktop
    (RC1) and when i want to setup a VPN connection with the normal Windows VPN
    wizard. The connection wizard work fine but when I want to connect to a Cisco
    Pix firewall (501, 506, 515) I receive a error “Error 732 : Your computer and
    the remote computer could not agree on PPP control protocols“. I check the
    connection with a Windows XP client and it looks the same. and in XP its
    working fine. (so I’m using the VPN without a Cisco Client). The same problem
    was in the Bata2 and the Pre-RC1. What is different between XP and Vista
    (with out this option many customers can’t use the normal VPN anymore)

    Thanks
     
    Peter, Sep 5, 2006
    #1
    1. Advertisements

  2. Peter

    Jimmy Brush Guest

    Hello,

    I believe Vista by default only uses MS-CHAP v2 authentication protocol.
    Changing this setting to use the less secure v1 protocol may allow it to
    work.
     
    Jimmy Brush, Sep 5, 2006
    #2
    1. Advertisements

  3. Peter

    Peter Guest

    I also read that Vista only support MS-CHAP2 But when you take a look at the
    VPN connection there is still the option to choose for MS-CHAP1 (same as XP)
    And it’s less secure but it's works ;) But has anyone a work around for this
    problem?
     
    Peter, Sep 5, 2006
    #3
  4. Do I understand you correct that selecting MS-CHAP1 in Vista makes the
    connection work? In that case the only problem you have is that the Pix
    is not able to handle a more secure version of the protocol, perhaps an
    update of the firewall software will make it support MS-CHAP2.
     
    Erik Wikström, Sep 5, 2006
    #4
  5. Peter

    Peter Guest

    No if you select the MS-CHAP1 option noting is happening.
    The connection looks the same as XP but this not working the same.
    I hope they fix this “problemâ€
     
    Peter, Sep 6, 2006
    #5
  6. Sorry for OT, but which VPN protocol are you using? I would like to connect
    to Cisco PIX VPN, but was unsucceful neither from XP not Vista. Are you
    using PPTP?

    Thanks
    Robert
     
    Robert Gajdzica, Sep 7, 2006
    #6
  7. Peter

    Peter Guest

    Hi Robert

    A normal connection in XP was MS-CHAPv1 to connect to a Pix Firewall (PAP
    and CHAP is no option because it’s not secure) But the MS-CHAPv1 option is
    not available in Vista anymore so it will not work anymore. because
    Cisco not working with MS-CHAPv2. I read it’s only available in the 7.0
    software but that’s not supported on the Pix 501, 506 and the 515 and that’s
    a problem in Vista.
     
    Peter, Sep 7, 2006
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.