Visual Studio 2005 Service Pack 1 Install Failure

Discussion in 'Windows Update' started by John Ashmun, May 30, 2007.

  1. John Ashmun

    John Ashmun Guest

    On a Windows Server 2003 SP 1 system that's kept up to date, the Service Pack
    1 update for Visual Studio 2005 failed with Error 0x643. Microsoft Update
    suggests trying it again, but the retry failed the same way.
     
    John Ashmun, May 30, 2007
    #1
    1. Advertisements

  2. John Ashmun

    Tamathumper Guest

    My retry failed on one, and worked on another machine. It took two reboots
    to get it to go on the first machine.
     
    Tamathumper, May 30, 2007
    #2
    1. Advertisements

  3. John Ashmun

    John Ashmun Guest

    I'll restart the machine and give it another go, thanks.
     
    John Ashmun, May 30, 2007
    #3
  4. John Ashmun

    spock Guest

    Dunno if you got it to work yet or not. My problem installing on Windows
    2000 was that I didn't have enough free hd space on my c partition... I had
    over 2GB and it wasn't enough.

    Apparently the sp download is 442MB. Then it unpacks it twice each of which
    is 466MB... _then_ it starts the install. It seems it needs 1.4GB before it
    even starts installing.

    Now that's efficiency!
     
    spock, Jun 11, 2007
    #4
  5. John Ashmun

    John Ashmun Guest

    I should have said that I was working with Server 2003 SP1. It turned out
    that what it needed was a hotfix.

    Regards,
    John
     
    John Ashmun, Jun 12, 2007
    #5
  6. John Ashmun

    Alex Guest

    Hi there,
    I would really appreciate if you point me to that hotfix.
    My 5 attempt to install-re-install that freaken service pack failed.
    At first I try MSDN CD. There was a missing file error.
    Then I used Microsoft update and got red flags from antivirus.
    I disabled AV completely.
    Tried again.
    Dr. Watson throws red flag.
    And on each next attempt my server simple died (Blue screen of death).
    After reboot it worked like nothing happened but service pack still not
    installed.
     
    Alex, Sep 18, 2007
    #6
  7. John Ashmun

    Mark Moore Guest

    Just wanted to say this was exactly the fix. Couldn't belive I needed to
    clear 3G of space to get it to install. Gaah!

    -MM
     
    Mark Moore, May 7, 2008
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.