Volume Shadow Copy Service causing problems

Discussion in 'Windows Vista File Management' started by Gerry Hickman, Mar 16, 2008.

  1. Hi,

    (Vista SP1 x86)

    Over the last few months I've been seeing an issue where one of my hard
    drives becomes unresponsive, then it returns to normal. At first I
    thought it was a faulty hard drive, either remapping bad blocks or
    failing internal cache, but extensive block-level and SMART testing
    indicated the drive was OK.

    I now notice there's a pattern to this problem. The Volume Shadow Copy
    Service is always being started by Windows around the same time I'm
    seeing the problem.

    I looked in the scheduled tasks to see what times System Restore (SR)
    was running, but the times did not coincide with the problem. I now
    wonder if it's something to do with the "Previous Versions" feature?

    I'd like to disable what ever is causing VSS to start, I can disable SR,
    but don't know how to disable "Previous Versions". I don't really want
    to disable the VSS service completely. I'd like to run it like this for
    a few weeks and see if it solves the problem.
    Gerry Hickman, Mar 16, 2008
    1. Advertisements

  2. Gerry Hickman

    Kerry Brown Guest

    If you turn off Automatic restore points for a drive it also turns off
    Previous Versions.
    Kerry Brown, Mar 16, 2008
    1. Advertisements

  3. Thanks Kerry,

    Can you remind me how to do that?
    Gerry Hickman, Mar 16, 2008
  4. Gerry Hickman

    Kerry Brown Guest

    Right click on Computer. Pick Properties. In the left hand pane under Tasks
    click on System Protection. Click on Continue or supply Administrator
    credentials at the UAC prompt. Remove the check mark beside the drive you
    don't want protected.
    Kerry Brown, Mar 16, 2008
  5. Gerry Hickman

    Bob Guest

    Bob, Mar 16, 2008
  6. Ah, it's under "Properties", no wonder I couldn't find it! OK, that's
    strange, it says it's only enabled on the C drive, but I was having
    problems with my D drive. Might turn it off anyway, and see what happens.

    Thing is, I don't really want to disable SR, I only want to disable the
    "Previous Versions" feature; is that possible?

    The problem I'm having is not coinciding with SR, something else is
    staring VSS and causing the problem.
    Gerry Hickman, Mar 16, 2008
  7. Gerry Hickman

    Kerry Brown Guest

    I don't think there is a way to turn off one without turning off both.
    Kerry Brown, Mar 16, 2008
  8. Gerry

    Kerry is correct about the Previous Versions being tied to System Restore.
    You cannot disable these components, individually.

    If System Restore is enabled, the way it works is to create a Restore Point
    once a day, by default. It then monitors that drive and records any changes.

    The only other thing that might be using the Volume Shadow Copy Service
    would be if you have a Scheduled Backup set to automatic.
    Ronnie Vernon MVP, Mar 17, 2008
  9. Hi Ronnie,
    I don't have any backup jobs defined. I can see VSS service start-up in
    the Event log at times that do NOT match the SR scheduled task. I've
    disabled SR on the C drive now, will see if VSS ever starts on it's own
    Gerry Hickman, Mar 17, 2008
  10. Hi,

    OK, I don't think the problem is anything to do with VSS. I now see
    what's happening. I'd been running chkdsk at the exact time of these
    problems, and it's chkdsk that starts VSS!

    The original problem is that the hard disk becomes unresponsive, and the
    Event log fills up with

    Event 57


    The system failed to flush data to the transaction log. Corruption may


    This is a DYNAMIC volume, otherwise it would probably say something like
    the "the device did not respond within the timeout period". Microsoft's
    Event help does not have any help on the volmgr Event.

    Caching is disabled, so I don't know why it needs to "flush" anything,
    it should give an IO error instead.
    Gerry Hickman, Mar 17, 2008
  11. Gerry

    There is a lot of information on the net about this problem. It appears to
    be an issue with a drive in all cases, but nothing consistent with the drive
    type. Take a look at the following link, maybe something will jump out at

    "vista" "volmgr" "The system failed to flush data to the transaction log" -
    Google Search:
    Ronnie Vernon MVP, Mar 18, 2008
  12. Well, I don't know how to "turn on" the Shadow Copy... That is the most
    important thing, I guess... Then, maybe, when I try to install MS updates
    and other MS software and hardware that I own, it might work without me
    sitting here going through everything as I did with Windows 95 - through

    any help greatly appreciated!
    yellowscarf47, Mar 18, 2008
  13. Hi Ronnie,
    Yes, I'd read most of those before posting here, wasn't convinced of the
    answers. Disabling ReadyBoost certainly didn't make any difference. I've
    ordered a new drive.
    Gerry Hickman, Mar 18, 2008
  14. Yellowscarf47

    Go to Start and type services and click services in the results.

    Scroll down to Volume Shadow Copy and double click. Set the Start Up Type
    to automatic and click the Start Button.


    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience

    Ronnie Vernon MVP, Mar 18, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.