VPC 2004 networking woes.

Discussion in 'Virtual PC' started by narn, Sep 21, 2005.

  1. narn

    narn Guest

    Am trying to set up several VPC's to inter-operate and have access to the
    LAN resources.

    Configuration:

    VPC: VPC 2004

    Host OS: Win2000 Server on a hardwired LAN, Virtual Machine Network Services
    and Loopback adapter installed

    Guest OS: Doesn't really matter, they all behave the same.

    Problem: Selecting Ethernet Controller for the VPC NIC produces an error
    during VPC boot. The only option that works is Shared networking and Local
    only. Not exactly what I would like.

    So, what is the magic chant I need to recite to get this work?


    Many thanks.
     
    narn, Sep 21, 2005
    #1
    1. Advertisements

  2. narn

    Bill Grant Guest

    What error does it produce?

    How do the LAN machines get their network config? Do you have a DHCP
    server on the LAN?

    If the vm guest's networking is set to the physical NIC option it should
    work just like any machine on the LAN (as far as networking is concerned).

    On the host machine, check the properties for your NIC. Is there a check
    mark in the box alongside Virtual Machine Network Services?

    If you use the loopback adapter option you will need to manually
    configure the loopback adapter on the host and the vm's NIC to be in the
    same IP subnet.
     
    Bill Grant, Sep 21, 2005
    #2
    1. Advertisements

  3. narn

    narn Guest

    The LAN has a DHCP server (Net Gear Router/Firewall). Changing the host to
    use DHCP instead of a static IP fixed half the problem. Any windows guest OS
    seems happy enough. Thanks for the tip. The help files say something like
    "if the host is using DHCP". It should say "the host MUST use DHCP.

    There are a couple problems remaining:

    - Having a server (the host) with a dynamic IP is bothersome. I don't have a
    Windows Domain controller running on the network. But I can live with it in
    this circumstance.
    - Red Hat Linux (version 6.1 - yeah I know it's old) evidently can't find
    the DHCP server because the ethernet controller comes up without an IP. The
    exact same configuration running on a physical machine runs just fine
    configured for DHCP.

    Any one running this version of RedHat in a VPC know how to get it happy
    with DHCP?

    Thanks again.
     
    narn, Sep 23, 2005
    #3
  4. narn

    Bill Grant Guest

    Once you know what info DHCP supplies, you don't really need it any
    more! You can simply manually add the IP, netmask and gateway info.

    Better still, have a look at the DHCP parameters on the router's DHCP
    service. Pick an IP address from its reserved set for your manually
    configured machines.
     
    Bill Grant, Sep 24, 2005
    #4
  5. narn

    narn Guest

    I actually tried manually configuring early on because it is far preferred
    over DCHP.

    Linux does not seem to like sharing the NIC with the host. I've tried both
    the older RedHat 6.1 and a fairly recent Debian 3.1 and they both behave the
    same. Under DCHP configuration eth0 comes up with no assigned IP. When
    manually configured I get "network is unreachable". Have tried manually
    bringing up the interface and adding the route but both fail.

    I'm guessing the problem is related to the combination of VPC 2004 and the
    Win2000 Server host OS.

    I may need to load a system with Win2003 Server or XP Pro to act as the
    host. I'm thinking of dropping a second NIC in the host and dedicating it to
    VPC use. Has anyone tried that?

    To illustrate (RedHat 6.1):
    [[email protected] /root]# ifconfig -a
    eth0 Link encap:Ethernet HWaddr 00:4C:69:6E:75:79
    inet addr:192.168.0.61 Bcast:192.168.0.255 Mask:255.255.255.0
    BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    Base address:0xec00

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:3924 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0

    [[email protected] /root]# route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use
    Iface
    127.0.0.0 * 255.0.0.0 U 0 0 0 lo
    [[email protected] /root]# ping 192.168.0.1
    connect: Network is unreachable
    [[email protected] /root]#
     
    narn, Sep 24, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.