VPC always at 100% CPU usage after CPU Upgrade to Quad Core

Discussion in 'Virtual PC' started by Damo, Apr 22, 2008.

  1. Damo

    Damo Guest

    Hi Everyone,

    I have recently upgraded my AMD 6000+ Dual Core to a 9600 Quad Core Phenom.
    Motherboard: Asus M2N32-SLI Deluxe Wireless, bios Ver 1802 - 8 GB of Ram.
    Previously i could run 5 VM's at once. Now with the quad core cpu, i run 1
    VM and it is using 100% CPU at all times. If i start a second, both VM's run
    dog slow with 100% CPU usage. If i look at the Task Manager on the Host
    (Vista Ultimate X64) I’m not even using 30%. Is there a problem with the AMD
    virtualization? The VM's seem to only use on core. If i start all 5 VM's my
    host CPU usage is still 30% but all VM's run at 100% CPU usage and are un
    usable. It's almost like the VM's are only using the 4th Core of the CPU -
    All VM's have a minimum of 1GB Ram
    Any suggestions would be greatly appreciated
     
    Damo, Apr 22, 2008
    #1
    1. Advertisements

  2. Damo

    Zootal Guest

    I have a 9600 quad core Phenom. I can run multiple VMs with excellent
    performance. IFAICT, AMD virtualization works quite well. However..the M2
    series of boards by Asus are pretty lousy boards. Scrap it and get a good
    board, and you might see a difference. I got about 20% better performance by
    upgrading to an M3A32 board.

    Ahh...you have Wireless on your board. Disable it in the bios and see if
    that changes anything. Asus wireless is buggy at best, and is known for
    causing performance problems.
     
    Zootal, Apr 22, 2008
    #2
    1. Advertisements

  3. Damo

    Damo Guest

    Hi Zootal,
    Thanks for your reply,
    Tried disabling the wireless - same issue (Im using windows to do the
    wireless not the crappy Asus utility that does not work prop on X64) I hear
    you with the mobo upgrade, but everything worked fine with the 6000+ The only
    diff now is the quad core - I also use the wireless, it's on a DMZ so i have
    2 VM's on a diff network.

    Question Zootal, Did you install your VM's with the quad core CPU?
    I have also uninstalled/re-installed VM Addons -
     
    Damo, Apr 22, 2008
    #3
  4. Damo

    Gary Mount Guest

    Virtual PC only uses one core.
     
    Gary Mount, Apr 22, 2008
    #4
  5. Damo

    Zootal Guest

    Did you disable wireless in the bios? Did you reinstall Windows from
    scratch? It's not as critical with XP as XP is much more forgiving then
    Win98, but sometimes still needs to be done.

    To answer your question, I did indeed install the VMs with the quad core. I
    installed XP64 from scratch.

    Clarification needed - is it the cpu in the VM that is maxed out? I'm
    guessing this is the case based on your descriptions earlier. IIRC, the Vm
    is a single threaded app, and multiple VMs run off of the same executable.
    Someone correct me if I'm wrong - do different VMs run on different threads?
    In task manager, I only see one executable no matter how many VMs I open up,
    and I think it only runs on one core.

    Perhaps someone with more experience with VMs can comment?
     
    Zootal, Apr 22, 2008
    #5
  6. Damo

    Damo Guest

    Very good Gary - I think you missed the point!
    Degradation in VM performance with a Quad Core - 1 of the 4 Cores is at 100%
    1 or 5 VM's only use 25-30% of Host CPU but the VM runs at 100% CPU usage.
     
    Damo, Apr 22, 2008
    #6
  7. Damo

    Damo Guest

    Hi Zootal,

    Thanks again for you help.
    Your correct, The VM CPU is maxed. I'm going to install another VM Vista
    Business tonight to see if its any better. My current Vista Business VM has
    totally died after the new CPU.

    I have a screen shot of 4 VM's cascaded with task manager open on each, CPU
    at 100% on each and the host task manager under that with CPU usage at 30 %
    6.8 GB Ram used -
     
    Damo, Apr 22, 2008
    #7
  8. Damo

    Gary Mount Guest

    Is your Quad Core Phenom a B1 stepping ?

     
    Gary Mount, Apr 22, 2008
    #8
  9. Damo

    Damo Guest

    Hi Gary,
    It a "black Edition" 9600 B2 Stepping

     
    Damo, Apr 22, 2008
    #9
  10. Damo

    Damo Guest

    I installed another Vista VM last night (Well Tried Too)
    The install took over 8 hours! And now is stuck booting into vista for the
    first time.
    CPU is maxed out on the VM, but the host is still only 25%-30% CPU Usage.
    I also looked up the threads, Under Task Manager, right click on VirtualPC
    and select Set Affinity, there you can set the threads, I have all 4 Cores
    ticked, I also played with the setting "Virtualization" which is another
    option when you right click the process VirtualPC .exe None of this helped,
    MY VM perfromance is shocking -

    - Below is AMD's Answer (Does not help much)


    Dear Sir,
    Thanks for contacting AMD Technical Support.
    After a quick inquiry, it appears that VPC 2007 uses only one core to run
    all of its VMs. As your previous dual core cpu has a faster clock frequency
    than your phenom's one, it's is not surprising that it runs slower. Maybe you
    can change to another vitualization software that will be able to use the
    4-cores of your new Cpu and so allow you to release the full potential of
    your Phenom.
    Please feel free to contact us again.

    Thanks & Regards.
    Alexis. AMD GCC.


    None of this helped, MY VM perfromance is shocking -
     
    Damo, Apr 22, 2008
    #10
  11. Damo

    Zootal Guest

    AMD support is clueless. I don't think the problem is that you have it
    running on one single slower core. I can run several VMs on one single
    slower core, and it does not do what you are observing. Something else is
    having an impact on your VMs and causing them to run at max cpu. Mine don't
    do that. There are two differences between your setup and mine - I'm running
    XP64, and IIRC you are using Vista. I'm using a M3 series board, you are
    using an M2 series. I'm not sure which, if either, is the problem.
     
    Zootal, Apr 23, 2008
    #11
  12. Damo

    Damo Guest

    Thanks Again Zootal,

    I lodged this with Microsoft Partner Support Last Night (Late) - I should
    just stick my dual core back in!
     
    Damo, Apr 23, 2008
    #12
  13. Damo

    Steve Jain Guest

    Two things to try, first make sure you have the latest BIOS from Asus.
    Next, try disabling hardware virtualization for VPC in VPC's options
    and see if that makes any difference, if not, try disabling it on the
    BIOS.
    A poor BIOS implementation of HV can cause the symptoms you're seeing.
    Vista shouldn't take 8 hours on any recent CPU.
     
    Steve Jain, Apr 23, 2008
    #13
  14. Damo

    Damo Guest

    Hi Steve,
    Thanks for your reply,

    I have the latest BIOS from ASUS 1802 - I have posted the same issue on the
    ASUS forums.
    I also have tried with AMD Virtualization turned off, AMD Live On/Off Same
    issue, VM max CPU usage.

    I think im getting the TLB Errata Error on the Phenom, You know the one that
    cant be replicated on a desktop PC according to AMD?
     
    Damo, Apr 23, 2008
    #14
  15. I suggest that each VM is using 100% of the *available* virtual processor;
    if the VM needs more/less processing power then more is assigned which would
    mean the CPU usage in the *host* increases/decreases while the virtual
    processor still thinks it's using 100% of the processing power.

    So the VM's Task Manager CPU Usage figures are useless.

    As to why it's so slow, <shrug>.

    Andrew
     
    Andrew Morton, Apr 23, 2008
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.