VPC's act a bit sluggish & "freeze" with new laptop...

Discussion in 'Virtual PC' started by AC [MVP MCMS], Aug 22, 2006.

  1. I just got a new laptop (Dell D820) with the Intel Centrino Duo 2Ghz & 945
    chipset (2GB RAM, 7200 RPM SATA HDD), and some VM's that I was using on another
    machine are acting up a bit. They boot and run just fine, but at times, they
    will go unresponsive (can move the mouse around, but clicks do nothing).

    I run my VM's though Invirtus' VM Optimizer and installed SpeedSwitchXP and
    made sure my CPU was set to run at max performance... both the VM guest drive
    & my host drive are defraggged... ideas?

    I'm running Virtual PC 2004 SP1 (v5.3.582.27) and I've installed the hibernation
    hotfix (KB#909095). I tried running the fix for the Centrino 915 chipset
    (KB#899525), but after rebooting, my situation was even worse.

    -AC [MVP MCMS]
    www.andrewconnell.co
     
    AC [MVP MCMS], Aug 22, 2006
    #1
    1. Advertisements

  2. Having just been through this with my new Dell Inspiron, here are a couple
    things to check.

    First, there were a TON of drivers that were preinstalled and my performace
    sucked until I did a clean install of WinXP.

    I also found that VPC has issues with my bluetooth adapter that came
    preinstalled in my new box, so if you have this, DO NOT install the driver
    when you reinstall XP and make sure you disable it in the bios before you
    rebuild XP.

    Hope this helps!

    Dev
     
    Devon Cochenour, Aug 22, 2006
    #2
    1. Advertisements

  3. Do you know what version of the Virtual Machine Additions you are
    using in your guest OS's? I'm using 13.705 (though on a ThinkPad
    R52).
     
    Matthew Chestnut, Aug 22, 2006
    #3
  4. AC [MVP MCMS]

    Nigel Guest

    Hi

    I have just taken delivery of a brand new Toshiba A6 which is a dual core
    laptop and I am getting the same problems. I am running Windows XP SP2 and
    version 13.306 of Virtual machine additions. There is no bluetooth on this
    laptop.

    Anybody any ideas ?
    --
    Regards

    Nigel


     
    Nigel, Aug 22, 2006
    #4
  5. On my ThinkPad R52, I'm also running the hotfix #899525, though I'm
    not running the hotfix #889677, since I'm assuming that build .34
    includes build .32 stuff.

    Just some info I've gathered...

    The free Virtual PC 2004 with SP1 is here:
    http://www.microsoft.com/windows/virtualpc/downloads/sp1.mspx

    Running SETUP.EXE will install VPC 5.3.582.27, which is VPC 2004 SP1.

    Included in the ZIP download is the "Laptop Hotfix" folder, which
    includes the hotfix for:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;889677.

    Executing the .MSP patch included in that folder brings VPC to
    v5.3.582.32.

    This patch is *not* included:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;899525.

    That hotfix brings VPC to v5.3.582.34.
     
    Matthew Chestnut, Aug 22, 2006
    #5
  6. Hello Devon,

    It's not a clean install (Dell Latitude D820) because the OS came much cleaner
    than I ever expected (only had the security & wifi software installed). I
    have wifi + bluetooth disabled when I try to run it and I still have the
    issue.

    -AC [MVP MCMS]
    www.andrewconnell.com
     
    AC [MVP MCMS], Aug 23, 2006
    #6
  7. Hello Matthew,

    For one (machine built & installed additions from VPC), I'm running 13.306.

    For another (machine built & installed additions from Virtual Server... but
    I'm running it in PC), I'm running 13.552.

    Where did you find 13.705?

    Both machines are having the problem.

    I found the download for 13.552 (http://www.microsoft.com/downloads/...3c-193b-41ac-af6e-ab7ab2db8541&DisplayLang=en),
    but how can you tell which version of Virtual Server you're running? I'm
    runnin 2005 R2, but not sure about enterprise/standard.

    -AC [MVP MCMS]
    www.andrewconnell.com
     
    AC [MVP MCMS], Aug 23, 2006
    #7
  8. Hello Matthew,

    I've installed one of the hotfixes you m ention #889677 (the hibernate fix),
    but not #899525 because that's for a Centrino 915 chipset, where I have the
    945 chipset (Dell Latitude D820) and when I installed the 915 fix on my 945,
    when I restored a virtual machine, it crashed the VM.

    -AC [MVP MCMS]
    www.andrewconnell.com
     
    AC [MVP MCMS], Aug 23, 2006
    #8
  9. I'm running the following Virtual Server on my laptop:

    C:\Program Files\Microsoft Virtual Server\vssrvc.exe
    Virtual Server 2005 R2 SP1 Service
    v. 1.01.0512.0000

    I'm pretty sure the 13.705 stuff came with VS 2004 R2, maybe sp1?

    Regardless, here's where you can find the latest VMA that I know of:

    "Virtual Machine Additions 13.709 now available for Vista Beta 2 July
    Refresh "
    http://blogs.virtualserver.tv/blogs..._July_Refresh_Virtual_Machine_Additions_.aspx



     
    Matthew Chestnut, Aug 23, 2006
    #9
  10. Are you using the Synaptics pointing device in your laptop?

    I found that the advanced features Like scrolling and the hot spot regions
    features of this device caused me some issues as well. After disabling this,
    I am still up and running after doing all the OTHER tweaks....
    --
    Devon Cochenour
    MCSD, MCT MSF Master Trainer



     
    Devon Cochenour, Aug 23, 2006
    #10
  11. AC [MVP MCMS]

    AC [MVP] Guest

    Not sure what you're referring to. The only thing I have is a standard wireless
    USB2 mouse. I have a colleague who recently worked with PSS to improve his
    VPC performance. Their fix: unplug any USB2 mice! arg :(

    -AC [MVP MCMS]
    www.andrewconnell.com
     
    AC [MVP], Aug 23, 2006
    #11
  12. My new Dell came with a touch pad that was a Synaptic Pointing Device that
    had a BUNCH of advanced features. When I disabled all of the advanced
    features (Edge scrolling, and hot spots), all seems to be well again. But
    alas, yes, VPC does not support USB.....
    --
    Devon Cochenour
    MCSD, MCT MSF Master Trainer



     
    Devon Cochenour, Aug 23, 2006
    #12
  13. I use a usb mouse and keyboard with no issues. They are seen by virtual
    machines as PS/2 devices.

     
    Colin Barnhorst, Aug 23, 2006
    #13
  14. AC [MVP MCMS]

    AC [MVP] Guest

    Ah... the D820 doesn't come with one... just a standard and simple Alps Touchpad
    (no edge scrollers or special features). I prefer it that way :)

    -AC [MVP MCMS]
    www.andrewconnell.com
     
    AC [MVP], Aug 24, 2006
    #14
  15. AC [MVP MCMS]

    Paul Adare Guest

    Since I'm working on a D820 at the moment with edge scrolling enabled,
    I can assure you that it does have these features.

    --
    Paul Adare - MVP Virtual Machines
    It all began with Adam. He was the first man to tell a joke--or a lie.
    How lucky Adam was. He knew when he said a good thing, nobody had said
    it before. Adam was not alone in the Garden of Eden, however, and does
    not deserve all the credit; much is due to Eve, the first woman, and
    Satan, the first consultant." - Mark Twain
     
    Paul Adare, Aug 24, 2006
    #15
  16. AC [MVP MCMS]

    AC [MVP] Guest

    OK, let me make sure I know what I'm talking about then. Edge scrolling is
    when the touchpad has the ability on the right & bottom to act as the wheel
    on a mouse... correct?

    My D820 can't do that (I got the fingerprint reader too, so I wonder if that
    affected it) as it doesn't have the lines on the right/bottom of the touchpad.

    Regardless... how do VPC's on your D820 run? Any issues?

    -AC [MVP MCMS]
    www.andrewconnell.com
     
    AC [MVP], Aug 24, 2006
    #16
  17. Hello everybody,

    I would like to add a new aspect to the discussion: we are experiencing a
    problem on two new notebooks (DELL M65) which has the same behaviour as you
    describe here. We have contacted DELL support and they proposed to switch off
    speedstep and multicore support in BIOS - or to choose another VM software
    (they assume that Virtual PC does not support multicore).

    I would like to ask the experts here for your opinion. Looking forward to
    any feedback.

    Kind Regards,
    Peter






     
    Peter Schwindling, Aug 24, 2006
    #17
  18. No, I am running it WITH the speed step on, with the dual core and the VPC is
    fast. With my dell the things I had to do to get it to run were....

    rebuilt the box to get rid of the 270 drivers that came preinstalled.
    Install the speed switch software.
    I disabled the Bluetooth capabilities since the drivers were not signed by MS
    I disabled the advanced features of my touch pad. On my box these are called
    Gestures, Tap Zones, EdgeMotion, and Scrolling (this was the one that I think
    was causing the issue). Scrolling is where the right side and bottom of the
    touch pad allow you to scroll like a wheel on a mouse. After I disabled that,
    no more issues.

    --
    Devon Cochenour
    MCSD, MCT MSF Master Trainer



     
    Devon Cochenour, Aug 24, 2006
    #18
  19. I disabled my ThinkPad R52's touchpad due to the Synaptics drivers
    constantly using CPU/IO cycles (as reported by sysinternals.com's
    Process Explorer).

    I successfully use a USB mouse with my ThinkPad, but not the touchpad
    (just the ThinkPad pointer.)
     
    Matthew Chestnut, Aug 24, 2006
    #19
  20. I run VS and VPC on dual-core systems without issues. Perhaps your issue is
    not related to that.

     
    Colin Barnhorst, Aug 24, 2006
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.