VPN connects but does not browse

Discussion in 'Windows Small Business Server' started by Jay Hova, Aug 18, 2005.

  1. Jay Hova

    Jay Hova Guest

    I have a share on a server that I am trying to connect to but I can't browse
    to it. I don't see any of the other computers on the network. How can I
    troubleshoot this
     
    Jay Hova, Aug 18, 2005
    #1
    1. Advertisements

  2. Jay Hova

    Joe Guest

    Join your computer to the domain. That's what domain security is for.
     
    Joe, Aug 18, 2005
    #2
    1. Advertisements

  3. Jay Hova

    Jay Hova Guest

    I can't contact the domain controller

     
    Jay Hova, Aug 19, 2005
    #3
  4. In
    Browsing across a VPN (or any routed connection) is not a simple matter. Do
    you actually need to browse? Can you resolve the computer names to IPs and
    ping them/connect to them using \\computername ?

    If you must browse, make sure you have WINS running properly, your remote
    computer is using the WINS server IP and is registered in the WINS database,
    and NetBIOS over TCP/IP is enabled. However, there's never any guarantee
    that this will work flawlessly. Usually, VPN users don't need to browse -
    they can connect to shares directly. What is it you wish to use your VPN
    access for, exactly?
     
    Lanwench [MVP - Exchange], Aug 19, 2005
    #4
  5. In
    You don't need to join your computer to the domain (and that is not related
    to browsing anyway). However, if you can't contact the domain controller,
    you have some larger connectivity problems. Can you ping it by its LAN IP?
    By name?
     
    Lanwench [MVP - Exchange], Aug 19, 2005
    #5
  6. Jay Hova

    Jay Hova Guest

    ok here is the weird thing. It just started working. Before my connection at
    the server would start and connect just fine then I would get no response
    after 300+ bytes. That is to say I could go on the connection statistics and
    I would see bytes sent and received a the bytes received would be somewhere
    just over 300. Now for some reason it just started working. Before I was
    unable to browse if I did a search for a computer I would be unable to find
    it. Now everything works just like I would expect it to work. How should I
    diagnose this?
     
    Jay Hova, Aug 19, 2005
    #6
  7. In
    Browsing and searching aren't the same thing, though.

    I think you have some connectivity problems - latency in the line, who
    knows. You might want to post in a networking group for more info (and tell
    them what kind of VPN you use, as you haven't specified it here). Also
    mention whether anyone else has the same issue....
     
    Lanwench [MVP - Exchange], Aug 19, 2005
    #7
  8. Jay Hova

    Jay Hova Guest

    Ok, now that I have checked it and made sure it works from my home machine I
    am trying to remote in from china. I have a client there who is trying to
    connect to the VPN. Now, I have verified that he is connected and is not
    having the weird problem I was. Now I can ping the server and resolve a host
    name from my home computer but my client can't. I have tried both name and IP
    resolution with no luck. is there anything else I can do?
     
    Jay Hova, Aug 19, 2005
    #8
  9. Jay Hova

    Joe Guest

    That's why I always suggest joining the domain. I've never seen any
    trouble then, and I've never achieved consistent results any other way.
    I've tried most suggested juju involving lmhosts and other files, though
    possibly I haven't sacrificed the right animals.

    There are default measures in place to protect the LAN from rogue VPN
    connections, and simply withholding cooperation in network browsing is
    easy to do. I assume it is done.
     
    Joe, Aug 19, 2005
    #9
  10. Jay Hova

    Joe Guest

    I was replying specifically to Lanwench there, I thought she had picked
    up your problem.

    So can you ping the server by IP address and by name, every time you
    connect? If not, there are basic networking problems that must be solved
    before you can get any further.

    Sudden thought: I have a feeling that joining the domain is one of the
    few occasions where you must use the full domain name i.e. it must be
    in servername.yourdomain.local form rather than just servername. I
    think that you do indeed get the 'DC cannot be found' if you don't. It's
    quite a while since I did this, but it is definitely possible to open
    a VPN as an outsider and join the domain over the VPN (given domain
    admin credentials). After that you need to reboot and from then on you
    can select to logon to the domain rather than your local machine, and
    you can select to do so over a network connection.

    I rarely do this as my XP Pro machine normally runs as part of a
    workgroup, with fast user switching, and you need to reboot after
    switching to or from a domain logon. I can't remember the last time I
    needed full domain facilities on a client's network from home. RWW and
    TSWeb do everything I routinely need. But my main client's two remote
    users always use a domain logon and I would hear very quickly if they
    ever had trouble reaching things.
     
    Joe, Aug 20, 2005
    #10
  11. Jay Hova

    Jay Hova Guest

    I am unable to ping either the IP or the hostname of the server. However I do
    get a VPN connection. What I can't figure out is what sort of network problem
    would allow me to establish a VPN but not allow it to work. Again I can now
    do this from my home PC just fine.
     
    Jay Hova, Aug 21, 2005
    #11
  12. Jay Hova

    Joe Guest

    By far the most common cause is that protocol 47 (GRE) is being stopped
    somewhere. The PPTP VPN has two components, the link control and other
    housekeeping over TCP port 1723, and the actual data over GRE. The VPN
    will be reported as connected with just the TCP/1723 part working, even
    if no data can pass.

    As to why, presumably either a firewall or an ISP involved is blocking
    the protocol. You should not need to open anything on the client machine
    or firewall at that end.
     
    Joe, Aug 21, 2005
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.